Bug 118135 - Unnamed Impress slides should be given meaningful names for PDF Indexes/Bookmarks based on their titles
Summary: Unnamed Impress slides should be given meaningful names for PDF Indexes/Bookm...
Status: RESOLVED DUPLICATE of bug 118136
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
6.0.4.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
: 131373 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-06-13 03:45 UTC by Explorer09
Modified: 2020-06-19 15:09 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample presentation created when following "Steps to Reproduce" (67.58 KB, application/vnd.oasis.opendocument.presentation)
2018-06-25 09:17 UTC, Explorer09
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Explorer09 2018-06-13 03:45:10 UTC
Description:
This is a feature request for usability.

The "Slides" -> "Rename slides" feature is seldom used in my workflow in crafting a presentation. For now I don't know the practical uses of such slide names (are they identifiers for scripts/machine codes, or are they meant for remarks for humans?), but one thing does irritate me.

When the slides are exported to PDF, these unnamed slides would be given placeholder names like "Slide 1", "Slide 2" etc. (locale-specific), and they would become names for "Indexes"/"Bookmarks" in PDF, despite the slides already having titles that can give a better index during export.

An example use case is described in "Steps to Reproduce" below.

Steps to Reproduce:
1. In LibreOffice Impress, create a new, blank presentation.
2. Make four slides (Press Ctrl-M three times).
3. Edit the titles in the *contents* of four slides so they are "Foo", "Bar", "Baz" and "Baz" respectively.
4. Select the second slide, use "Slides" -> "Rename slides" to name it "Barred"
5. Export this presentation to PDF
6. Open the PDF in Adobe Reader, Evince or whatever PDF viewer you have.

Actual Results:  
If you show the "Bookmarks" in Adobe Reader, or "Index" in Evince's side pane, you see they are marked "Slide 1", "Barred", "Slide 3" and "Slide 4" respectively (name varied on your LibreOffice language).

Expected Results:
The "Bookmarks" or "Index" names would be "Foo", "Barred", "Baz", "Baz (2)" respectively (if the bookmark names don't allow collision).


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0
Comment 1 Heiko Tietze 2018-06-25 08:36:03 UTC
Cannot confirm this problem. Slide 1..n works well as default names, and renaming to Foo, Bar, Baz, Qux produces a PDF with exactly these slide names. 

(In reply to Explorer09 from comment #0)
> 3. Edit the titles in the *contents* of four slides so they are "Foo",
> "Bar", "Baz" and "Baz" respectively.

Maybe there is a misunderstanding, at least I don't get "contents". If you talk about the slide *title* it's a different property than the slide *name*
Comment 2 Explorer09 2018-06-25 09:17:23 UTC
Created attachment 143091 [details]
Sample presentation created when following "Steps to Reproduce"
Comment 3 Explorer09 2018-06-25 09:31:25 UTC
(In reply to Heiko Tietze from comment #1)
> Cannot confirm this problem. Slide 1..n works well as default names, and
> renaming to Foo, Bar, Baz, Qux produces a PDF with exactly these slide
> names. 
> 

I forgot to mention that bug 118136 is related to this one, in that's two symptoms that might have the same root cause.

The problem of 118135 is that exporting a PDF with "Slide 1", "Slide 2" etc. (placeholder slide names) as their bookmarks are meaningless.

Either give meaningful names for PDF bookmarks, or don't make bookmarks for those unnamed slides.

> (In reply to Explorer09 from comment #0)
> > 3. Edit the titles in the *contents* of four slides so they are "Foo",
> > "Bar", "Baz" and "Baz" respectively.
> 
> Maybe there is a misunderstanding, at least I don't get "contents". If you
> talk about the slide *title* it's a different property than the slide *name*

I meant the title text of each slide. The text you write in the "Click to add title" text fields.
I think most users don't realize the "slide name" concept and its difference from the "title". For me, I'll just write the titles and ensure they're almost unique among the slides (for convenience of audience and readers). With that in mind, I expect I never need to care about slide "names" at all and expect Impress generate reasonable names for me. And that PDF bookmarks give quick outline of the whole presentation. Saving my time of naming each bookmark individually.
Comment 4 Timur 2018-06-25 12:05:08 UTC
I'll mark as a duplicate of a bug 107932 because you mention contents.
Please also see Bug 95193.

*** This bug has been marked as a duplicate of bug 107932 ***
Comment 5 Heiko Tietze 2020-06-16 16:04:25 UTC
*** Bug 131373 has been marked as a duplicate of this bug. ***
Comment 6 Heiko Tietze 2020-06-16 16:05:41 UTC
Reopening as there are more requests. Any opinion?
Comment 7 Heiko Tietze 2020-06-19 14:59:35 UTC
Taking the other ticket as reference because of the broader discussion.

*** This bug has been marked as a duplicate of bug 118136 ***