Bug 118138 - Last used color part of background color split button not working correctly
Summary: Last used color part of background color split button not working correctly
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Maxim Monastirsky
URL:
Whiteboard: target:6.2.0 target:6.1.0.1
Keywords: bibisected, bisected, regression
: 118524 (view as bug list)
Depends on:
Blocks: Split-Group-Buttons-Color
  Show dependency treegraph
 
Reported: 2018-06-13 09:36 UTC by Yousuf Philips (jay) (retired)
Modified: 2018-07-03 13:32 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2018-06-13 09:36:45 UTC
steps:
1. open calc
2. select a few cells
3. click the button portion of the background color split button to apply yellow
4. click it again and the yellow will be removed.

regression as not in 6.0

Version: 6.2.0.0.alpha0+
Build ID: f7e0297b01f739e17f2f9517bf3d89baaee654ab
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group threaded
Comment 1 Xisco Faulí 2018-06-13 09:50:08 UTC
Regression introduced by:

author	Daniel <danielfaleirosilva@gmail.com>	2018-03-24 00:13:26 -0300
committer	Samuel Mehrbrodt <Samuel.Mehrbrodt@cib.de>	2018-03-28 08:57:51 +0200
commit	bdd7abf56676732f8ce4fd04bea5c72758f1ec3b (patch)
tree	0fa318b0f9a67a62055abda66b3301766140a17b
parent	1c1160967acf49cffae8921f3ab8361821bbaaaf (diff)
tdf#63438 Toggle highlight color to no fill if the same value is active

Bisected with: bibisect-linux64-6.1

Adding Cc: to Daniel
Comment 2 Xisco Faulí 2018-06-13 09:59:07 UTC
after
https://cgit.freedesktop.org/libreoffice/core/commit/?id=bdd7abf56676732f8ce4fd04bea5c72758f1ec3b,
it seems it's the correct behaviour now. See bug 63438
Closing as RESOLVED WONTFIX
Comment 3 Yousuf Philips (jay) (retired) 2018-06-13 19:39:25 UTC
This bug report is about background color and not highlight color, which bug 63438 was to fix.
Comment 4 Commit Notification 2018-06-24 23:55:20 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2fd31c75b677b145cf56404348857e60befcabff

tdf#117987 tdf#118138 Compare with the currently used color

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2018-06-25 13:16:05 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=415368daf3047a6dfb2577822a72f65df7374df8&h=libreoffice-6-1

tdf#117987 tdf#118138 Compare with the currently used color

It will be available in 6.1.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Xisco Faulí 2018-06-26 10:01:39 UTC
Verified in

Version: 6.2.0.0.alpha0+
Build ID: 2dac65c50481684863433d67999c0ecf81c67e6b
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded

@Maxim Monastirsky, thanks for fixing this!!!
Comment 7 Xisco Faulí 2018-07-03 13:32:22 UTC
*** Bug 118524 has been marked as a duplicate of this bug. ***