Download it now!
Bug 63438 - Toggle highlight color to no fill if the same value is active
Summary: Toggle highlight color to no fill if the same value is active
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: target:6.1.0
Keywords: difficultyInteresting, easyHack, needUITest, skillCpp
: 81187 (view as bug list)
Depends on:
Blocks: Highlight-Color-Button
  Show dependency treegraph
 
Reported: 2013-04-11 17:19 UTC by Pablo San Martín
Modified: 2018-06-13 10:00 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pablo San Martín 2013-04-11 17:19:40 UTC
It would be great that when you prompt the command "highlight" over a text already highlighted with the same colour, the highlighting would be deleted. This would make it much easier for users reading long files in fullscreen mode and highlighting with a shortcut, and would avoid setting the "No fill" option on and off after and before de-highlighting a passage.
Comment 1 A (Andy) 2013-04-20 10:38:14 UTC
marked as enhancement request
Comment 2 Neutrino 2013-09-22 14:57:02 UTC
For two reasons I'd have thought the fact that it doesn't do this already would actually be a bug and not an enhancement request.

1) The whole point of the highlighting feature is to be able to easily highlight and unhighlight sections of text, and currently there is no way to unhighlight text at all without resetting your configured highlight colour to No Fill, which is obviously extremely unhelpful as it obliges you to have to manually reapply your preferred highlight colour every single time you unhighlight something.

2) Clicking Highlight again to unhighlight is the way all other word processors support this feature and there is no reason why Libre Office should implement this any differently.

Recategorized as normal severity Bug.
Comment 3 QA Administrators 2015-04-01 14:41:11 UTC Comment hidden (obsolete)
Comment 4 Pablo San Martín 2015-04-01 15:21:27 UTC
The bug is still present in LibreOffice 4.4.2.2 run in Lubuntu 14.04.
Comment 5 tommy27 2016-04-16 07:23:52 UTC Comment hidden (obsolete)
Comment 6 Pablo San Martín 2016-05-31 14:16:47 UTC
The bug is still present in LibreOffice 5 run in Xubuntu 16.04.
Comment 7 QA Administrators 2017-09-01 11:16:57 UTC Comment hidden (obsolete)
Comment 8 Pablo San Martín 2017-09-01 11:29:57 UTC
Still present on 5.1.6.2 running on Kubuntu 16.04.
Comment 9 Heiko Tietze 2018-02-21 09:25:11 UTC
So you are talking about a character style and not direct formatting? But anyway, I object the idea to temporarily unapply properties and suggest you format the documents in a way that it can be read easily.
Comment 10 Pablo San Martín 2018-02-21 09:30:05 UTC
I'm not sure you are understanding the issue. What info do you need? Would screenshots help?
Comment 11 Pablo San Martín 2018-02-21 09:33:19 UTC
We want highlighting to behave like italics or bold. 

If you press Ctrl+I in a text in italics, it turns back to normal. 

Why cant a text highlighted with, say, Ctrl+H can't behave in the same way?
Comment 12 Heiko Tietze 2018-02-21 10:11:34 UTC
(In reply to Pablo San Martín from comment #11)
> We want highlighting to behave like italics or bold. 

Then it's a WONTFIX. See bug 108751 comment 19.

In a nutshell, by making the color functions a toggle buttons we loose the ability to apply a color to many objects. You can use a character style with highlighting attributes and another with no fill, and switch quickly with find & replace. Ctrl+M is another way to quickly get rid of the highlighting if you work with direct formatting.
Comment 13 Pablo San Martín 2018-02-21 10:17:53 UTC
(In reply to Heiko Tietze from comment #12)

> Then it's a WONTFIX. See bug 108751 comment 19.

I'm not asking to "update the font color and highlight color icons based on current focus in the text".

But rather: "Only when and if the current highlight colour and the existing highlighting is the same, when running the command "highlight" it should "de-highlight"."

Is that also a WONTFIX?
Comment 14 Pablo San Martín 2018-02-21 10:20:20 UTC
Sorry, it wasn't so clear: "When and if the current highlight colour is the same as that of the selected (and already highlighted) passage, running the command "highlight" it should "de-highlight" it."
Comment 15 Pablo San Martín 2018-02-21 10:22:55 UTC
Ctrl+M works, thanks! But it's really not that intuitive, as italics and bold are.
Comment 16 Heiko Tietze 2018-02-21 10:26:08 UTC
(In reply to Pablo San Martín from comment #14)
> Sorry, it wasn't so clear: "When and if the current highlight colour is the
> same as that of the selected (and already highlighted) passage, running the
> command "highlight" it should "de-highlight" it."

Yes, that makes sense. Adjusted the summary accordingly.
Comment 17 Thomas Lendo 2018-02-25 20:26:56 UTC
Set back to enhancement as it worked till now as intended by the devs.

I like and support the idea of de-highlithing the selected area/text if it's the same as the last applied color (which is shown as color in the button). If a part of the selection is not highlighted in this color, clicking the button should highlight it as it does now.

This would simplify the workflow for many users. Ctrl+M is not intuitive for most users as they don't know the difference between direct (hard) and style (soft) formatting. Hope that not too many users are confused/disturbed with the behavior change.
Comment 18 Heiko Tietze 2018-02-26 08:28:20 UTC
SvxColorToolBoxControl is defined in include/svx/tbcontrl.hxx (with a short README) and svx/source/tbxctrls/tbcontrl.cxx
Comment 19 Thomas Lendo 2018-02-26 11:00:34 UTC
Just for information:
MSO 2013 behaves as it is desired in this bug report. Clicking twice at the text highlight color button adds (first click) and removes (second click) the color. But this effect doesn't exist for the font color.
Comment 20 Commit Notification 2018-03-28 06:58:46 UTC
Daniel committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bdd7abf56676732f8ce4fd04bea5c72758f1ec3b

tdf#63438 Toggle highlight color to no fill if the same value is active

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 21 Thomas Lendo 2018-04-03 13:59:04 UTC
Verified with
Version: 6.1.0.0.alpha0+ (x64)
Build ID: 8e0eb015e74775b9bf02326ffd7b67e83ad6c60d
CPU threads: 8; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-04-03_03:53:38
Locale: de-AT (de_AT); Calc: CL

Thanks for the patch, Daniel!
Comment 22 Maxim Monastirsky 2018-05-08 19:30:03 UTC
*** Bug 81187 has been marked as a duplicate of this bug. ***