Download it now!
Bug 118157 - FILEOPEN Padding within text box in DOCX is incorrect
Summary: FILEOPEN Padding within text box in DOCX is incorrect
Status: RESOLVED DUPLICATE of bug 124600
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX-Textbox
  Show dependency treegraph
 
Reported: 2018-06-14 09:08 UTC by Aron Budea
Modified: 2019-10-08 14:54 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample DOCX (15.87 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-06-14 09:08 UTC, Aron Budea
Details
Comparison screenshot (Word - Writer) (101.75 KB, image/png)
2018-06-14 09:09 UTC, Aron Budea
Details
Sample DOCX (table in text box) (19.33 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-06-14 09:24 UTC, Aron Budea
Details
Comparison screenshot of table in text box (Word - Writer) (57.81 KB, image/png)
2018-06-14 09:25 UTC, Aron Budea
Details
Result in LO 6.1 (89.78 KB, image/jpeg)
2018-06-14 14:18 UTC, Dieter
Details
Screenshot of the example files in Writer (88.15 KB, image/png)
2019-10-08 14:52 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2018-06-14 09:08:39 UTC
Created attachment 142721 [details]
Sample DOCX

Open attached DOCX in Writer. It contains a piece of justified text in a text box.
In Writer the left and right padding isn't equal.

Observed using LO 6.2 daily build (c3e552ac25be001a623469c549ee8d0719b98133) / Windows 7.
In 6.0.0.3 the padding is wrong in a different way, text is shifted to the left instead of the right.
In earlier versions it's again wrong in a different way, e.g in 4.4.0.3 the text starts a bit outside the shape.
In 4.0.0.3 the padding looks right, but at this point it's imported as a frame, while in 4.4.0.3 it's imported as a text box, so the bug was introduced when the text box import was rewritten.
Comment 1 Aron Budea 2018-06-14 09:09:22 UTC
Created attachment 142722 [details]
Comparison screenshot (Word - Writer)
Comment 2 Aron Budea 2018-06-14 09:24:50 UTC
Created attachment 142723 [details]
Sample DOCX (table in text box)

Here's an interesting sample that probably stems from the same issue, it contains a table within the text box that has 'Indent from left' set to 0.1".
In Word the table's left border overlaps the text box's border.
In Writer it starts within the text box, likely due to the increased left padding.
Comment 3 Aron Budea 2018-06-14 09:25:22 UTC
Created attachment 142724 [details]
Comparison screenshot of table in text box (Word - Writer)
Comment 4 Dieter 2018-06-14 14:18:35 UTC
Created attachment 142738 [details]
Result in LO 6.1

I confirm it with

Version: 6.1.0.0.beta1 (x64)
Build ID: 8c76dfe1284e211954c30f219b3a38dcdd82f8a0
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
Locale: en-US (de_DE); Calc: CL

althoug the difference between left and right spacing is minimal.
Comment 5 Aron Budea 2019-03-01 11:07:16 UTC
Still in 6.3.0.0.alpha0+ (140fd0a1b1da1b0b14bda17c926dd8f95750ba92) / Windows 7.
Comment 6 NISZ LibreOffice Team 2019-10-08 14:52:59 UTC
Created attachment 154842 [details]
Screenshot of the example files in Writer

These started to look good recently since:

Version: 6.4.0.0.alpha0+ (x64)
Build ID: ff5f02b9282e19a2a8a68604c588e9487021b0b5
CPU threads: 4; OS: Windows 6.3; UI render: default; VCL: win; 
Locale: hu-HU (hu_HU); UI-Language: en-US
Calc: threaded

https://gerrit.libreoffice.org/plugins/gitiles/core/+/ff5f02b9282e19a2a8a68604c588e9487021b0b5

author
Miklos Vajna <vmiklos@collabora.com> Tue Sep 17 17:08:02 2019 +0200 
committer
Miklos Vajna <vmiklos@collabora.com> Tue Sep 17 17:53:56 2019 +0200 
Related: tdf#124600 sw textbox: sync left/right margin of shape to textbox
Comment 7 NISZ LibreOffice Team 2019-10-08 14:54:58 UTC
Let's mark this as duplicate for simplicity.

*** This bug has been marked as a duplicate of bug 124600 ***