Bug Hunting Session
Bug 124600 - FILEOPEN DOCX: Wrong textbox alignment and spacing
Summary: FILEOPEN DOCX: Wrong textbox alignment and spacing
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.2.2 release
Hardware: All All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:6.4.0 target:6.3.3 target:6.2.8
Keywords: filter:docx
: 118157 (view as bug list)
Depends on:
Blocks: DOCX-Textbox
  Show dependency treegraph
 
Reported: 2019-04-08 06:32 UTC by Patrick Jaap
Modified: 2019-10-09 10:12 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
sample docx (437.21 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-04-08 06:33 UTC, Patrick Jaap
Details
LO.pdf LibreOffice rendering (73.95 KB, application/pdf)
2019-04-08 06:33 UTC, Patrick Jaap
Details
MSO.pdf Office rendering (73.84 KB, application/pdf)
2019-04-08 06:34 UTC, Patrick Jaap
Details
PDF export in current master (59.71 KB, application/pdf)
2019-09-26 15:49 UTC, Patrick Jaap
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Jaap 2019-04-08 06:32:33 UTC
Description:
In the sample document there are 3 problems with wrong spacing of the textboxes. They seem to be wrong positioned and cause an additional text break.
See comparison of MSO and LO (PDFs)

Steps to Reproduce:
1. Open the sample document :)

Actual Results:
see LO.pdf

Expected Results:
see MSO.pdf


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Patrick Jaap 2019-04-08 06:33:05 UTC
Created attachment 150593 [details]
sample docx
Comment 2 Patrick Jaap 2019-04-08 06:33:55 UTC
Created attachment 150594 [details]
LO.pdf LibreOffice rendering
Comment 3 Patrick Jaap 2019-04-08 06:34:19 UTC
Created attachment 150595 [details]
MSO.pdf Office rendering
Comment 4 Durgapriyanka 2019-04-08 15:06:27 UTC
Thank you for reporting the bug. I can confirm the bug present in 

Version: 6.1.3.2
Build ID: 86daf60bf00efa86ad547e59e09d6bb77c699acb
CPU threads: 2; OS: Windows 6.1; UI render: default; 
Locale: en-US (en_US); Calc: group threaded

and

Version: 6.3.0.0.alpha0+
Build ID: b6b28931435e44aca92b8c0e1659f701e3ed1a87
CPU threads: 2; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-01-30_06:57:04
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded
Comment 5 Buovjaga 2019-04-09 18:06:15 UTC
Same result with 5.0.2. In older versions it was much worse.

Patrick: normally we would split this into different reports, but perhaps you want to hack on all the problems yourself in a series of commit.
Comment 6 BogdanB 2019-04-10 15:13:40 UTC
Confirm it in 
Version: 6.3.0.0.alpha0+
Build ID: 84d4125b28c384f9ac6285737a5bb9093978798e
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-04-06_20:07:58
Locale: ro-RO (ro_RO.UTF-8); UI-Language: en-US
Calc: threaded
Comment 7 Commit Notification 2019-09-17 10:37:23 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/4883da6fd25e4645a3b30cb58212a2f666dae75a%5E%21

Related: tdf#124600 DOCX import: ignore left wrap on left-aligned shapes

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2019-09-17 15:55:20 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/ff5f02b9282e19a2a8a68604c588e9487021b0b5%5E%21

Related: tdf#124600 sw textbox: sync left/right margin of shape to textbox

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2019-09-18 17:25:27 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/c3940a9fb2de7ba09f7d82497491918fd9bb3d0e

Related: tdf#124600 sw anchored object allow overlap: add doc model

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2019-09-19 11:42:38 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/ab825c665c1ee509769bdaf0ae95fc111a357fc6

Related: tdf#124600 sw anchored object allow overlap: add UNO API

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2019-09-19 16:32:39 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/d37096f59e7e0286e55008153591a60bab92b9e8

Related: tdf#124600 sw anchored object allow overlap: add layout

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2019-09-20 10:43:21 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/f8c7a2284b88c149addc8a30abb0cad8a10dad77

Related: tdf#124600 sw anchored object allow overlap: add DOCX filter

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2019-09-24 08:57:16 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/acfb28d572201396bbe60e3824ccab28567d6a74

tdf#124600 sw AddVerticalFrameOffsets: fix bad wrap of half-intersecting frame

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2019-09-24 14:17:52 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/ac7047f72087f09f2ab223f1af2518778382c06a

Related: tdf#124600 sw anchored object allow overlap: wrap-through handling

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Miklos Vajna 2019-09-24 14:20:22 UTC
I think the import result of the bugdoc now matches the Word one on master.
Comment 16 Commit Notification 2019-09-24 16:46:37 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/a5698f1a0fb8bf8775f1a098ae9ee09de968d632

Related: tdf#124600 sw anchored object allow overlap: add ODT filter

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2019-09-25 11:26:05 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/472535a4f8aa95a17d996e96a67df60e72df7b32

Related: tdf#124600 sw anchored object allow overlap: add UI

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Patrick Jaap 2019-09-26 15:49:00 UTC
Created attachment 154555 [details]
PDF export in current master

Hi! 

I tested the import filter patches and attached the current render result in master (commit 622a11cf60d9772d6f66ad99a6bd1ef0a3bacb4e).

As far as I can see, the mentioned bugs are indeed resolved. Thanks :)
Comment 19 Oliver Sander 2019-09-27 12:39:21 UTC
Thanks from me as well.  Can we get this backported to 6.3 or even 6.2?
Comment 20 Miklos Vajna 2019-09-30 08:41:53 UTC
Sure, I'll backport the two bugfixes to libreoffice-6-3 and libreoffice-6-2.
Comment 21 Commit Notification 2019-09-30 11:44:37 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/1d1f7bf0ffd04e16c2a64220e36aba95f3a519e5

Related: tdf#124600 DOCX import: ignore left wrap on left-aligned shapes

It will be available in 6.3.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 22 Commit Notification 2019-10-01 10:48:20 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/858ba31da42b8c9c0367bf20ebbeded74fe0165b

Related: tdf#124600 sw textbox: sync left/right margin of shape to textbox

It will be available in 6.3.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 23 Commit Notification 2019-10-03 09:06:49 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/commit/6de9cff1f918b6fc3ef58d9e080388c741e84b55

Related: tdf#124600 DOCX import: ignore left wrap on left-aligned shapes

It will be available in 6.2.9.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 24 Commit Notification 2019-10-04 07:17:57 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/commit/74fc3dd94adeaac750e4cea08281d912dc5a11ee

Related: tdf#124600 sw textbox: sync left/right margin of shape to textbox

It will be available in 6.2.9.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 25 Commit Notification 2019-10-08 10:08:40 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-6-2-8":

https://git.libreoffice.org/core/commit/f9ad3ce992f9d9d29384612759cb3f4533dbe134

Related: tdf#124600 DOCX import: ignore left wrap on left-aligned shapes

It will be available in 6.2.8.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 26 NISZ LibreOffice Team 2019-10-08 14:54:58 UTC
*** Bug 118157 has been marked as a duplicate of this bug. ***
Comment 27 Commit Notification 2019-10-09 10:12:15 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-6-2-8":

https://git.libreoffice.org/core/commit/f9c43356d7492d1c7a9d267f47d10e123fe4fe37

Related: tdf#124600 sw textbox: sync left/right margin of shape to textbox

It will be available in 6.2.8.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.