Download it now!
Bug 118314 - Remove "Input Method Status" menu option and implementation
Summary: Remove "Input Method Status" menu option and implementation
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: target:6.4.0
Keywords: difficultyBeginner, easyHack, skillCpp, topicCleanup
: 118852 (view as bug list)
Depends on:
Blocks: Main-Menu
  Show dependency treegraph
 
Reported: 2018-06-22 07:57 UTC by Heiko Tietze
Modified: 2019-09-04 08:22 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Julien Nabet 2018-06-22 08:22:20 UTC Comment hidden (obsolete)
Comment 2 Julien Nabet 2018-06-22 13:53:11 UTC Comment hidden (obsolete)
Comment 3 Commit Notification 2018-07-10 06:35:53 UTC
andreas kainz committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ab3e7a234fb6e55274159952743d6c937c7c3f7c

tdf#118314 menubar: remove ShowImeStatusWindow in menubars

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2018-07-10 06:38:16 UTC
andreas kainz committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=501bb68bbeee19e39e62947a479e273f9a85e6bd&h=libreoffice-6-1

tdf#118314 menubar: remove ShowImeStatusWindow in menubars

It will be available in 6.1.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2018-07-11 21:11:18 UTC
Adolfo Jayme Barrientos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=2af2ba2a19e62ec8463c0f8e6b3d2346e75e5bb2

tdf#118314 Delete help content related to obsolete “Input Method Status” feature
Comment 6 Commit Notification 2018-07-12 13:55:42 UTC
Adolfo Jayme Barrientos committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=e41b7db0240b8c99741ff699e0fc0d787b443bf4&h=libreoffice-6-1

tdf#118314 Delete help content related to obsolete “Input Method Status” feature
Comment 7 Adolfo Jayme 2018-07-21 22:45:57 UTC
*** Bug 118852 has been marked as a duplicate of this bug. ***
Comment 8 Xisco Faulí 2018-08-21 12:40:29 UTC
A polite ping to Heiko Tietze:
Is this bug fixed? if so, could you please close it as RESOLVED FIXED ? Otherwise, Could you please explain what's missing?
Thanks
Comment 9 andreas_k 2018-08-21 12:57:09 UTC
Help page should be removed to.
From ui it was removed.
Comment 10 Heiko Tietze 2018-08-21 13:42:31 UTC
Andreas dropped the UI access in https://gerrit.libreoffice.org/#/c/57185/, Adolfo removed the help in https://gerrit.libreoffice.org/57224. What's missing is to clean the code- what Tomaz wanted to do.
Comment 11 Xisco Faulí 2018-11-26 16:48:11 UTC
Dear Tomaz Vajngerl,
This bug has been in ASSIGNED status for more than 3 months without any
activity. Resetting it to NEW.
Please assigned it back to yourself if you're still working on this.
Comment 12 Xisco Faulí 2018-11-26 16:48:39 UTC
@Heiko, I guess we could turn this issue into an easyHack ?
Comment 13 andreas_k 2018-11-26 16:56:14 UTC
Help page and UI the function was removed, so it's "only" code cleanup missing.
Comment 14 Heiko Tietze 2018-12-04 10:33:45 UTC
Some code pointers based on SID_SHOW_IME_STATUS_WINDOW (there might be other relevant commands):

sfx2/source/appl/imestatuswindow.cxx
sfx2/source/appl/imestatuswindow.hxx

sfx2/source/appl/appserv.cxx
vcl/source/app/svapp.cxx
sfx2/sdi/sfx.sdi
sfx2/sfxsids.hrc
Comment 15 Commit Notification 2019-09-04 07:13:02 UTC
Szabolcs Toth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/5bfa8b8d5e1cf3cb572dbd91bf3b0cfcf29fb65a%5E%21

tdf#118314 Code clean up on imestatuswindow

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.