Download it now!
Bug 118402 - Needs ellipsis: "New > Templates"
Summary: Needs ellipsis: "New > Templates"
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.2.7.2 release
Hardware: All All
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard: target:6.2.0
Keywords: difficultyBeginner, easyHack, skillDesign, topicDesign
Depends on:
Blocks:
 
Reported: 2018-06-27 01:49 UTC by Explorer09
Modified: 2018-07-20 11:09 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Explorer09 2018-06-27 01:49:33 UTC
Description:
In LibreOffice Impress, the File->Templates->"Manage Templates" menu item, and various buttons within the Manage Templates window, do not have ellipses on the texts. Many HIGs (Human Interface Guidelines) would require ellipses on controls that do not take immediate action but require additional options.

Steps to Reproduce:
1. Go to File->Templates->"Manage Templates"
2. See the "Move", "Export" and "Import" buttons on the bottom bar of the Templates window.
3. Click on the gear icon on the bottom left, and see "New category" and "Delete category" submenu items.

Actual Results:
All the mentioned button or menu item texts do not have ellipses on them:
1. "Manage Templates"
2. "Move", "Export" and "Import"
3. "New Category" and "Delete Category"

Expected Results:
The button or menu item text should be have ellipsis suffix, like:
1. "Manage Templates..."
2. "Move To...", "Export..." and "Import..."
3. "New Category..." and "Delete Category..."


Reproducible: Always


User Profile Reset: No



Additional Info:
Tested on:
* LibreOffice Impress 5.2.7.2 en-US locale
* LibreOffice Impress 6.0.5.2 zh-TW locale
Comment 1 Explorer09 2018-06-27 03:03:05 UTC
(In reply to Explorer09 from comment #0)
> Expected Results:
> The button or menu item text should be have ellipsis suffix, like:
> 1. "Manage Templates..."

I make a correction here. Adding ellipsis on File->Templates->"Manage Templates" might not look sensible (as it does not _require_ input on managing Impress templates). But a similar menu item, File->New->"Templates", may need ellipsis, so it becomes File->New->"Templates..."
Comment 2 Explorer09 2018-06-27 03:06:09 UTC
P.s. The item would be better to be named File->New->"New from a Template..."
Comment 3 mh rony 2018-06-27 07:18:46 UTC Comment hidden (obsolete)
Comment 4 Buovjaga 2018-06-28 10:04:00 UTC
Feedback on menus, so let's show to UX team
Comment 5 Heiko Tietze 2018-06-29 06:23:58 UTC
(In reply to Explorer09 from comment #1)
> I make a correction here. Adding ellipsis on File->Templates->"Manage
> Templates" might not look sensible (as it does not _require_ input on
> managing Impress templates). But a similar menu item,
> File->New->"Templates", may need ellipsis, so it becomes
> File->New->"Templates..."

That would have been my reply for Manage Templates. We shouldn't overdo ellipsis, otherwise the information becomes pointless - and that's why it makes sense in New because we indicate the difference to the other items.

This is a very simple easyhack (how to find the code pointer: https://design.blog.documentfoundation.org/2018/02/28/easyhacking-all-about-terminology/)
Comment 6 Abhyudaya Sharma 2018-07-15 12:37:25 UTC
I have posted a patch here: https://gerrit.libreoffice.org/#/c/56926/
Comment 7 Commit Notification 2018-07-20 11:09:03 UTC
Abhyudaya Sharma committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8544730f60b18ec25ed5ff2a939ffb8f1c425c03

tdf#118402 Add ellipsis to New -> Templates

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Heiko Tietze 2018-07-20 11:09:32 UTC
(In reply to Abhyudaya Sharma from comment #6)
> I have posted a patch here: https://gerrit.libreoffice.org/#/c/56926/

Thank you!