Bug 118496 - Equations in PowerPoint are badly imported
Summary: Equations in PowerPoint are badly imported
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.3 all versions
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: HarfBuzz-regressions
  Show dependency treegraph
 
Reported: 2018-07-02 00:22 UTC by Regina Henschel
Modified: 2019-07-04 11:03 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Equation in PowerPoint (18.94 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2018-07-02 00:22 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2018-07-02 00:22:41 UTC
Created attachment 143262 [details]
Equation in PowerPoint

Open attached document. You will see an equation which is shown as image and as formula. [The error that it is shown twice is tracked in bug 117658.] Move the image away and double-click the formula. You should get the Math editor. Look at the command window. On the left side you see a lot of brackets stacked. Depending on your installed fonts you might see "missing glyph" characters in the formula. They belong to the characters U+1d465 (x) and U+1d45b (n). Now replace these characters with the corresponding normal characters x and n. The brackets will be rendered as they should when you are finished.

Problems are:
The command window cannot properly handle this unicode range.
The glyphs of this range have an italic appearance by itself and they are put to italic by LibreOffice in addition. That looks not nice.
Many fonts incl. OpenSymbol, Liberation family, and Noto family do not have glyphs in that Unicode range.

The equation looks better in presentation mode. But here too the setting "italic" on the variable is ugly. If you use menu Format > Font and disable italic for Category Variable, you can see, that it looks better.

Expected: The formula renders nearly the same as shown in the image.
Comment 1 Telesto 2018-07-02 21:17:41 UTC
Repro
Version: 6.2.0.0.alpha0+
Build ID: 7e1cabd96526cb7befc5ea5073358093efbe12d0
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-06-27_23:39:20
Locale: nl-NL (nl_NL); Calc: CL
Comment 2 Xisco Faulí 2018-07-03 11:01:45 UTC
Only reproducible on Win.

Regression introduced by:

author	Khaled Hosny <khaledhosny@eglug.org>	2016-11-02 23:52:06 +0200
committer	Khaled Hosny <khaledhosny@eglug.org>	2016-11-03 00:17:06 +0000
commit	8f2dd1df1d6cc94ebbc1149de72bc6d6dffa6533 (patch)
tree	db496889434c484a87b13ffcc4650d65e6672129
parent	c8be45889217c555e4bec92af838d0524ceba4e0 (diff)
Revert "Revert "Enable the new text layout engine by default""

Bisected with: bibisect-win32-5.3

Adding Cc: to Khaled Hosny
Comment 3 QA Administrators 2019-07-04 02:47:00 UTC Comment hidden (obsolete)
Comment 4 Regina Henschel 2019-07-04 11:03:29 UTC
Tested with Version: 6.4.0.0.alpha0+ (x64)
Build ID: 9105b85c708f42024ce063b9a944466c0afdfe9a
CPU threads: 8; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-06-28_22:42:37
Locale: de-DE (en_US); UI-Language: en-US
Calc: threaded

The command window is OK now. The used fonts are still wrong. The source has for all parts "Cambria Math". But that is a more general problem, because LibreOffice does not put style information into its equation, but into the settings.