Download it now!
Bug 118563 - Base filename forgotten in save dialog when switching file format (kde4)
Summary: Base filename forgotten in save dialog when switching file format (kde4)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.1.0.1 rc
Hardware: All Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: kde4
Keywords:
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2018-07-06 00:17 UTC by sergio.callegari
Modified: 2019-01-01 19:29 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
no filename, no path (55.21 KB, image/png)
2018-07-13 09:19 UTC, Dr. Bernhard Friedrichs
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sergio.callegari 2018-07-06 00:17:25 UTC
Description:
If you open an ods file and then try to save it as xls, when you switch the file type, the file name field gets cleared. Insted it should keep the same base file name with the new extension as a preset.

Steps to Reproduce:
See description

Actual Results:
See description

Expected Results:
See description


Reproducible: Always


User Profile Reset: No



Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: SpreadsheetDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes
Comment 1 Dr. Bernhard Friedrichs 2018-07-13 09:19:52 UTC
Created attachment 143529 [details]
no filename, no path
Comment 2 Dr. Bernhard Friedrichs 2018-07-13 09:24:48 UTC
Same applies to pdf export.

Libreoffice does not show a filename, does forget the path.
Also the default folder "documents" is not set, starts in $HOME
Comment 3 Aron Budea 2018-07-19 00:40:40 UTC
Which Linux distribution / desktop environment are you using?
Comment 4 sergio.callegari 2018-07-19 07:45:19 UTC
Kubuntu Linux 18.04. Unable to reproduce anymore, something in my environment must have changed.
Comment 5 sergio.callegari 2018-07-22 16:23:02 UTC
Reproducing again. Not clear what triggers the issue.
Comment 6 Buovjaga 2018-07-22 18:24:11 UTC
NEW per Bernhard's comments.

Previously I've observed (with kde4 backend) that when changing filetype to some OOXML, it suddenly changes the file name to some random file from the same directory.

Would be interesting to keep an eye on this when kde5 backend gets into a usable state.
Comment 7 Buovjaga 2019-01-01 19:29:24 UTC
This is no longer a problem with the new kde5 backend.

Arch Linux 64-bit
Version: 6.3.0.0.alpha0+
Build ID: 2c7b0030b40de00e8c9ab997bdfe83631861968a
CPU threads: 8; OS: Linux 4.20; UI render: default; VCL: kde5; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 1 January 2019