Bug 118650 - UI: Calc - Insert/Delete Rows/Columns allowed even if document is read only
Summary: UI: Calc - Insert/Delete Rows/Columns allowed even if document is read only
Status: RESOLVED DUPLICATE of bug 114131
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.4.5.1 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-07-09 19:35 UTC by Jonathan Marten
Modified: 2018-07-09 20:09 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screen shot of enabled actions (32.31 KB, image/png)
2018-07-09 19:40 UTC, Jonathan Marten
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Marten 2018-07-09 19:35:33 UTC
Description:
These options are allowed (not greyed out) and work even if the spreadsheet document is read-only.  This only happens if a complete row is selected (in which case the two Insert Rows operations are allowed) or a complete column (in which case the two Insert Columns operations are allowed).


Steps to Reproduce:
1. Open a spreadsaheet and set it to read only mode.
2. Select a complete row (by clicking on the row number in the left margin).
3. Observe that the Sheet - Insert Rows - Rows Above and Rows Below menu actions are enabled and do the appropriate insertion when clicked.
4. Select a complete column.
5  Observe the same for Sheet - Insert Columns - Columns Left and Columns Right.


Actual Results:
Sheet is changed by inserting rows or columns.

Expected Results:
Either the menu actions should not be enabled, or the "Document opened in read-only mode" should be given.



Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 5.4.5.1
Build ID: Gentoo official package
CPU threads: 3; OS: Linux 4.12; UI render: default; VCL: gtk2; 
Locale: en-GB (en_GB.UTF-8); Calc: group
Comment 1 Jonathan Marten 2018-07-09 19:40:38 UTC
Created attachment 143405 [details]
Screen shot of enabled actions
Comment 2 Roman Kuznetsov 2018-07-09 20:09:36 UTC

*** This bug has been marked as a duplicate of bug 114131 ***