Bug 118669 - LibreOffice 6.0.3 - "update available" icon not visible on the Menu bar UI when update balloon activated
Summary: LibreOffice 6.0.3 - "update available" icon not visible on the Menu bar UI wh...
Status: RESOLVED DUPLICATE of bug 113205
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.0.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-07-10 14:41 UTC by rogue1618
Modified: 2018-07-11 08:41 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rogue1618 2018-07-10 14:41:31 UTC
Description:
Whenever an update was available, the icon for it was not visible, been like that for a few updates now.

Steps to Reproduce:
1. Start LibreOffice.
2. Get notice of an update being available but icon cannot be seen.
3. Can still click where the icon should be but have to guess where it is.

Actual Results:
I could still click where the icon should be but could not see it.

Expected Results:
Should be able to see the icon.


Reproducible: Always


User Profile Reset: No



Additional Info:
This might have to do with a recent Windows update. For a few weeks now when starting my PC after an Microsoft update, it takes some time before some of my menu icons are also visible. Not sure what Microsoft changed.
Comment 1 V Stuart Foote 2018-07-10 21:12:27 UTC
Confirmed on Windows 10 Ent 64-bit en-US with
Version: 6.0.3.2 (x64)
Build ID: 8f48d515416608e3a835360314dac7e47fd0b821
CPU threads: 8; OS: Windows 10.0; UI render: GL; 
Locale: en-US (en_US); Calc: CL

Clicking Help -> Check for Updates, enables the "LibreOffice update available" Balloon on the MenuBar, but no icon is shown on the button.

Looks like the Static definition of the bitmap/icon used by the createMenuBarUI used for the updatecheck needs a tweak. 

=-ref-=

https://opengrok.libreoffice.org/xref/core/extensions/source/update/check/updatecheck.cxx#184

https://opengrok.libreoffice.org/xref/core/extensions/source/update/ui/updatecheckui.cxx#79

https://opengrok.libreoffice.org/xref/core/extensions/inc/bitmaps.hlst#42
Comment 2 Xisco Faulí 2018-07-11 08:41:46 UTC
Thanks for reporting the issue.
This is a dupe of bug 113205

*** This bug has been marked as a duplicate of bug 113205 ***