Bug 113205 - Icon of updates button on right end of menu bar is not visible
Summary: Icon of updates button on right end of menu bar is not visible
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.4.0.0.alpha1+
Hardware: All All
: high major
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.3.0 target:6.2.1 target:6.1.5
Keywords: bibisected, bisected, regression
: 117396 118669 118815 121042 121941 (view as bug list)
Depends on:
Blocks: Updates
  Show dependency treegraph
 
Reported: 2017-10-17 21:23 UTC by sergio.callegari
Modified: 2019-04-08 13:08 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot showing the issue (9.90 KB, image/png)
2017-10-18 09:31 UTC, sergio.callegari
Details
Windows 7 invisible update icon (77.57 KB, image/jpeg)
2018-04-16 05:08 UTC, Guy Rouillier
Details
how the icon in previous versions (9.67 KB, image/png)
2018-06-20 18:37 UTC, Xisco Faulí
Details
Screenshot with 6.2.0.1 (53.05 KB, image/png)
2019-01-05 01:52 UTC, Mike Kaganski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sergio.callegari 2017-10-17 21:23:28 UTC
Description:
When an update to some extension is available, an alert is shown. An icon should appear in the top right corner of the LibO window.

Unfortunately, with LibO and the kde VCL this does not work as it should. A notification is shown, but there is no icon. As a matter of fact, the icon is there, just not visible. Hovering with the mouse on the top right corner of LibO makes a small frame appear together with the notification text.

Steps to Reproduce:
See description. It is impossible to reproduce the issue with user actions. An extension update should be available.

Actual Results:  
See description

Expected Results:
See description


Reproducible: Always

User Profile Reset: No

Additional Info:
[Information automatically included from LibreOffice]
Locale: en-US
Module: TextDocument
[Information guessed from browser]
OS: Linux (All)
OS is 64bit: yes
Builds ID: LibreOffice 5.4.2.2


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0
Comment 1 Xisco Faulí 2017-10-18 08:46:19 UTC
Could you please attach an screenshot ?
Comment 2 sergio.callegari 2017-10-18 09:31:58 UTC
Created attachment 137073 [details]
Screenshot showing the issue
Comment 3 sergio.callegari 2017-10-18 09:33:05 UTC
Screenshot has been provided. This is when you hover with the mouse, which gives you the notification and the small squared frame. Otherwise, nothing is shown at all.
Comment 4 sergio.callegari 2017-10-18 09:40:54 UTC
In fact, a regression in 5.4. Libreoffice 5.3 used to show the icon on my same platform.
Comment 5 Adolfo Jayme 2017-10-24 11:28:28 UTC
Confirmed under Windows.
Comment 6 sergio.callegari 2018-02-13 15:19:19 UTC
Still an issue in LibO 6.0.1 RC 1
Comment 7 sergio.callegari 2018-03-31 13:58:10 UTC
Still an issue as of 6.0.3.1
Comment 8 Guy Rouillier 2018-04-16 05:08:02 UTC
Created attachment 141386 [details]
Windows 7 invisible update icon
Comment 9 Guy Rouillier 2018-04-16 05:10:51 UTC
Having this issue on Windows 7 64-bit, running version 6.0.1.1 (x64).  Will attach screenshot. I'm seeing this issue in both Writer and Calc.
Comment 10 LigH 2018-04-20 07:05:38 UTC
Confirming for LO 6.0.21 reporting an update to 6.0.3 on Windows 7 SP1 x64 (German) with Java 1.8u162 and OpenGL acceleration enabled (GT1050Ti). Hovering the area displays the button frame.

The notification bubble on top of the application window also looks a bit strange, like missing its border on one side, and missing possible shadow effects.
Comment 11 sergio.callegari 2018-05-31 09:08:07 UTC
Bug is still present as of 6.1 beta.
The update reminder feature has been broken through 5.4, 6.0 and now it may remain broken through the 6.1 cycle too. May I suggest that the feature is temporarily hidden/disabled altogether for 6.1 until it can be fixed? IMHO, as is it is very confusing for users (who see a notification without knowing what it refers to) and gives a very poor impression of the application for a very little advantage.
Comment 12 Adolfo Jayme 2018-06-18 19:06:37 UTC
*** Bug 117396 has been marked as a duplicate of this bug. ***
Comment 13 Xisco Faulí 2018-06-20 18:20:59 UTC
I could 'bibisect' it with bibisect-linux-64-releases and it started in libreoffice-5.4.0.0.alpha1
Comment 14 Xisco Faulí 2018-06-20 18:30:16 UTC
@Andreas, @Heiko, would you mind checking if the icon still exists in the build system?
Comment 15 Xisco Faulí 2018-06-20 18:37:11 UTC
Created attachment 142978 [details]
how the icon in previous versions
Comment 17 Xisco Faulí 2018-07-11 08:41:46 UTC
*** Bug 118669 has been marked as a duplicate of this bug. ***
Comment 18 Xisco Faulí 2018-07-11 08:43:09 UTC
Nice comment with code pointer from V Stuart: https://bugs.documentfoundation.org/show_bug.cgi?id=118669#c1
Comment 19 V Stuart Foote 2018-07-11 12:51:02 UTC
(In reply to Xisco Faulí from comment #18)
> Nice comment with code pointer from V Stuart:
> https://bugs.documentfoundation.org/show_bug.cgi?id=118669#c1

I'll just add them here...

Clicking Help -> Check for Updates, enables the "LibreOffice update available" Balloon on the MenuBar, but no icon is shown on the button.

Looks like the Static definition of the bitmap/icon used by the createMenuBarUI used for the updatecheck needs a tweak. 

=-ref-=

https://opengrok.libreoffice.org/xref/core/extensions/source/update/check/updatecheck.cxx#184

https://opengrok.libreoffice.org/xref/core/extensions/source/update/ui/updatecheckui.cxx#79

https://opengrok.libreoffice.org/xref/core/extensions/inc/bitmaps.hlst#42
Comment 20 Buovjaga 2018-07-18 17:04:14 UTC
*** Bug 118815 has been marked as a duplicate of this bug. ***
Comment 21 Xisco Faulí 2018-10-31 15:19:21 UTC
*** Bug 121042 has been marked as a duplicate of this bug. ***
Comment 22 Xisco Faulí 2018-12-06 14:39:32 UTC
*** Bug 121941 has been marked as a duplicate of this bug. ***
Comment 23 andreas_k 2018-12-08 22:25:15 UTC
Ok the icons

extensions/source/update/ui/onlineupdate_16
extensions/source/update/ui/onlineupdate_26

are available in 

- breeze, breeze_dark, breeze_svg
- colibre, colibre_svg
- elementary, elementary_svg

where onlineupdate_26 is 24x24px and onlineupdate_16 is 16x16px

in karasa_jaga onlineupdate_26 is 66x21px and onlineupdate_16 is 44x13px
and in tango  onlineupdate_26 is 22x22px and onlineupdate_16 is 16x16px

in sifr, sifr_dark, sifr_svg and tango_svg the icons are missing.

so from my point of view I don't think it's an icon issue the issue is somewhere in the code.
Comment 24 V Stuart Foote 2018-12-09 07:01:07 UTC
(In reply to andreas_k from comment #23)
The bitmaps.hlst mapping suggests they should be in core/extensions/source/update/ui, but I don't see them there.

Otherwise, wouldn't they be better handled if moved to receive the same handling in all icon-themes?

From core/extensions/source/update/ui to core/icon-themes/<theme>/res
Comment 25 andreas_k 2018-12-11 13:13:45 UTC
(In reply to V Stuart Foote from comment #24)
> (In reply to andreas_k from comment #23)
> The bitmaps.hlst mapping suggests they should be in
> core/extensions/source/update/ui, but I don't see them there.
> 
> Otherwise, wouldn't they be better handled if moved to receive the same
> handling in all icon-themes?
> 
> From core/extensions/source/update/ui to core/icon-themes/<theme>/res

ah thanks stuart, I copy the colibre update icon into core/extensions/source/update/ui, but I recommend to use the icon theme related icons as you also suggested Stuart.
Comment 26 Heiko Tietze 2018-12-17 17:04:22 UTC
Sergio, please verify that this patch works.
Comment 27 Commit Notification 2018-12-17 17:04:32 UTC
andreas kainz committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/4f89c98d715592be42d8d378786d79eb27acadcb%5E%21

tdf#113205 add onlineupdate icons to core/extensions/source/update/ui

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 28 Commit Notification 2018-12-17 22:28:35 UTC
andreas kainz committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/8c7473e2998e13fc9c62aaa9ce9d7b536e81be57%5E%21

tdf#113205 add onlineupdate icons to core/extensions/source/update/ui

It will be available in 6.2.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 29 Mike Kaganski 2019-01-05 01:52:25 UTC
Created attachment 148051 [details]
Screenshot with 6.2.0.1

(In reply to Commit Notification from comment #28)
> It will be available in 6.2.0.1.

Still reproducible with Version: 6.2.0.1 (x64)
Build ID: 0412ee99e862f384c1106d0841a950c4cfaa9df1
CPU threads: 12; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: CL
Comment 30 Mike Kaganski 2019-01-05 02:01:06 UTC
The installed LibreOffice does not contain any "onlineupdate*.png". 

Using ProcMon, I can see that LibreOffice looks for %AppData%\LibreOffice\4\cache\colibre\100\extensions\source\update\ui\onlineupdate_16.png - with PATH NOT FOUND result (no "colibre" directory under "%AppData%\LibreOffice\4\cache" exists).
Comment 31 Mike Kaganski 2019-01-05 03:11:54 UTC
I couldn't grasp the packing machinery involved, but the pushed commits are clearly wrong, and what's missing is correct packing of the PNGs into the theme ZIPs. Adding the icons to the ZIP's extensions/source/update/ui/onlineupdate_NN.png fixes the problem.
Comment 32 Mike Kaganski 2019-01-05 03:28:54 UTC
Bibisected to https://git.libreoffice.org/core/+/816190b7b0f0cb75782cd12fe2cd908fdaf819fa using /bibisect-win32-5.4. Caolán, could you please take a look?
Comment 33 Caolán McNamara 2019-01-09 21:34:29 UTC
Hmm, I think the makefile rule in postprocess/CustomTarget_images.mk means that only images like these in a "res" subdir make their way into the zip file
Comment 34 Caolán McNamara 2019-01-10 09:24:06 UTC
https://cgit.freedesktop.org/libreoffice/core/commit/?id=5135a19c0cdc2937499e126dd5429eeb24a023a9

unzip -l instdir/share/config/images_breeze.zip |grep onlineupdate
      344  01-10-2019 09:15   extensions/res/update/ui/onlineupdate_16.png
      330  01-10-2019 09:15   extensions/res/update/ui/onlineupdate_26.png

that seems to do it

backport to 6.2 in gerrit, fixed in master
Comment 35 Mike Kaganski 2019-01-10 10:47:37 UTC
(In reply to Caolán McNamara from comment #34)

Thank you very much!
Do you think that previous commits should be reverted?
Comment 36 Caolán McNamara 2019-01-10 10:52:42 UTC
yeah, I'll take care of that now
Comment 37 Commit Notification 2019-01-10 11:12:56 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/9df951314107ba69efb820797b8b5f2918351952%5E%21

Resolves tdf#113205: move extension 'source' resources to 'res'

It will be available in 6.2.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 38 Commit Notification 2019-01-10 15:10:24 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/fa4507a7e59cb88f87392b1cb2513d0b62c32d8b%5E%21

Related: tdf#113205, revert add icons to extensions/source/update/ui

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 39 Xisco Faulí 2019-01-11 11:21:32 UTC
(In reply to Caolán McNamara from comment #36)
> yeah, I'll take care of that now

Cherry-picked to 6-2 as well -> https://gerrit.libreoffice.org/#/c/66160/

Any chance https://cgit.freedesktop.org/libreoffice/core/commit/?id=5135a19c0cdc2937499e126dd5429eeb24a023a9 could be cherry-picked to 6-1 ?
gerrit prompts as merge conflict
Comment 40 Caolán McNamara 2019-01-11 12:11:41 UTC
https://gerrit.libreoffice.org/#/c/66165/
Comment 41 Commit Notification 2019-01-11 16:14:31 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

https://git.libreoffice.org/core/+/f90139b70faf19beac1c4e812d67087502e27abf%5E%21

Resolves tdf#113205: move extension 'source' resources to 'res'

It will be available in 6.1.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 42 Commit Notification 2019-01-11 17:41:47 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/bbdd753f1e0155c483a554d3f28cbc3f1521105d%5E%21

Related: tdf#113205, revert add icons to extensions/source/update/ui

It will be available in 6.2.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 43 Harald Koester 2019-04-08 13:08:05 UTC
Verified with version 6.2.2 (64 bit, Win 10). Icon for extension update is now visible at the right end of the menu bar.