Download it now!
Bug 118688 - Filled form fields exported to PDF show as empty after converting to JPEG with ImageMagick
Summary: Filled form fields exported to PDF show as empty after converting to JPEG wit...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:pdf
Depends on:
Blocks: PDF-Export Fields
  Show dependency treegraph
 
Reported: 2018-07-11 09:32 UTC by Justin
Modified: 2019-12-10 03:59 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
ODT with form field (8.47 KB, application/vnd.oasis.opendocument.text)
2018-07-18 10:47 UTC, Buovjaga
Details
PDF export from the ODT, FDF form fields (3.26 KB, application/pdf)
2018-07-18 10:47 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Justin 2018-07-11 09:32:52 UTC
Description:
I have a odt file with filled form fields I want to export to pdf and later convert it to jpg with imagemagick.
The pdf still has the filled forms but later in the jpg the filled forms are empty. After finding this post: 
https://stackoverflow.com/questions/20156293/how-to-convert-a-pdf-with-a-filled-form-to-a-jpeg-image-using-imagemagick-and-pr I tried to safe the pdf with another programm and converting this pdf to jpg just worked as expected and the filled forms were kept.

Steps to Reproduce:
1. open a odt with form fields
2. fill the fields
3. export as pdf
4. try to convert the pdf to jpg with imagemagick

Actual Results:
In the jpg the filled forms are empty.

Expected Results:
The filled forms are also available in the jpg.


Reproducible: Always


User Profile Reset: No



Additional Info:
https://stackoverflow.com/questions/20156293/how-to-convert-a-pdf-with-a-filled-form-to-a-jpeg-image-using-imagemagick-and-pr

Possibly this helps finding the issue.
Comment 1 Xisco Faulí 2018-07-11 11:27:05 UTC
Thank you for reporting the bug.
it seems you're using an old version of LibreOffice.
Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 2 Justin 2018-07-11 11:52:22 UTC
Thanks for the answer.
I tested with the latest version and it still does not work.
Comment 3 Buovjaga 2018-07-18 10:47:26 UTC
Created attachment 143612 [details]
ODT with form field
Comment 4 Buovjaga 2018-07-18 10:47:55 UTC
Created attachment 143613 [details]
PDF export from the ODT, FDF form fields
Comment 5 Buovjaga 2018-07-18 10:49:33 UTC
I did

convert -colorspace CMYK -alpha off -interlace none -density 300x300 -quality 100 formfield-fdf.pdf formfield-fdf.jpg

after filling the form in Okular and saving and the jpg contains the text.

Justin: do you really get an empty field, if you test with my PDF? I also tried exporting with PDF format forms, but that worked fine as well.

Arch Linux 64-bit
Version: 6.2.0.0.alpha0+
Build ID: 860a9daf2b45942a4b10ff22d36aa3fe29be19f4
CPU threads: 8; OS: Linux 4.17; UI render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group threaded
Built on July 14th 2018
Comment 6 Justin 2018-07-24 06:09:04 UTC
Sorry for the delay.
Yes I tested again and also with the test files I do not get the filled form. I also tried with your command. Still the same.

My actual command was like this:
convert -density 200 -background 'white' formfield.pdf -alpha 'remove' -quality 85 -verbose -version formfield.jpg
Comment 7 Buovjaga 2018-07-24 08:16:45 UTC
Eh, my bad: contrary to your description, I filled the field in Okular and not LibreOffice. I reproduce, if I fill the field already in LibreOffice.

Already in
Arch Linux 64-bit
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 8 QA Administrators 2019-12-10 03:59:51 UTC
Dear Justin,

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug