Bug 118690 - Printing does not start if Comments to Margin is set
Summary: Printing does not start if Comments to Margin is set
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
6.0.0.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.2.0 target:6.1.3
Keywords: bibisected, bisected, perf, regression
: 119567 (view as bug list)
Depends on:
Blocks: Writer-Comments Print
  Show dependency treegraph
 
Reported: 2018-07-11 12:10 UTC by Gabor Kelemen
Modified: 2018-10-19 13:54 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of a stuck LO 6.2 alpha in Task Manager (16.07 KB, image/png)
2018-07-11 12:10 UTC, Gabor Kelemen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen 2018-07-11 12:10:01 UTC
Created attachment 143453 [details]
Screenshot of a stuck LO 6.2 alpha in Task Manager

Printing LibreOffice Writer document without a comment, but with the option Print Comments in margins enabled does not start, but causes 100% processor use. 

Having a comment in the document starts the printing correctly. 
Also opening the Print dialog again and canceling it stops the excessive processor use and resumes the printing correctly.

This reportedly used to work in 5.4.5.

Steps to reproduce:

    1. Open LibreOffice Writer 6.0.
    2. In Options, choose LibreOffice Writer and Print option
    3. Select In margins under Comments
    4. Type a short text, but don't add a comment
    5. Press Ctrl+P and Enter. Printing does not start, but processor use goes to 100%.
    6. If the printing doesn’t start, press Ctrl+P again and click on Cancel button. Printing resumes.

Actual results:
Printing doesn’t start after pressing Ctrl+P and Enter

Expected results:
Printing should start after pressing Ctrl+P and Enter

Still happens on:
Version: 6.2.0.0.alpha0+
Build ID: 5fce97a58b8f764e35bf98128591c9a89537da05
CPU threads: 4; OS: Windows 6.3; UI render: default; 
Locale: hu-HU (hu_HU); Calc: CL

Bibisected using bibisect-win32-6.0:

# bad: [bc1845d882e52469a4583747881a465749177829] source sha:c30963b8b4bbbe42a24b97aafa161eff9d7ccdd4
# good: [cc5c4c7ed1d8d01b0063bcaaeb5f6d59282c8029] source sha:9feb7f7039a3b59974cbf266922177e961a52dd1
git bisect start 'origin/master' 'oldest'
# bad: [611b687719dc875499fd14d50e699b7ce871b941] source sha:2cd664b3d618e6085be8b44ee86eada6cd5f8789
git bisect bad 611b687719dc875499fd14d50e699b7ce871b941
# good: [1ab9d28e263358b2f569adb76bcc856198d0f435] source sha:ccb6513baf6eae9af40eecd05a2991bdd3ce3bbf
git bisect good 1ab9d28e263358b2f569adb76bcc856198d0f435
# bad: [8c62e5fd421ccd2e5c767f4067798f7253965b76] source sha:19805f85b35672e6d0ee16f8fb4b79a3e94fc05d
git bisect bad 8c62e5fd421ccd2e5c767f4067798f7253965b76
# good: [4f3fd1e9cb890eca495849359508d148ab23ffb8] source sha:91795dfd726c76db03e5bc731608e7bff8eabacb
git bisect good 4f3fd1e9cb890eca495849359508d148ab23ffb8
# bad: [a6c2b4f451ba5455504b91b97974248b72ce23fb] source sha:59a00dde20b7862ad5e5e0f208631dae6c213bb5
git bisect bad a6c2b4f451ba5455504b91b97974248b72ce23fb
# bad: [c9c25e9188a85d5754cd6d1b12e5c7705f7bb169] source sha:d30ae9c17ba51a55dd491f4c91712860b495f424
git bisect bad c9c25e9188a85d5754cd6d1b12e5c7705f7bb169
# good: [2431f6b0c467065adfd72548fb5ccd2c887f655b] source sha:29bb9775ce5443d5f4929471fa2cd85d8e6d6c45
git bisect good 2431f6b0c467065adfd72548fb5ccd2c887f655b
# good: [cf277d34f9d3e8b995de6c0cc4b157260d8a2e9e] source sha:fd1647ad9042a359127fccc03d6c99d7d1fea7fb
git bisect good cf277d34f9d3e8b995de6c0cc4b157260d8a2e9e
# good: [3e6cfd0567d125239fc2cdb895b4c04d4c0e2379] source sha:4be3b5a000058eacc1fd3e8b34909e9c8cb1c8cb
git bisect good 3e6cfd0567d125239fc2cdb895b4c04d4c0e2379
# good: [7c36eb81668a3d4d6020c8c946372b2c8ad7ad2d] source sha:26dd5d4614e5968f111b77a3f03129a6a2a7c0c7
git bisect good 7c36eb81668a3d4d6020c8c946372b2c8ad7ad2d
# bad: [70b98b8acdeaf67dcc94b6399de1e7249af8fc91] source sha:9dfd1bb102bb08f0651a6921722d731ab973bd08
git bisect bad 70b98b8acdeaf67dcc94b6399de1e7249af8fc91
# good: [97d7bedf044e3295cfbad42203a7050d756e0426] source sha:fae4b84882adac35d7cc170cef555bd0b41bb3df
git bisect good 97d7bedf044e3295cfbad42203a7050d756e0426
# bad: [f74978f623c850e9b9f4208a0aba46f75bd8b03c] source sha:221b0ab1245be6dba23b4ef3c516e846d95d2f71
git bisect bad f74978f623c850e9b9f4208a0aba46f75bd8b03c
# first bad commit: [f74978f623c850e9b9f4208a0aba46f75bd8b03c] source sha:221b0ab1245be6dba23b4ef3c516e846d95d2f71

https://cgit.freedesktop.org/libreoffice/core/commit/?id=221b0ab1245be6dba23b4ef3c516e846d95d2f71
Comment 1 Gabor Kelemen 2018-07-11 12:11:07 UTC
Confirmed by my team members.
Comment 2 Xisco Faulí 2018-07-12 15:11:48 UTC
Adding Cc: to Jan-Marek Glogowski
Comment 3 Xisco Faulí 2018-09-11 10:26:44 UTC
*** Bug 119567 has been marked as a duplicate of this bug. ***
Comment 4 Commit Notification 2018-09-24 16:06:28 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=79cb9ef524c3a6b058019da5ca6acfad7a895bf2

tdf#118690 don't try to process all messages

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Gabor Kelemen 2018-10-03 11:17:22 UTC
Verified with:

Version: 6.2.0.0.alpha0+
Build ID: 52cb73911e661fb636085337374e09845f07783b
CPU threads: 1; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-10-02_01:05:50

(daily build from yesterday)

Now printing starts for us just fine. Thanks!
Comment 6 Commit Notification 2018-10-11 08:00:24 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=376a4c754a2bf95b3033b88d68e98a562ba8632b&h=libreoffice-6-1

tdf#118690 don't try to process all messages

It will be available in 6.1.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Xisco Faulí 2018-10-11 09:54:30 UTC
Verified in

Version: 6.2.0.0.alpha0+
Build ID: 425af6845ebe066c950b0b63f50563e067485f3e
CPU threads: 16; OS: Windows 6.3; UI render: default; VCL: win; 
Locale: en-GB (en_GB); Calc: threaded

Cherry-picked to 6-1-3: https://gerrit.libreoffice.org/#/c/61655/

@Jan-marek, should it be closed as RESOLVED FIXED ?
Comment 8 Commit Notification 2018-10-19 12:53:46 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "libreoffice-6-1-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=765e019e2d4be851096e70b943f01dd021545e3c&h=libreoffice-6-1-3

tdf#118690 don't try to process all messages

It will be available in 6.1.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.