Bug 119567 - Repeated print with deleted comments doesn't open printer window from 6.0
Summary: Repeated print with deleted comments doesn't open printer window from 6.0
Status: CLOSED DUPLICATE of bug 118690
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Writer-Comments Print
  Show dependency treegraph
 
Reported: 2018-08-28 15:58 UTC by Timur
Modified: 2021-10-18 05:59 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Timur 2018-08-28 15:58:11 UTC
While testing Bug 112294 I came to this one:
1. Open a document with comments or add comment to a new document
2. Open File -> Print (can be PDF printer)
3. Select Print Comments "Place in margins"
4. Print the document 
5. Delete all comments
6. Open File -> Print and choose the same or another printer
7. Press OK to print

Expected: Print window
Experienced: no Print window, even if 6. and 7. repeated

8. Open File -> Print again 
9. Press Cancel (to cancel, as Help frequently says)

Experienced: here come Print window (or windows if 6. and 7. repeated)

Repro from 6.0 to 6.2+. Not with 5.4. Marked regression.
Comment 1 Xisco Faulí 2018-08-29 08:15:12 UTC
@Daniel Silva, I thought you could be interested in this issue...
Comment 2 Timur 2018-08-30 09:15:53 UTC
Xisco, you didn't confirm? Can it be bibisected?
Comment 3 Dieter 2018-09-10 20:48:50 UTC
I confirm it with

Version: 6.0.6.2 (x64)
Build-ID: 0c292870b25a325b5ed35f6b45599d2ea4458e77
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: group
Comment 4 Xisco Faulí 2018-09-11 10:25:42 UTC
Regression introduced by:

author	Jan-Marek Glogowski <glogow@fbihome.de>	2017-07-20 15:49:45 +0200
committer	Jan-Marek Glogowski <glogow@fbihome.de>	2017-07-24 18:05:06 +0200
commit 221b0ab1245be6dba23b4ef3c516e846d95d2f71 (patch)
tree 92020efa71219b36729d9a07ac948cdf104450bf
parent fae4b84882adac35d7cc170cef555bd0b41bb3df (diff)
WIN use Reschedule instead of own dispatch loops
Since we're filtering the wakeup timer event in the main dispatch
loop, we should use Application::Reschedule in the Backend.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=221b0ab1245be6dba23b4ef3c516e846d95d2f71

Bisected with: bibisect-win32-6.0

Adding Cc: to Jan-Marek Glogowski
Comment 5 Xisco Faulí 2018-09-11 10:26:44 UTC
Closing as dupe of bug 118690

*** This bug has been marked as a duplicate of bug 118690 ***
Comment 6 Deloresarks 2020-01-09 07:04:29 UTC Comment hidden (spam)
Comment 7 Murielard 2020-02-15 08:01:39 UTC Comment hidden (spam)
Comment 8 Kelly Kevin 2021-10-18 05:59:44 UTC Comment hidden (spam)