Bug 118897 - Gill Sans Shadowed MT Light font not recognized
Summary: Gill Sans Shadowed MT Light font not recognized
Status: RESOLVED DUPLICATE of bug 69254
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.0.4.2 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-07-23 00:09 UTC by Jon R Kibler
Modified: 2018-08-10 17:50 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Open Office Font List showing "missing" font present (1.08 MB, image/tiff)
2018-07-23 00:19 UTC, Jon R Kibler
Details
ScreenShot showing font missing from LibreOffice (1.39 MB, image/tiff)
2018-07-23 00:20 UTC, Jon R Kibler
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jon R Kibler 2018-07-23 00:09:08 UTC

    
Comment 1 Jon R Kibler 2018-07-23 00:19:16 UTC
Created attachment 143698 [details]
Open Office Font List showing "missing" font present
Comment 2 Jon R Kibler 2018-07-23 00:20:26 UTC
Created attachment 143699 [details]
ScreenShot showing font missing from LibreOffice
Comment 3 Jon R Kibler 2018-07-23 00:20:49 UTC
Opening a document that contains text using the Gill Sans Shadowed MT Light font renders all use of that font as the default font.

Opening the same document in OpenOffice has no issue with the font.

All other applications (Pages, etc.) properly render the font.

Libreoffice also doesn't show the font on the drop-down font list, either. For example, compare the two screenshots of font lists between OO and LO.
Comment 4 Alex Thurgood 2018-07-24 07:43:30 UTC
This is not a font under an opensource licence.

I tried downloading it from here:
http://fontsgeek.com/fonts/Gill-Sans-Shadowed-MT-Pro-Light/download

and the download failed (due to some unspecified leagal reason, or trademark issue).

A similar one sells for 42 Euros plus VAT on this site:
https://www.linotype.com/fr/186393/gill-sans-light-shadowed-product.html

where a mention is made at the bottom of the page that Gill Sans is a trademarked expression.

In other words, it is likely that only licensed distributors (such as Linotype) are legally authorized to offer the font for download.

This will make it difficult, or impossible to confirm your bug report, unless someone has a legally acquired copy of the font. 

Please do not post the font to the bug report.
Comment 5 Alex Thurgood 2018-07-24 07:48:55 UTC
The Gill Sans fonts provided with macOS appear to be the following (from my FontBook):

GillSans-Light
GillSans
GillSans-LightItalic
GillSans-Italic
GillSans-Bold
GillSans-SemiBold
GillSans-UltraBold
GillSans-BoldItalic
GillSans-SemiBoldItalic
Comment 6 Alex Thurgood 2018-07-27 07:01:34 UTC

*** This bug has been marked as a duplicate of bug 69254 ***
Comment 7 LibreTraining 2018-08-10 01:37:34 UTC
Jon,
I tested with the Gill Sans Nova fonts package which also includes a Shadowed Light and it is listed in the dialogs as expected.
The Shadowed fonts are in their own typographic family so I would expect them to work properly.
Tested on LO 6.1.0.3 x64 on Windows 7 x64.

I would like to test your fonts to see why they have an issue and mine do not.
Could you please send the fonts directly to my email which you should be able to see.

It is highly unlikely the font police will show up and have an issue with our testing to make sure their products work properly with LibreOffice.
Comment 8 Jon R Kibler 2018-08-10 02:07:34 UTC
@LibreTraining ... 

I can confirm that 6.1.0.3 on the Mac does not fix the problem.

I sent you the font. Please let me know if you need anything else.

Jon Kibler
Comment 9 LibreTraining 2018-08-10 17:37:18 UTC
Hi Jon,

Thanks for "the font" but I do think we need to test with all the fonts installed.
I think part of the LO fonts problems stem from the family names, etc. not being handled properly.
Please send me the full package of fonts so I can replicate what you had installed.
Specifically which fonts did you have installed?

I sent you my full package of Gills Sans Nova fonts.
Please test on your system.
I had installed just all the regular fonts and the Shadowed Light - and it appeared in the font list.
I did not install all the fonts at once though we may also want to test that too.

I will install the same fonts you had installed and post my results back here.

Once we know how each package works on each of our systems I can examine the font files metadata to see if I can determine why there is an issue.

Regards,

Ken
Comment 10 LibreTraining 2018-08-10 17:50:13 UTC
What I mean by "all the regular fonts" is the regular width and style.
I did not install any of the Condensed, Inline, or Deco fonts.
Just all the regular width fonts from Light to UltraBold with italics, 
and the one Shadowed Light font.