Bug 118965 - Cannot Edit choices in Writer Input List
Summary: Cannot Edit choices in Writer Input List
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.4.2 release
Hardware: All All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:6.2.0 target:6.1.1 target:6.0....
Keywords: bibisected, bisected, regression
: 119355 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-07-27 08:53 UTC by ibelin123
Modified: 2018-08-19 19:22 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Input list sample (8.90 KB, application/vnd.oasis.opendocument.text)
2018-07-27 10:25 UTC, ibelin123
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ibelin123 2018-07-27 08:53:06 UTC
Description:
In Writer.. I click the edit button in Input List.. the window will just close.. It will not lead you to a edit window

Steps to Reproduce:
1.Click on an input list field.
2.Click on edit


Actual Results:
window closes

Expected Results:
it should have lead you to the edit input list field window


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Jacques Guilleron 2018-07-27 10:11:32 UTC
Hi ibelin123

I dont reproduce using
LO 6.0.5.2 Build ID: 54c8cbb85f300ac59db32fe8a675ff7683cd5a16
Threads CPU : 2; OS : Windows 6.1; UI Render : par défaut; 
Locale : fr-FR (fr_FR); Calc: CL
Can you provide a sample document dowing this behavior and precise on which OS you
work?
Thank you.
Comment 2 ibelin123 2018-07-27 10:25:58 UTC
Created attachment 143802 [details]
Input list sample

Thank you for the quick response! 

   Operating System: Windows 7 Professional 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_ldr.170209-0600)
           Language: English (Regional Setting: English)
System Manufacturer: Hewlett-Packard
       System Model: HP Compaq 6200 Pro SFF PC
               BIOS: Default System BIOS
          Processor: Intel(R) Core(TM) i5-2400 CPU @ 3.10GHz (4 CPUs), ~3.1GHz
             Memory: 4096MB RAM
Available OS Memory: 3984MB RAM
Comment 3 Regina Henschel 2018-07-27 20:07:18 UTC
A click on the Edit button should open the field dialog, similar to Edit > Fields. It was OK in Version: 5.4.7.2 (x64)
Build ID: c838ef25c16710f8838b1faec480ebba495259d0
CPU threads: 8; OS: Windows 6.19; UI render: default; 
Locale: en-US (en_US); Calc: CL

It is broken in Version: 6.0.4.2 (x64)
Build ID: 9b0d9b32d5dcda91d2f1a96dc04c645c450872bf
CPU threads: 8; OS: Windows 10.0; UI render: default; 
Locale: de-DE (en_US); Calc: CL
Comment 4 ibelin123 2018-07-28 06:40:14 UTC
As additional info, when you right click on the input list field, then click "field" in the pop-up, it will bring you to the edit window.
Comment 5 Jacques Guilleron 2018-07-29 08:07:34 UTC
Th
Comment 6 Jacques Guilleron 2018-07-29 08:27:28 UTC
Hi ibelin123, Regina,

I probably missed it because right click gave list field opening,
I reproduce with
LO  6.0.0.0.alpha1+ Build ID: 133d617a7758acb342d82e5d446e165cd87e2cac
CPU threads: 2; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-11-18_01:48:12
Locale: fr-FR (fr_FR); Calc: CL
and upper versions
but not with
LO 6.0.0.0.alpha0+
Build ID: 02c53f744ed23e2149fc7c83d67cb7d8aa5eb0ed
CPU threads: 2; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-08-24_05:48:55
Locale: fr-FR (fr_FR); Calc: CL
Comment 7 Xisco Faulí 2018-07-29 18:37:20 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=7d5245848c28f5786258476cd7aa2a4523645de3

author	Bernhard Widl <bernhard.widl@cib.de>	2017-09-15 17:39:48 +0200
committer	Thorsten Behrens <Thorsten.Behrens@CIB.de>	2017-09-19 01:11:25 +0200
commit	7d5245848c28f5786258476cd7aa2a4523645de3 (patch)
tree	dc57a024f062b9d18bf647710652b67206c3b0d7
parent	c686dc4f33c7461a28df95603d06591a3a0171cd (diff)
tdf#79877 revert to old behavior when clicking on input fields.
doubleclick on input field brings up old input fields dialog
that dialog now starts at current field and has previous/next navigation

Bisected with: bibisect-linux64-6.0

Adding Cc: to Bernhard Widl
Comment 8 Xisco Faulí 2018-07-30 08:44:32 UTC
@Caolán, I thought you could be interested in this issue...
Comment 9 Caolán McNamara 2018-07-30 10:12:55 UTC
I imagine that the EditHdl needs to return RET_YES instead of RET_OK in order for the edit entry to work. https://gerrit.libreoffice.org/#/c/58313/ probably will fix this
Comment 10 Xisco Faulí 2018-07-30 10:18:09 UTC
(In reply to Caolán McNamara from comment #9)
> I imagine that the EditHdl needs to return RET_YES instead of RET_OK in
> order for the edit entry to work. https://gerrit.libreoffice.org/#/c/58313/
> probably will fix this

Indeed, it fixes the issue... tested locally... thanks for the quick fix!
Comment 11 Commit Notification 2018-07-30 11:28:19 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1eb1fe39f14a8fcd306859f0741c88b8577a2598

Resolves: tdf#118965 fix input list edit button

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Caolán McNamara 2018-07-30 11:29:19 UTC
backports in gerrit
Comment 13 Commit Notification 2018-07-30 14:09:38 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=15f8f0be29c42ac0c10af679ff5bb51b29bb3bd1&h=libreoffice-6-1

Resolves: tdf#118965 fix input list edit button

It will be available in 6.1.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 ibelin123 2018-08-01 04:38:14 UTC
Its now fixed in the daily build. Thank you! That was quick!
Comment 15 Xisco Faulí 2018-08-01 07:51:49 UTC
(In reply to ibelin123 from comment #14)
> Its now fixed in the daily build. Thank you! That was quick!

Setting to VERIFIED!!
Comment 16 Commit Notification 2018-08-02 11:53:47 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f36207cb94ef8245bdb62651bae9ca290a4744df&h=libreoffice-6-0

Resolves: tdf#118965 fix input list edit button

It will be available in 6.0.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2018-08-02 11:54:01 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-6-1-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d26dd924f93202d6911efc31430c9fc9cb72f0e7&h=libreoffice-6-1-0

Resolves: tdf#118965 fix input list edit button

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Julien Nabet 2018-08-19 09:54:44 UTC
*** Bug 119355 has been marked as a duplicate of this bug. ***
Comment 19 BogdanB 2018-08-19 19:22:40 UTC
Confirm it is working now.

Version: 6.1.1.0.0+
Build ID: 5a56b72413d5f555c854e36d3bd2fd50ec21644c
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:libreoffice-6-1, Time: 2018-08-15_02:45:13
Locale: ro-RO (ro_RO.UTF-8); Calc: group threaded