Download it now!
Bug 119025 - "Merge with next paragraph" doesn't merge borders across row spacing
Summary: "Merge with next paragraph" doesn't merge borders across row spacing
Status: RESOLVED DUPLICATE of bug 115296
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.0.2 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Regressions-borderline
  Show dependency treegraph
 
Reported: 2018-07-31 19:37 UTC by Octavio Alvarez
Modified: 2018-08-02 10:14 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example with thick border. (9.45 KB, application/vnd.oasis.opendocument.text)
2018-07-31 23:53 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Octavio Alvarez 2018-07-31 19:37:02 UTC
Description:
Applying borders to multiple paragraphs and setting "Merge with next paragraph" leaves space across row spacing.

Steps to Reproduce:
1. New Writer document.
2. Type "Hello 1" <ENTER>
3. Type "Hello 2" <ENTER>
4. Type "Hello 3", no <ENTER>.
5. Edit » Select All.
6. Format » Paragraph...
7. ... » Tab: Indents & Spacing » Spacing: Above paragraph: 1 cm
8. ... » Tab: Borders » Line Arrangement: Select All Four Borders
9. ... » Tab: Borders » Properties: Merge with next paragraph [checked]

Actual Results:
Inter-paragraph space is not bordered.

Expected Results:
Have a single square around the three paragraphs.



Reproducible: Always


User Profile Reset: No



Additional Info:
Same thing happened with "Below paragraph: 1cm" and "Line spacing: Proportional: 200%".

Version: 6.1.0.2 (x64)
Build ID: b3972dcf1284967612d5ee04fea9d15bcf0cc106
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: en-US (en_US); Calc: group threaded

I suggest UX for this bug be analyzed along #118204. Not a duplicate.
Comment 1 Regina Henschel 2018-07-31 23:53:14 UTC
Created attachment 143865 [details]
Example with thick border.

Yes there is a gap, that shouldn't be there. It is there too, if you use spacing below, and a small gap can even be seen, if the margins are set to 0.

The gap was not there in version 5.4.7, but in that version the corners are not correct.

The borders were correct in version LibreOffice 3.5.4.2 
Build ID: 165a79a-7059095-e13bb37-fef39a4-9503d18
Comment 2 Xisco Faulí 2018-08-02 10:14:27 UTC
Regression introduced by https://cgit.freedesktop.org/libreoffice/core/commit/?id=1d86f43a10f097aa4925bd48870477001098f5ff, which is the same as in bug 115296
Closing as RESOLVED DUPLICATED

*** This bug has been marked as a duplicate of bug 115296 ***