Download it now!
Bug 119041 - FILESAVE DOCX Anchor setting of charts are always saved as “As Character” regardless of the original setting
Summary: FILESAVE DOCX Anchor setting of charts are always saved as “As Character” reg...
Status: RESOLVED DUPLICATE of bug 128207
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX-Anchor-and-Text-Wrap
  Show dependency treegraph
 
Reported: 2018-08-01 13:42 UTC by Gabor Kelemen
Modified: 2020-02-28 09:47 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
The original file (in ODF format) (18.99 KB, application/vnd.oasis.opendocument.text)
2018-08-01 13:42 UTC, Gabor Kelemen
Details
The DOCX export of the same file (15.62 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-08-01 13:42 UTC, Gabor Kelemen
Details
A screenshot showcasing the issue (159.28 KB, image/png)
2018-08-01 13:43 UTC, Gabor Kelemen
Details
Chart anchor settings in current master (129.53 KB, image/png)
2019-07-02 12:15 UTC, Gabor Kelemen
Details
The original file saved by current 6.4 master (15.87 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-07-02 12:16 UTC, Gabor Kelemen
Details
The Sample Dcument In 7.0 Master (105.22 KB, image/png)
2020-02-28 09:47 UTC, Attila Bakos (NISZ)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen 2018-08-01 13:42:21 UTC
Created attachment 143894 [details]
The original file (in ODF format)

The anchor setting of the charts in text documents is not preserved: when the file is saved as DOCX, the anchor setting is always stored as “As Character”. This makes it impossible to wrap the text around the chart, and also results the document content to be rearranged after save and reload.

Steps to reproduce:
1.	Open LibreOffice Writer and create a simple document with some random text in it.
2.	Insert a Chart via Insert –> Chart.
3.	 Charts are anchored “To Paragraph” by default, so there is no need to change this setting. Resize and move the chart in a position where it is wrapped around with the text.
4.	Save the file as DOCX and reload it.

Actual results:
The chart jumps to the first character of its respective paragraph, and the anchor setting changes from “To Paragraph” to “As Character”.

Expected results:
The anchor setting of the chart should be preserved.

LibreOffice details:
Version: 6.2.0.0.alpha0+
Build ID: bb1d5780226bb1b9156580972eea9aa849178742
CPU threads: 1; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-07-03_05:56:48
Locale: hu-HU (hu_HU); Calc: group threaded
Comment 1 Gabor Kelemen 2018-08-01 13:42:45 UTC
Created attachment 143895 [details]
The DOCX export of the same file
Comment 2 Gabor Kelemen 2018-08-01 13:43:05 UTC
Created attachment 143896 [details]
A screenshot showcasing the issue
Comment 3 Gabor Kelemen 2018-08-01 13:48:58 UTC
Found by my team. Confirmed with a more recent version from the bibisect-win32-6.2  repo:
Version: 6.2.0.0.alpha0+
Build ID: 921f285c7ff713ad219d3e3385d7e7d12d33581e
CPU threads: 4; OS: Windows 6.3; UI render: default; 
Locale: hu-HU (hu_HU); Calc: CL
Comment 4 Xisco Faulí 2018-08-02 14:51:20 UTC
Also reproduced in

Version: 5.2.0.0.alpha0+
Build ID: 3ca42d8d51174010d5e8a32b96e9b4c0b3730a53
Threads 4; Ver: 4.10; Render: default; 

Version: 4.3.0.0.alpha1+
Build ID: c15927f20d4727c3b8de68497b6949e72f9e6e9e

in previous versions the image disappeared after RT
Comment 5 Gabor Kelemen 2019-07-02 12:15:35 UTC
Created attachment 152511 [details]
Chart anchor settings in current master

It looks a bit better after the fix of bug #125518 in:

Version: 6.4.0.0.alpha0+ (x86)
Build ID: 81ab6abe574a75f1ed229a88ceee9eb3b143a18a
CPU threads: 4; OS: Windows 6.3; UI render: GL; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2019-07-02_02:29:05
Locale: hu-HU (hu_HU); UI-Language: en-US
Calc: CL

Still: "To paragraph" becomes "To character" (instead of "As character" and position values become 0 instead of the set values. 
But horizontal and vertical positions are now correct.
Comment 6 Gabor Kelemen 2019-07-02 12:16:06 UTC
Created attachment 152512 [details]
The original file saved by current 6.4 master
Comment 7 Attila Bakos (NISZ) 2020-02-28 09:41:01 UTC

*** This bug has been marked as a duplicate of bug 128207 ***
Comment 8 Attila Bakos (NISZ) 2020-02-28 09:47:27 UTC
Created attachment 158252 [details]
The Sample Dcument In 7.0 Master