Download it now!
Bug 119076 - Add means to use the horizontal ruler to shift left indent but leave first line in place
Summary: Add means to use the horizontal ruler to shift left indent but leave first li...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Rulers
  Show dependency treegraph
 
Reported: 2018-08-03 05:16 UTC by Bernd Wechner
Modified: 2018-09-03 07:26 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (91.92 KB, image/jpeg)
2018-08-29 17:46 UTC, Dieter
Details
Demonstration of ruler use and how pointers move (313.53 KB, video/mp4)
2018-08-29 20:55 UTC, Bernd Wechner
Details
Demonstration of ruler use and how pointers move (140.25 KB, image/gif)
2018-08-29 21:15 UTC, Bernd Wechner
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bernd Wechner 2018-08-03 05:16:25 UTC
Description:
There are three markers on the horizontal ruler:

    first line
    left indent
    right indent

which map to the paragraph formats:

    Indent, First line
    Indent, Before text
    Indent, After text

Alas moving (dragging) them has these affects:

    first line marker - dragging it moves just that marker
    right indent marker - dragging it moves just that marker
    left indent marker - dragging it moves just that marker AND the first line marker

But, I would like to be able to move the left indent marker WITHOUT moving the first line marker. Perhaps dragging it while the SHIFT key is depressed?


Steps to Reproduce:
1.Drag the left indent marker on the horizontal rule



Actual Results:
The first line indent marker moves with it

Expected Results:
The first line indent marker (optionally) stays put


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Dieter 2018-08-28 08:56:43 UTC
I agree with Bernd.
Comment 2 Heiko Tietze 2018-08-29 07:20:43 UTC
Please add a screenshot to make it perfectly clear what you mean.
Comment 3 Dieter 2018-08-29 17:46:10 UTC
Created attachment 144536 [details]
Screenshot

See ruler in the screenshot. You can't move the selected marker seperately from the marker above. There should be a possibility to do this. Bernd's suggestion was to move it while you press shift.
Comment 4 Bernd Wechner 2018-08-29 20:55:40 UTC
Created attachment 144539 [details]
Demonstration of ruler use and how pointers move

Dieter beat me. But I took a short video too to demonstrate. In it I show the rule, and an arbitrary start position for the two left pointers on it, then I move first the top one, and all is good,then the bottom one and they both move as a pair. This is  fine as default behaviour, but very often it is the separation between these two I wish to adjust without moving the top one. 

The work around currently is a manual bother: move both (by dragging the bottom one) then move the top one back to where it was. The bother is, trying to line the top one back up with surrounding paragraphs confidently by eye. 

I'm usually doing this to define a style, but not always, and yet another work around is to open the properties dialogues and use numbers for precision. The problem there is that it is often very nice, by eye to adjust the bottom pointer. 

The most common use case I have for this is when indenting all but the first line of a paragraph, wanting to keep the first line where it is, but indent the body some to align with other visual elements - so its often by eye.
Comment 5 Bernd Wechner 2018-08-29 21:15:21 UTC
Created attachment 144540 [details]
Demonstration of ruler use and how pointers move

The attached video was .mp4 and didn't seem to upload intact. So converted to gif, and attach again. Re-recorded it, starting with pointers at default position.
Comment 6 Bernd Wechner 2018-08-31 01:42:13 UTC
I should add, that subjectively, the effort to implement a fix seems low.

If we define two formats:

    Indent, First line
    Indent, Before text

and two arrows on the horizontal ruler:

    first line
    left indent

currently one arrow maps to one format, which makes sense. The nature of "Indent, First line" is that it is relative to "Indent, Before text" and the mapping is simply:


"first line" -> "Indent, First line"
"left indent" -> "Indent, Before text"

The consequence of which is the current UX because "Indent, First line" is relative to "Indent, Before text", so when you move "left indent", "Indent, First line" is unchanged, but the "first line" pointer must move to reflect that.

The request which would improve UX immensely IMO is to optionally map:

SHIFT+"left indent" -> "Indent, Before text" AND "Indent, Before text"

such that a move in the arrow (with SHIFT depressed say) updates not only "Indent, Before text" but also "Indent, Before text" such that the arrow "first line" remains unmoved, in short the indent of the first line remains fixed relative to the page not relative to "Indent, Before text" (the left margin of the paragraph).
Comment 7 ajlittoz 2018-09-02 13:10:22 UTC
Unless I don't understand OP's need, this already exists. However the modifier is Ctrl, not Shift. And it has existed for years since a similar feature existed in M$ Word.
Comment 8 ajlittoz 2018-09-02 13:19:24 UTC
My suggestion is to close this report with NOTABUG or INVALID and to request an improvement in built-in help, topic Rulers>"using rulers" paragraph "Changing indents": two rules are mentioned. A third one with Ctrl-click and drag should be added.

This would be similar to Rulers>default settings leading to page "Inserting and Editing Tab Stops" where paragraph "Moving Tabs on the Ruler" mentions a Ctrl-drag trick.
Comment 9 Dieter 2018-09-02 13:41:57 UTC
(In reply to ajlittoz from comment #8)
> My suggestion is to close this report with NOTABUG or INVALID and to request
> an improvement in built-in help, topic Rulers>"using rulers" paragraph
> "Changing indents": two rules are mentioned. A third one with Ctrl-click and
> drag should be added.
> 
> This would be similar to Rulers>default settings leading to page "Inserting
> and Editing Tab Stops" where paragraph "Moving Tabs on the Ruler" mentions a
> Ctrl-drag trick.

I agree
Comment 10 Bernd Wechner 2018-09-02 23:35:57 UTC
I agree 100%. Just tested and it works. Ingenious. Yes, this shoudl close and become an enhancement feature for the docs. Because I asked this at ask.libreoffice first:

https://ask.libreoffice.org/en/question/161761/use-horizontal-ruler-to-shift-left-indent-but-leave-first-line-in-place/

and not a soul knew how to do it, and we concluded it wsn't possible, so they recommended filing a feature request. 

Imagine my mix of joy and embarrassment to discover CTRL does this! Embrassment because I iterally thought I'd tried every combination of keys CRTL, SHIFT, ALT alone and in pairs and as a triplet) held down while dragging to test and try and find one that worked on the supposition it probably already existed! But I didn't find it. Human error clearly!

But no did I find it in the documentation nor did any community members at ask.libreoffice know about so, indeed this points to a wonderful little hidden feature that would benefit from being properly and well documented!
Comment 11 Dieter 2018-09-03 06:47:28 UTC
Bernd, I opened Bug 119657. Please confirm it (and perhaps add you experiences).

I close this bug with WORKSFORME.