Bug 119289 - Failure to sing existing pdf on LibreOffice 6.1.0.3.(x64) on Win10 with SmartCard
Summary: Failure to sing existing pdf on LibreOffice 6.1.0.3.(x64) on Win10 with Smart...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.1.0.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Digital-Signatures
  Show dependency treegraph
 
Reported: 2018-08-15 11:05 UTC by novica
Modified: 2018-11-28 13:06 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description novica 2018-08-15 11:05:23 UTC
Description:
I'm trying to sign an existing PDF with Libreoffice.

The pin is asked for when I try to sign a LibreOffice document, such as an odt document, but not when trying to sign an existing pdf.

This is on Windows 10.

Steps to Reproduce:
 File -> Digital Signatures -> Sign existing PDF;

Then I click on the Sign Document button, and again on the Sign Document button in the Digital Signatures dialog;

Select certificate dialog pop-out and I select my certificate and click sign.



Actual Results:
After that nothing happens. There is no dialog to enter the pin. There is no error.

Expected Results:
A popup for the pin should show up.


Reproducible: Always


User Profile Reset: No



Additional Info:
 I used to be able to sign pdfs in previous versions of Libreoffice, but not sure which was the last version when I signed before.
Comment 1 Buovjaga 2018-09-03 18:55:23 UTC
Please look at the existing reports, ctrl-f for "pdf": https://bugs.documentfoundation.org/showdependencytree.cgi?id=105605&hide_resolved=1
Does it look like your problem is found among them?
Comment 2 novica 2018-09-04 07:14:39 UTC
As far as I can see the problem with not showing the dialog box for entering pin of a certificate is not among the listed issues.
Comment 3 Juan Jose Pablos 2018-10-08 09:19:02 UTC
Looks like you are using a smart card. 
Could you provide more hardware information about the smart card you used?
Comment 4 novica 2018-10-14 18:04:41 UTC
I'm not sure what do you mean by hardware infomarion. It is a Gemalto USB SmartCard Reader
Comment 5 Juan Jose Pablos 2018-10-23 00:39:50 UTC
Please try current version 
libo-master64~2018-10-22_01.47.50_LibreOfficeDev_6.2.0.0.alpha1_Win_x64.msi
It worked for me.
Comment 6 Timur 2018-10-26 08:35:32 UTC
Juan, can you confirm that you were able to reproduce with 6.1.0 as reporter and not with master 6.2+? What about 6.1.3?
In that case testing with master makes sense for reporter.
Comment 7 novica 2018-10-26 08:48:01 UTC
I upgraded to Version: 6.1.1.2 (x64) (the check for updates button says there no newer version) and the issue is gone. 

I can sing existing pdf documents. Thank you.
Comment 8 Juan Jose Pablos 2018-10-26 23:39:53 UTC
@Timur,
I have test these Prerelease builds:

LibreOffice_6.1.3.1_Win_x64.msi (2018-Oct-11 07:39) Windows7 64bits
LibreOfficeDev_6.2.0.0.alpha1_Win_x64.msi (2018-Oct-11 07:39) Windows7 64bits


Both works as expected.
Comment 9 Juan Jose Pablos 2018-10-27 00:21:33 UTC
Even the LibreOffice_6.0.7.2_Win_x64.msi (Windows7 64bits) works as expected.
Comment 10 Xisco Faulí 2018-11-28 13:06:51 UTC
(In reply to novica from comment #7)
> I upgraded to Version: 6.1.1.2 (x64) (the check for updates button says
> there no newer version) and the issue is gone. 
> 
> I can sing existing pdf documents. Thank you.

Thanks for retesting with the latest version.
Setting to RESOLVED WORKSFORME as the commit fixing this issue hasn't been identified.