Bug 119303 - writer enhancement: input field dialog - select content by default
Summary: writer enhancement: input field dialog - select content by default
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.4.2 release
Hardware: All All
: medium enhancement
Assignee: Michael Weghorn
URL:
Whiteboard: target:6.2.0
Keywords:
: 122513 (view as bug list)
Depends on:
Blocks: Fields
  Show dependency treegraph
 
Reported: 2018-08-15 19:28 UTC by D.F.
Modified: 2019-03-09 21:51 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description D.F. 2018-08-15 19:28:00 UTC
With 6.x double click on an input field will now open the input field dialog.
Great thing to have! Thanks a lot!

One thing would make it even better:
Whenever you double-click you generally intend to change the value within the input-field. So it would be great if the existing content would be selected as default [as it was with the old input-field dialog].
At the moment you will have to double-click the content to start editing.
It would be great if this could be implemented.
Thanks!
Comment 1 Mike Kaganski 2018-08-15 19:31:47 UTC
+1 from me :-)
Comment 2 Commit Notification 2018-08-24 07:18:35 UTC
Michael Weghorn committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=db6f17dc09b49ecbe89cbb99de71c069c029e052

tdf#119303 Preselect text in input field dialog

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 BogdanB 2018-09-15 14:22:52 UTC
Tested on 6.2 on linux.

All the content of the field is selected after double-click, so you can easily modify or delete the field.

Version: 6.2.0.0.alpha0+
Build ID: 9a9b81c7212fa6a6762246593acf3f1950677a22
CPU threads: 4; OS: Linux 4.15; UI render: GL; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-09-08_00:00:43
Locale: ro-RO (ro_RO.UTF-8); Calc: threaded
Comment 4 D.F. 2018-09-25 19:40:37 UTC
Tested on dev6.1.2.0.0+ under Linux
Works with input field and input field for variable.
Thanks a lot!

Version: 6.1.2.0.0+
Build ID: c9d15d30b66102aff3f3e10bb8243edf2ab77334
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:libreoffice-6-1, Time: 2018-09-07_09:42:07
Locale: de-DE (de_DE.UTF-8); Calc: group threaded
Comment 5 Mike Kaganski 2019-03-09 20:44:19 UTC
*** Bug 122513 has been marked as a duplicate of this bug. ***
Comment 6 ibelin123 2019-03-09 21:51:31 UTC
Tried in 6.2 (Windows 7). Enhancement works fine. Thank you.