Bug 119315 - FILEOPEN: Flat format (.fodp) looses background image
Summary: FILEOPEN: Flat format (.fodp) looses background image
Status: RESOLVED DUPLICATE of bug 130479
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, regression
Depends on:
Blocks: Regressions-imageHandling ODF-Flat
  Show dependency treegraph
 
Reported: 2018-08-16 15:54 UTC by Regina Henschel
Modified: 2020-05-21 05:39 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
File to reproduce the probblem. (37.96 KB, application/vnd.oasis.opendocument.presentation)
2018-08-16 15:54 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2018-08-16 15:54:30 UTC
Created attachment 144239 [details]
File to reproduce the probblem.

Open attached document. It has the bitmap "Paper Texture" from the list of bundled images set as background image of filling the master page background.

Save the document in Flat format (.fodp). Reopen this file.
Notice: The page has no background.

If you open the file in an editor, you see, that the image is contained in base64 encoding. It is an FILEOPEN error, because the file generated by LO6.1 shows the background image if opened in LO5.4.; and a file generated by LO5.4 fails in LO6.1.

It was OK in Version: 5.4.7.2 (x64)
Build ID: c838ef25c16710f8838b1faec480ebba495259d0
CPU threads: 8; OS: Windows 6.19; UI render: default; 
Locale: en-US (en_US); Calc: CL

It fails in Version: 6.1.0.3 (x64)
Build ID: efb621ed25068d70781dc026f7e9c5187a4decd1
CPU threads: 8; OS: Windows 10.0; UI render: default; 
Locale: de-DE (en_US); Calc: CL
Comment 1 Regina Henschel 2018-08-16 16:05:45 UTC
OK in Version: 6.0.6.2 (x64)
Build ID: 0c292870b25a325b5ed35f6b45599d2ea4458e77
CPU threads: 8; OS: Windows 10.0; UI render: default; 
Locale: de-DE (en_US); Calc: CL
Comment 2 MM 2018-08-16 19:36:09 UTC
Confirmed on ubuntu 16.04 x64 with Version: 6.2.0.0.alpha0+
Build ID: 4f50129e54c8b4a78e35dc869fd1f5fbc5aa9a87
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-08-04_22:32:09
Locale: en-US (en_US.UTF-8); Calc: threaded

but

Unconfirmed with Version: 6.0.0.0.alpha1+
Build ID: 637d96a25926e299fff5b4cf5a0055b1d171b23b
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-11-17_23:45:59
Locale: en-US (en_US.UTF-8); Calc: single
Comment 3 raal 2018-08-17 12:09:30 UTC
This seems to have begun at the below commit.
Adding Cc: to Tomaž Vajngerl ; Could you possibly take a look at this one? Thanks
 17b7baa8664f81722fb1e6cfbebc94de93f74514 is the first bad commit
commit 17b7baa8664f81722fb1e6cfbebc94de93f74514
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Thu Feb 1 04:53:03 2018 -0800

    source e02efb621fe672aa52e56caa916cf5c3fd0a9cb8
author	Tomaž Vajngerl <tomaz.vajngerl@collabora.co.uk>	2018-02-01 15:28:53 +0900
committer	Tomaž Vajngerl <quikee@gmail.com>	2018-02-01 11:54:22 +0100
commit e02efb621fe672aa52e56caa916cf5c3fd0a9cb8 (patch)
tree 725947b541b4774722d9d4a9d11a2ac58463a753
parent a61747c2c375d1fe404c976d2a03125e4dc78d8f (diff)
Change bitmap table to store XBitmap instead of GraphicObject URL

or 
 9ffc04552bfe98632795547e7783a7ffea29c7dd is the first bad commit
commit 9ffc04552bfe98632795547e7783a7ffea29c7dd
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Fri Apr 20 01:00:02 2018 -0700

    source 7b355669c6ddeab2e6cec692d6afdff41c61d0fb
author	Tomaž Vajngerl <tomaz.vajngerl@collabora.co.uk>	2018-04-14 15:13:05 +0900
committer	Tomaž Vajngerl <quikee@gmail.com>	2018-04-20 09:15:22 +0200
commit 7b355669c6ddeab2e6cec692d6afdff41c61d0fb (patch)
tree 46c55326bccfa68a2bb5fad6d637e0f4576c8d68
parent 663fd3d6e1f93ec989dc289e688d5dbfe434cbca (diff)
Function to load graphic swapped out (loaded on demand)
Comment 4 Xisco Faulí 2019-02-06 12:01:41 UTC
Still reproducible in

Version: 6.3.0.0.alpha0+
Build ID: 202d9af5ab4291a8f867791293477a18ae48051d
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 5 Aron Budea 2020-05-21 05:24:06 UTC
This got fixed between yesterday and today's daily build, must be because of bug 130479's fix. Marking as duplicate.

*** This bug has been marked as a duplicate of bug 130479 ***