Download it now!
Bug 130479 - Inlined BMP fills do not render
Summary: Inlined BMP fills do not render
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
6.1.0.3 release
Hardware: All All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:7.0.0 target:6.4.5
Keywords: bibisected, bisected, regression
: 117598 118066 119315 120871 121800 122660 (view as bug list)
Depends on:
Blocks: Regressions-imageHandling
  Show dependency treegraph
 
Reported: 2020-02-06 08:51 UTC by Fridrich Strba
Modified: 2020-06-01 14:18 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
flat ODG file that shows the regression (875.04 KB, application/vnd.oasis.opendocument.graphics-flat-xml)
2020-02-06 08:51 UTC, Fridrich Strba
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fridrich Strba 2020-02-06 08:51:41 UTC
Created attachment 157687 [details]
flat ODG file that shows the regression

The attached flat ODG file has 3 rectangles, all with bitmap fills. They are not rendered as bitmap fills and the fill is white, although when one clicks on the shape and tries to see the "Area", it is "bitmap", but no preview at all. This file renders well in 3.5.
Comment 1 Miklos Vajna 2020-02-06 09:05:36 UTC
I can reproduce this on master (core.git b2d9603bc02db3a6711948274c5fa2b5cf148d48), and not on 3.5 (core.git d6cde02dbce8c28c6af836e2dc1120f8a6ef9932, from 2011).
Comment 2 Aron Budea 2020-02-09 19:19:21 UTC
Bibisected to the following commits using repo bibisect-linux-64-6.1. First grey rectangles are shown instead of bitmaps, and they turn white with the second commit. Adding CC: to Tomaž Vajngerl.

Adding a couple of other bugs that can be traced back to the same commit(s) in see also.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=e02efb621fe672aa52e56caa916cf5c3fd0a9cb8
author		Tomaž Vajngerl <tomaz.vajngerl@collabora.co.uk>	2018-02-01 15:28:53 +0900
committer	Tomaž Vajngerl <quikee@gmail.com>	2018-02-01 11:54:22 +0100

"Change bitmap table to store XBitmap instead of GraphicObject URL"

https://cgit.freedesktop.org/libreoffice/core/commit/?id=3400424877032595490f38711b5e8520ed889fee
author		Tomaž Vajngerl <tomaz.vajngerl@collabora.co.uk>	2018-02-26 11:15:37 +0900
committer	Tomaž Vajngerl <quikee@gmail.com>	2018-02-26 06:04:43 +0100

"xmloff: remove unused code when loading/saving the bitmap table"
Comment 3 Commit Notification 2020-05-20 07:03:03 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/96baf8c69330d50af7d31ab9838bcd0ec7c8c50b

tdf#130479 FODG import: fix handling of <draw:fill-image> in styles

It will be available in 7.0.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Aron Budea 2020-05-21 05:20:48 UTC
*** Bug 120871 has been marked as a duplicate of this bug. ***
Comment 5 Aron Budea 2020-05-21 05:24:06 UTC
*** Bug 119315 has been marked as a duplicate of this bug. ***
Comment 6 Aron Budea 2020-05-21 05:26:55 UTC
*** Bug 118066 has been marked as a duplicate of this bug. ***
Comment 7 Aron Budea 2020-05-21 05:29:40 UTC
*** Bug 117598 has been marked as a duplicate of this bug. ***
Comment 8 Aron Budea 2020-05-21 05:36:16 UTC
*** Bug 122660 has been marked as a duplicate of this bug. ***
Comment 9 Aron Budea 2020-05-21 05:38:41 UTC
*** Bug 121800 has been marked as a duplicate of this bug. ***
Comment 10 Commit Notification 2020-05-23 14:31:12 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-6-4":

https://git.libreoffice.org/core/commit/a97cbe7221c0175a4a2d342e2d1a62b06af4e13a

tdf#130479 FODG import: fix handling of <draw:fill-image> in styles

It will be available in 6.4.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Xisco Faulí 2020-06-01 14:18:43 UTC
Verified in

Version: 7.0.0.0.beta1+
Build ID: 2506d8221dd940dfd93d3d7c183430ba6ba3089d
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Miklos, thanks for fixing this issue!!