Bug 117598 - Pattern fill goes missing when pasting between LibO applications
Summary: Pattern fill goes missing when pasting between LibO applications
Status: RESOLVED DUPLICATE of bug 130479
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Object-Fill-Pattern Regressions-imageHandling
  Show dependency treegraph
 
Reported: 2018-05-13 12:03 UTC by Telesto
Modified: 2020-05-21 05:39 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Call stack (5.91 KB, text/plain)
2018-05-14 01:02 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2018-05-13 12:03:20 UTC
Description:
Maybe converted already with the list of copy/paste issues.. but just in case

Steps to Reproduce:
1. Insert a shape - smiley for example
2. Add a pattern fill to the shape
3. Copy the shape
4. Open Calc
5. Paste -> Blue; no pattern fill

Actual Results:  
Missing pattern file

Expected Results:
A pattern fill


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.1.0.0.alpha1+
Build ID: c5f8a296fcfc08f8ac441cb8300a7565caa50b53
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-05-10_03:01:48
Locale: nl-NL (nl_NL); Calc: CL

Not in
Version: 6.0.0.1.0+
Build ID: 47cc374c0659fd3db74a1b184c870eaa56bc385b
CPU threads: 4; OS: Windows 6.3; UI render: default; 
Locale: nl-NL (nl_NL); Calc: CL


User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
Comment 1 Regina Henschel 2018-05-14 01:02:26 UTC
Created attachment 142083 [details]
Call stack

It is OK in Version: 6.0.4.2 (x64)
Build ID: 9b0d9b32d5dcda91d2f1a96dc04c645c450872bf
CPU threads: 8; OS: Windows 10.0; UI render: default; 
Locale: de-DE (de_DE); Calc: CL

I get the described behavior in Version: 6.1.0.0.alpha1+ (x64)
Build ID: 5e34e3741de8aae10bf30889c227581818276186
CPU threads: 8; OS: Windows 10.0; UI render: default; 
Locale: de-DE (de_DE); Calc: CL
and a failed assertion and crash
Ausgelöste Ausnahme: Lesezugriffsverletzung
"this->pImpl._Mypair.**_Myval2**" war "nullptr".
Call stack is attached. 






and a crash in
Version: 6.1.0.0.alpha0+ (x64)
Build ID: 55b9706bea5aa9b654ab39bc7d56339422e17087
CPU threads: 8; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-04-18_06:02:46
Locale: de-DE (de_DE); Calc: CL
Comment 2 raal 2018-05-14 14:00:16 UTC
This seems to have begun at the below commit.
Adding Cc: to Tomaž Vajngerl; Could you possibly take a look at this one? Thanks
 17b7baa8664f81722fb1e6cfbebc94de93f74514 is the first bad commit
commit 17b7baa8664f81722fb1e6cfbebc94de93f74514
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Thu Feb 1 04:53:03 2018 -0800

    source sha:e02efb621fe672aa52e56caa916cf5c3fd0a9cb8
author    Tomaž Vajngerl <tomaz.vajngerl@collabora.co.uk>    2018-02-01 15:28:53 +0900
committer    Tomaž Vajngerl <quikee@gmail.com>    2018-02-01 11:54:22 +0100
commit    e02efb621fe672aa52e56caa916cf5c3fd0a9cb8 (patch)
tree    725947b541b4774722d9d4a9d11a2ac58463a753
parent    a61747c2c375d1fe404c976d2a03125e4dc78d8f (diff)
Change bitmap table to store XBitmap instead of GraphicObject URL
Comment 3 Xisco Faulí 2018-06-05 21:47:24 UTC Comment hidden (obsolete)
Comment 4 Xisco Faulí 2018-06-05 21:56:29 UTC
Sorry for my previous comment, I can still reproduce it in

Version: 6.2.0.0.alpha0+
Build ID: 48b49937fed5e50d299a94063eb325799ff672e9
CPU threads: 1; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-06-05_01:47:06
Locale: es-ES (es_ES); Calc: group threaded

but not the crash...
Comment 5 Xisco Faulí 2018-06-05 22:00:42 UTC
I can reproduce the crash in

Version: 6.1.0.0.alpha0+
Build ID: 55b9706bea5aa9b654ab39bc7d56339422e17087
CPU threads: 16; OS: Windows 6.3; UI render: default; 
Locale: en-GB (en_GB); Calc: group

but not

Version: 6.1.0.0.beta1+
Build ID: 91d8af2c5cf4e8ec0f1ce0e532e0c896de77750b
CPU threads: 16; OS: Windows 6.3; UI render: default; 
Locale: en-GB (en_GB); Calc: group threaded

so at least the crash is fixed. Good news!!
Comment 6 QA Administrators 2019-06-09 03:02:00 UTC Comment hidden (obsolete)
Comment 7 Aron Budea 2020-05-21 05:29:40 UTC
This got fixed between yesterday and today's daily build, must be because of bug 130479's fix. Marking as duplicate.

*** This bug has been marked as a duplicate of bug 130479 ***