Bug 118066 - 3D object is blue when it's pasted to another component
Summary: 3D object is blue when it's pasted to another component
Status: RESOLVED DUPLICATE of bug 130479
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha1+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
: 117911 (view as bug list)
Depends on:
Blocks: Regressions-imageHandling
  Show dependency treegraph
 
Reported: 2018-06-08 10:40 UTC by Xisco Faulí
Modified: 2020-05-21 05:39 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
How it looks in 6.2 master (14.34 KB, image/png)
2018-06-08 10:40 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2018-06-08 10:40:16 UTC
Created attachment 142614 [details]
How it looks in 6.2 master

Steps to Reproduce:
1. Launch Draw
2. Insert or any other image https://wiki.documentfoundation.org/images/0/01/BHS_large_6.1_beta1_test.png
3. Convert to 3D object 
4. Copy it
5. Open Writer
6. Paste it

-> The 3D object is totally blue

Reproduced in

Version: 6.2.0.0.alpha0+
Build ID: 2a7f74900fb646235b74d4c9bd4690e44edc3ed4
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded
Comment 1 Xisco Faulí 2018-06-08 10:52:23 UTC
Regression introduced by:

author	Tomaž Vajngerl <tomaz.vajngerl@collabora.co.uk>	2018-02-01 15:28:53 +0900
committer	Tomaž Vajngerl <quikee@gmail.com>	2018-02-01 11:54:22 +0100
commit e02efb621fe672aa52e56caa916cf5c3fd0a9cb8 (patch)
tree 725947b541b4774722d9d4a9d11a2ac58463a753
parent a61747c2c375d1fe404c976d2a03125e4dc78d8f (diff)
Change bitmap table to store XBitmap instead of GraphicObject URL
As we want to get rid of GraphicObject URLs for the more robust
image life-cycle handling, it was necessary to change the way
bitmap table stores and handles images, so that they always
store a Graphic object (wrapped in UNO object that provides the
XGraphic and XBitmap interface).

In addition this changes loading and saving from ODF (xmloff) and
OOXML (oox) filters so they don't depend on GraphicObject URL
anymore, but load or save directly to / from  XGraphic or XBitmap.

Bisected with: bibisect-linux64-6.1

Adding Cc: to Tomaž Vajngerl
Comment 2 Telesto 2018-06-08 12:11:11 UTC
*** Bug 117911 has been marked as a duplicate of this bug. ***
Comment 3 Roman Kuznetsov 2018-06-08 13:16:15 UTC
men, tools Convert to Curve (3-D, 3-D rotation object, etc) should use for drawn shapes.
converting any image to curve (or another mode) isn't right
it is possible, but it is not necessary to do
Comment 4 Xisco Faulí 2019-02-06 11:59:39 UTC
Still reproducible in

Version: 6.3.0.0.alpha0+
Build ID: 202d9af5ab4291a8f867791293477a18ae48051d
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded
Comment 5 Aron Budea 2020-05-21 05:26:55 UTC
This got fixed between yesterday and today's daily build, must be because of bug 130479's fix. Marking as duplicate.

*** This bug has been marked as a duplicate of bug 130479 ***