Download it now!
Bug 119341 - FILEOPEN: Hang loading a document (gtk/gtk3)
Summary: FILEOPEN: Hang loading a document (gtk/gtk3)
Status: RESOLVED DUPLICATE of bug 118967
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.1.0.3 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, perf, regression
Depends on:
Blocks: Regressions-AW080
  Show dependency treegraph
 
Reported: 2018-08-18 09:10 UTC by marin
Modified: 2018-09-22 18:56 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
ppt files (150.65 KB, application/wps-office.pptx)
2018-08-20 14:32 UTC, marin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description marin 2018-08-18 09:10:01 UTC
libreoffice6.1.0中的impress加载和保存超慢卡顿假死机,在加载ppt和保存ppt的时候,在ppt页数比较多的时候,大概7-8页,那么打开加载就会卡顿假死机,保存的时候也是,当页数较多的时候,往下拉列表框的时候,同样也会卡顿假死机,可能是正在后台加载。而同一个pptx文件,在wps中加载非常快,在libreoffice6.0.6版本虽然比wps慢一点,但是也很快了,不会出现6.1.0的情况。请排查。
Comment 1 marin 2018-08-18 09:10:44 UTC
libreoffice6.1.0中的impress加载和保存超慢卡顿假死机,在加载ppt和保存ppt的时候,在ppt页数比较多的时候,大概7-8页,那么打开加载就会卡顿假死机,保存的时候也是,当页数较多的时候,往下拉列表框的时候,同样也会卡顿假死机,可能是正在后台加载。而同一个pptx文件,在wps中加载非常快,在libreoffice6.0.6版本虽然比wps慢一点,但是也很快了,不会出现6.1.0的情况。请排查。
Comment 2 Regina Henschel 2018-08-18 17:01:26 UTC
Please repeat your bug report in English, if possible.

Please, can you attach the file?

Can you please test, whether the file opens quicker in a "Daily-build"? You can download a daily build from https://dev-builds.libreoffice.org/daily/master/. You can install it parallel to your productive build.
Comment 3 marin 2018-08-20 04:16:56 UTC
Impress loading and saving super slow carton and false crash in libreoffice6.1.0

Slide ppt loads in impress 6.1.0.3 are very slow and bogus dead, but the same PPT file loads very quickly in wps, and in libreoffice 6.0.6 it is not as fast as in wps, nor is it 6.1.0.3. Please check it.
Comment 4 marin 2018-08-20 04:17:14 UTC Comment hidden (obsolete)
Comment 5 Regina Henschel 2018-08-20 11:55:15 UTC
Please add an example file. That makes it much easier to confirm the bug and helps the developers a lot to fix the bug.
Comment 6 marin 2018-08-20 14:32:47 UTC
Created attachment 144332 [details]
ppt files

I use other ppt files to test, other files do not have the situation I mentioned, will it be my PPT file primitives more, slow parsing?
Comment 7 Xisco Faulí 2018-08-21 11:58:57 UTC
Reproduced in

Version: 6.2.0.0.alpha0+
Build ID: 4a0ca73c31990568bf20a1c3f0906c3a5770a38e
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded

but not in

Version: 6.2.0.0.alpha0+
Build ID: 4a0ca73c31990568bf20a1c3f0906c3a5770a38e
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: x11; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded
Comment 8 Xisco Faulí 2018-08-21 12:29:48 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=6c14c27c75a03e2363f2b363ddf0a6f2f46cfa91

author	Armin Le Grand <Armin.Le.Grand@cib.de (CIB)>	2018-03-01 15:54:32 +0100
committer	Armin Le Grand <Armin.Le.Grand@cib.de>	2018-04-06 22:29:02 +0200
commit	6c14c27c75a03e2363f2b363ddf0a6f2f46cfa91 (patch)
tree	e66f50adb222dbc1490b4df2d3c63541dad999ac
parent	e1b247a843c5eb850fe0079819239d9883412d38 (diff)
SOSAW080: Added first bunch of basic changes to helpers

Bisected with: bibisect-linux64-6.1

Adding Cc: to Armin Le Grand
Comment 9 marin 2018-08-21 13:05:42 UTC
OS : linux 4.17
VCL : gtk3
Comment 10 Buovjaga 2018-09-22 18:00:04 UTC
Loads in 2-3 seconds for me. No hang. Please test with a fresh build. Tested gtk3 and gtk3_kde5

Arch Linux 64-bit
Version: 6.2.0.0.alpha0+
Build ID: 0ffa7a733d834647dfd59b864c52a015028822b6
CPU threads: 8; OS: Linux 4.18; UI render: default; VCL: gtk3_kde5; 
Locale: fi-FI (fi_FI.UTF-8); Calc: threaded
Built on September 21st 2018
Comment 11 Xisco Faulí 2018-09-22 18:30:25 UTC
Fixed by https://cgit.freedesktop.org/libreoffice/core/commit/?id=6b669c9d9ee61c5c37c384c3a546467a048f5636
Closing as RESOLVED DUPLICATED of bug 118967

*** This bug has been marked as a duplicate of bug 118967 ***
Comment 12 Xisco Faulí 2018-09-22 18:41:48 UTC
(In reply to Xisco Faulí from comment #11)
> Fixed by
> https://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=6b669c9d9ee61c5c37c384c3a546467a048f5636
> Closing as RESOLVED DUPLICATED of bug 118967
> 
> *** This bug has been marked as a duplicate of bug 118967 ***

I've just noticed one thing, if the file is open and close, the 'do you want to save the document' dialog is displayed now...
Comment 13 Xisco Faulí 2018-09-22 18:56:12 UTC
> I've just noticed one thing, if the file is open and close, the 'do you want
> to save the document' dialog is displayed now...

Reported in bug 120066