Bug 119367 - UI / german translation: dialogues in english
Summary: UI / german translation: dialogues in english
Status: NEEDINFO
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
5.4.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: kirikoo007
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-08-19 17:44 UTC by gambacherkalbenstein
Modified: 2020-05-02 12:19 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
German language package (78.84 KB, image/png)
2018-08-19 18:16 UTC, BogdanB
Details
setting in many languages (38.18 KB, image/png)
2019-12-28 11:06 UTC, kirikoo007
Details
setting in many languages (38.18 KB, image/png)
2019-12-28 11:11 UTC, kirikoo007
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gambacherkalbenstein 2018-08-19 17:44:25 UTC
since that version shown above, all (!!) of the dialogues - the sidebar aswell - are shown in english, while i am useing the german version of LO.
Comment 1 BogdanB 2018-08-19 18:16:14 UTC
Created attachment 144307 [details]
German language package

You can download separate the translation package:
see the screenshot (Übersetzte Benutzeroberfläche: Deutsch (Torrent, Info))
Comment 2 gambacherkalbenstein 2018-08-19 18:18:09 UTC
i need to add that i usually use the translation shipping with the installer - this should work out of the box...
Comment 3 gambacherkalbenstein 2018-08-19 18:22:28 UTC
ps: with neither firefox or chrome i can see that translation package under "supplementary downloads"
Comment 4 Julien Nabet 2018-08-19 18:37:34 UTC
On which env are you?
Last LO version is 6.0.6 or brand new 6.1.0
Comment 5 BogdanB 2018-08-19 19:31:38 UTC
(In reply to gambacherkalbenstein from comment #3)
> ps: with neither firefox or chrome i can see that translation package under
> "supplementary downloads"

https://de.libreoffice.org/download/download/
Comment 6 BogdanB 2018-08-19 19:33:53 UTC
(In reply to BogdanB from comment #5)
> (In reply to gambacherkalbenstein from comment #3)
> > ps: with neither firefox or chrome i can see that translation package under
> > "supplementary downloads"
> 
> https://de.libreoffice.org/download/download/

Sorry, I have seen now it's only for linux in separate package. I dont know for windows. Wait for another person to answeer that.
Comment 7 gambacherkalbenstein 2018-08-19 20:37:22 UTC
i am now on 6.1 on win 10 - sorry for that.

even tried with several versions: prior, back to (then) "now", x86 or x64 ...
Comment 8 BogdanB 2018-08-19 21:16:50 UTC
Try this
https://wiki.documentfoundation.org/UserProfile

Or, after that uninstall Libre Office. And install a stable version again. 6.0.6 maybe

On linux stable and old versions have translations, but newer and fresh versions have the translation in separate package.
Comment 9 gambacherkalbenstein 2018-08-20 09:10:49 UTC
thanks for that hint; i tried it on win 10 - nothing changing

a new try: restart the setup, selected "change" and unchecked the english versions ... no success

maybe it has something to do wit h LO being installed in a filepath with a german umlaut ü...? otherwise that doesn't happen with OOo 4.x ...
Comment 10 Xisco Faulí 2018-09-17 11:36:38 UTC
Dear reporter,
Could you please make sure german is selected as UI language in Tools - Options - Language Settings - Language - User interface?

OTOH, could you please confirm you download the installer from https://www.libreoffice.org/download/libreoffice-fresh/?type=win-x86&version=6.1&lang=de ?

Setting to NEEDINFO until the questions above are answered!
Comment 11 gambacherkalbenstein 2018-09-17 12:30:45 UTC
hi,

i just installed the latest version:

Version: 6.1.1.2 (x64)
Build ID: 5d19a1bfa650b796764388cd8b33a5af1f5baa1b
CPU threads: 8; OS: Windows 10.0; UI render: GL; 
Locale: de-DE (de_DE); Calc: CL

and set "german" as language as advised. still english language in dialogues.
Comment 12 Thomas Lendo 2018-09-19 22:13:34 UTC
Have you renamed or deleted your user profile directory for LibreOffice? Only with a fresh installation and a fresh profile we can exclude a profile problem.

What's your OS language?

Does the issue still exist when you go back to an older version of LibreOffice that worked in the past before your update to 6.0.6?
Comment 13 Xisco Faulí 2018-10-23 15:49:53 UTC
(In reply to Thomas Lendo from comment #12)
> Have you renamed or deleted your user profile directory for LibreOffice?
> Only with a fresh installation and a fresh profile we can exclude a profile
> problem.
> 
> What's your OS language?
> 
> Does the issue still exist when you go back to an older version of
> LibreOffice that worked in the past before your update to 6.0.6?

Dear Reporter,
Could you please answer the question above in order to help us triage this issue?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' once the question has been answered
Comment 14 gambacherkalbenstein 2018-10-24 13:16:42 UTC
sorry for my late answer.

yes, i deleted the profile and i reinstalled LO.
unfortunately, i do not remember the last version, where all strings were translated into german.

i even tried an older version of LO a while ago, where stuff was shown in german.

my win os language is german
Comment 15 Xisco Faulí 2019-04-30 08:42:29 UTC
A new major release of LibreOffice is available since this bug was reported.
Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 16 QA Administrators 2019-10-28 03:30:31 UTC Comment hidden (obsolete)
Comment 17 gambacherkalbenstein 2019-11-15 19:48:40 UTC
now 6.3.3.2 x64 - still valid problem ... it's getting quite annoying...

maybe it's about the installation-path (like "calibre"): it's filed under C:\Büro (german for "office"). could it be the umlaut "ü"?

and could you raise the importance-level, please? thank you.
Comment 18 kirikoo007 2019-12-28 10:54:26 UTC
hi,

I have exactly the same problem with french version. I've upda with this vers 6.2.8.2 (x64) Build ID:f82ddfca21ebc1e222a662a32b25c0c9d20169ee

i've verified languages parameters et all are in french, formulas 
formules ne sont pas cochées en anglais.

Or, les menus libre office avant démarrage d'une application calc ou vwriter
sont en anglais. après lancement de Calc les menus sont en français mais les
formules restent en anglais ...

'ai suivi le tuto renommer le dossier en local et j'ai aussi redémarré en
safe mode, pas de changement ...

J'ai ensuite tout désinstallé proprement, effacé tous les dossiers afférents
à Lo.

Redémarrer et ré-installer ....

Je pense qu'il reste quelque chose dans la base de registre ou ailleurs ....
Comment 19 kirikoo007 2019-12-28 11:06:58 UTC
Created attachment 156808 [details]
setting in many languages
Comment 20 kirikoo007 2019-12-28 11:11:16 UTC
Created attachment 156809 [details]
setting in many languages

hi,

I have exactly the same problem with french version. I've updated with this vers 6.2.8.2 (x64) Build ID:f82ddfca21ebc1e222a662a32b25c0c9d20169ee

i've verified language parameters and all are in french, formulas 
are not checked in english.

Libre office menu before starting calc ou writer application 
remains in english. After starting  menu options are in french but formulas remains in english.

i ve renamed local folder, i've have restarted in safe mode, no changes...

i've all uninstalled and deleted all Lo folders, cleaned the registrery.

I ve restarted windows 10 and began a new installation but the problem is still the same ...

So i cannot use my files with french formulas ... LO does not "understand" them ...

Sorry for my english ...

fred
Comment 21 campo.felice 2020-02-11 09:42:07 UTC
Hello,

I have this problem too.
OS: Windows 7, local de_DE, LibreOffice 6.3.4.2 portable ( see attachment 1: ) !!

LibreOffice 6.3.4.2 portable loaded from -> all same problem
https://portableapps.com/de/apps/office/libreoffice_portable or
https://de.libreoffice.org/download/portable-versions

Windows 10 1909 in VM -> same problem
older LibreOffice-Versions -> same problem

If you have german umlauts in application path ( e.g ~\Downloads\Büro\LibreOfficePortable ) the UI shows mixed languages ( german / english ) in menue, english in splash, sidebars, config, errors, etc.. ( see attachment 2/3: )

Opening or storing files in directories with umlauts is working well.

If I skip german umlauts and change application path to e.g. ~\Downloads\Buero\LibreOfficePortable everything works well. ( see attachment 4: )

There is just another drawback, when I work with umlauts in application pathnames. If I start libreoffice ( having mixed languages ) and try to enter options in menue, I receive error message from gpgME. Afterwards libreoffice crashes. Suppose this has another reason than language confusion ( see attachment 5: )

Attachments will be send on your request. Hope that helps to locate the error.
Felix
Comment 22 Ming Hua 2020-05-02 12:19:35 UTC
There are now three people reporting similar problems in this bug.  Some of you may want to read or comment on bug 94090, since that one seems to be getting more attention from developers.

It also probably shouldn't belong to the localization component, but I'm leaving it there for now.