Bug 119408 - Fails to start Draw, Impress due to new Avahi dependency
Summary: Fails to start Draw, Impress due to new Avahi dependency
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
(earliest affected) release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
: 121846 150559 (view as bug list)
Depends on:
Blocks: Network
  Show dependency treegraph
Reported: 2018-08-21 21:53 UTC by lj618
Modified: 2024-05-29 04:40 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Note You need to log in before you can comment on or make changes to this bug.
Description lj618 2018-08-21 21:53:10 UTC
Using the official LibreOffice-6.0.6 32-bit Linux builds from
www.libreoffice.org, Draw fails to start with this message:
   Error: Component cannot be loaded, possibly broken or incomplete
   installation. Full error message: loading component library
   <file:///opt/libreoffice6.0/program/../program/libsdlo.so> failed.

Impress also fails to start, but with no error message.

This occurs on distributions such as Slackware Linux, which do not include Avahi.

Steps to Reproduce:
1. libreoffice6.0 --draw
2. libreoffice6.0 --impress

Actual Results:
Draw fails to start, and exits with error message.
Impress fails to start, and just hangs forever with no window and no message.

Expected Results:
Draw starts.
Impress starts.

Reproducible: Always

User Profile Reset: No

Additional Info:
The cause is a newly introduced dependency of the Linux builds on Avahi (libavahi). The change to LibreOfficeLinux.conf was made 2018-05-19 and does not seem to be linked to a specific bug report nor documented in the release notes.

Here are 3 suggested ways to address this, from most desirable to least:

1. Change Draw and Impress to automatically detect availability of Avahi at runtime. If the library cannot be loaded, disable the remote-control feature in Impress, which seems to be the only use for Avahi. Draw does not seem to need Avahi for any function.

2. Revert the change and distribute Linux binaries that do not require Avahi and do not have the remote control Impress feature. Note that lack of support in Linux builds is documented in https://wiki.documentfoundation.org/Documentation/HowTo/Impress_Remote_%28iOS%29

3. Document Avahi as a required external dependency of the distributed Linux builds. Users of Linux distributions without Avahi will have to use builds from elsewhere.
Comment 1 Xisco Faulí 2019-01-10 12:17:20 UTC
A new major release of LibreOffice is available since this bug was reported.
Could you please try to reproduce it with the latest version of LibreOffice
from https://www.libreoffice.org/download/libreoffice-fresh/ ?
I have set the bug's status to 'NEEDINFO'. Please change it back to
'UNCONFIRMED' if the bug is still present in the latest version.
Comment 2 lj618 2019-01-10 22:46:33 UTC
CONFIRMED still a bug in 6.1.4
Status changed back to UNCONFIRMED as requested.
Comment 3 raal 2019-01-24 20:32:47 UTC
*** Bug 121846 has been marked as a duplicate of this bug. ***
Comment 4 raal 2019-01-24 20:34:02 UTC
Confirmed with duplicate bug
Comment 5 Emilio 2019-01-26 09:55:06 UTC
Solved installing Avahi
Comment 6 QA Administrators 2021-01-26 05:11:53 UTC Comment hidden (obsolete)
Comment 7 lj618 2021-01-26 22:05:59 UTC
Confirmed bug still exists. Draw will not start (with non-helpful error message) if Avahi is not present, even though Draw does not use Avahi. Impress will not start (with no message at all) if Avahi is not present. Avahi is apparently only used for remote control of Impress. Avahi should be conditionally loaded, only if needed.

From Help > About:

Build ID: 639b8ac485750d5696d7590a72ef1b496725cfb5                 
CPU threads: 2; OS: Linux 5.10; UI render: default; VCL: gtk3;
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded
Comment 8 Eric 2022-08-23 13:37:24 UTC
Bug still exists in (184fe81b8c8c30d8b5082578aee2fed2ea847c01), see also bug 150559

Impress will not start, Generates error

-- Component cannot be loaded, possibly broken or incomplete installation.
-- Full error message:
-- loading component library
-- <file:///opt/libreoffice7.3/program/../program/libsdlo.so> failed
-- /home/buildslave/source/libo-core-cppuhelper/source/shlib.css:311
Comment 9 Eric 2022-08-23 13:43:49 UTC
*** Bug 150559 has been marked as a duplicate of this bug. ***
Comment 10 Ian Huang 2022-08-27 20:27:27 UTC
I just did a system upgrade and now I can reproduce this as well. What's interesting is that Avahi is actually running for me, and is properly linked into libsdlo as far as I can tell. Can reproduce on both 7.4.0 and 7.3.5 in Archlinux. The Flatpak works fine, somehow.

I've talked to some people on #archlinux:libera.chat and they can't reproduce this issue, which is really weird.... I've tried a new user, safe mode, reinstalling, etc.
Comment 11 Graham Perrin 2022-09-07 06:21:54 UTC

FreeBSD bug 266262 – editors/libreoffice: fails to start Draw, Impress

See also: bug 139825
Comment 12 aisyk 2022-09-12 08:24:55 UTC
Confirmed bug on PopOS 22.04

LibreOffice don't start.

terminate called after throwing an instance of 'com::sun::star::uno::RuntimeException'

Fatal exception: Signal 6
Comment 13 Stéphane Guillou (stragu) 2024-05-29 04:40:19 UTC
Cloph, seeing c488328fd27a883e730d1eda47c4a4d2c07f3585, any comment on this? Or any idea what could have started it before it being explicitly enabled?