Bug Hunting Session
Bug 119449 - Formula editor should allow Latex notation
Summary: Formula editor should allow Latex notation
Status: RESOLVED DUPLICATE of bug 96208
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
6.1.0.3 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-08-23 13:13 UTC by brian.bj.parker99
Modified: 2019-09-07 14:24 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description brian.bj.parker99 2018-08-23 13:13:50 UTC
Description:
The syntax used to enter math equations in LO formula is apparently based on the largely obsolete troff eqn preprocessor. 
For example:
 x sup y sub z

Latex syntax is the standard format used to enter equations in modern applications, including Microsoft Word, wikipedia, mathjax etc.
Surprisingly, LO syntax also allows some latex notation, for example:
x^y_z  
which gives the same superscript and subscript as the above example. 
However, most other latex constructs fail e.g. \Lambda  as the latex equivalent of %LAMBDA.

As an enhancement request, the LO Formula editor math syntax should be expanded to include all standard Latex forms (including AMS-Latex) as synonyms. I can't see any fundamental ambiguities that would prevent this from being almost fully backwards compatible.
This would allow published latex formulae to be cut and pasted directly in LO presentations etc. and would increase compatibility with Microsoft Word.


Actual Results:
For example \Lambda is not accepted in the formula editor.

Expected Results:
Expected the same result as %LAMBDA


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 V Stuart Foote 2018-08-24 01:15:49 UTC

*** This bug has been marked as a duplicate of bug 73593 ***
Comment 2 V Stuart Foote 2018-08-26 14:24:55 UTC

*** This bug has been marked as a duplicate of bug 96208 ***