Bug 119476 - LO Impress hangs when unformatted text is over-pasted
Summary: LO Impress hangs when unformatted text is over-pasted
Status: RESOLVED DUPLICATE of bug 115438
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha1+
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2018-08-24 10:00 UTC by Robert Simpson
Modified: 2018-08-25 17:45 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Simpson 2018-08-24 10:00:19 UTC
Description:
When text is pasted into a text box, overwriting existing text, and using 'Paste Special-Unformatted', if the overwritten text comprises more than one line, then impress hangs. 

Steps to Reproduce:
1.create new impress file
2.create a textbox and enter text with more than one line
3.select the text
4.copy the text (or any text, say text from a .odt)
5.with text in textbox still selected, 'Edit-Paste Special' and select 'Unformatted Text

Actual Results:
impress freezes requiring a 'force quit'

Expected Results:
text in textbox should be overwritten


Reproducible: Always


User Profile Reset: No



Additional Info:
Normal Paste, or other forms of Paste Special do not cause the problem.

Workaround:
Delete the existing text before pasting the new.
(But it's a bore)
Comment 1 Xisco Faulí 2018-08-25 16:41:45 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=5131f5ba19ebc5de17139dbcf373866a9b155b2b

author	Armin Le Grand <Armin.Le.Grand@cib.de>	2017-08-10 20:08:56 +0200
committer	Armin Le Grand <Armin.Le.Grand@cib.de>	2017-08-11 08:51:43 +0200
commit	5131f5ba19ebc5de17139dbcf373866a9b155b2b (patch)
tree	627beb6b4b636e0161ba92ecf7fc3005a2c3b983
parent	46b4eb8b0e9325f8c29cd391baf9504bccee1837 (diff)
editviewoverlay: corrected AttributeChange
EditView on Overlay visualization needs to handle
selection change when e.g. FontSize attribute of
a selected text portion changes. Changed handling
so that selection overlay is an integral part of
text visualization overlay and refreshing text
visualization always refreshes selection visuals,
but not the other way around. Both anyways check
for real change, so just extra testing is avoided
which is still the better solution

Bisected with: bibisect-linux64-6.0

Adding Cc: to Armin Le Grand
Comment 2 Paul Trojahn 2018-08-25 17:45:15 UTC

*** This bug has been marked as a duplicate of bug 115438 ***