Bug 119479 - Editing with external tool breaks image
Summary: Editing with external tool breaks image
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
(earliest affected)
5.1 all versions
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
Keywords: bibisected, regression
: 120723 (view as bug list)
Depends on:
Blocks: Files-Linked
  Show dependency treegraph
Reported: 2018-08-24 13:13 UTC by Justin L
Modified: 2023-05-11 14:42 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:

draw-copyPage.odg: 4 pages with images (78.15 KB, application/vnd.oasis.opendocument.graphics)
2018-08-24 13:13 UTC, Justin L

Note You need to log in before you can comment on or make changes to this bug.
Description Justin L 2018-08-24 13:13:41 UTC
Created attachment 144412 [details]
draw-copyPage.odg: 4 pages with images

Edited images (saved in /tmp/*.png) using GIMP, Pinta, or Shotwell result in a broken link instead of an edited image. However, if the /tmp/*.png image is round-tripped by Gnome image viewer, then the image re-appears in Draw.

Also, I noted that the "broken" tmp file can be used to successfully replace an image, so LO is able to handle that image in general, but just not as a replacement during the "edit with external tool" process.

Tested with Ubuntu 16.04 and 18.04 with 6.0 alpha and 6.2 master.
Comment 1 Aron Budea 2018-08-24 13:23:49 UTC
Confirmed based on bug 103455 comment 5.
Comment 2 Justin L 2018-08-24 14:10:58 UTC
bibisect-linux-dbg-51 shows this worked until the day of https://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=782c116b5ac39aef27c3a00f7fc145c9f755e3a3..c8344322a7af75b84dd3ca8f78b05543a976dfd5

In this range we see another idle bug (see bug 103455)!  Suspicious, although I don't know how to reconcile that with being able to "fix" the problem by replacing the /tmp/png with a "good" image or using gnome-viewer.

author	Michael Meeks
commit 48c2815dd20cf20eeec8bb4e003000f4a3d13291 (patch)
tdf#91727 - Unwind non-dispatch of idle handlers.

Comments suggest that Michael's patch is only for Linux. Can someone test to see if this external editing problem can be seen in Windows (although I don't know which applications to test with since even in Linux at least one application is known to work...)
Comment 3 Xisco Faulí 2018-08-25 16:06:53 UTC
Adding regression and bibisected keywords...
Comment 4 Justin L 2018-09-01 06:23:58 UTC
jmux just did some timing patches, but those have not resolved this issue.
Comment 5 Buovjaga 2019-02-17 17:38:42 UTC
*** Bug 120723 has been marked as a duplicate of this bug. ***
Comment 6 Justin L 2020-04-03 08:57:06 UTC
confirmed still broken in 7.0 master
Comment 7 Justin L 2021-08-20 12:33:18 UTC
confirmed (with gimp) still broken in 7.3+
Comment 8 Cedric Sodhi 2021-10-06 15:11:25 UTC
Hit the same bug in current stable of Writer in Fedora 34. LIbreOffice Draw and Gimp being the editors, both time the image returns as a "Read Error" into LibreOffice!
Comment 9 Justin L 2023-05-11 00:05:15 UTC
It worked most of the time for me today. I was bibisecting in 7.3 and it seemed like I was narrowing down to a specific commit. But then when I went back previously non-working commits, then they were working. Then I checked out oldest of 7.3 and it worked too. So not sure what is going on here.

Using Gimp and Ubuntu 20.04 still.