Download it now!
Bug 119485 - Scrolling performance in multi page view with large amount of comments slow and comment boxes are flickering (repaints)
Summary: Scrolling performance in multi page view with large amount of comments slow a...
Status: RESOLVED DUPLICATE of bug 61558
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: perf, preBibisect, regression
Depends on:
Blocks: Writer-Comments
  Show dependency treegraph
 
Reported: 2018-08-24 18:48 UTC by Telesto
Modified: 2019-02-15 11:44 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Sample file (10.01 KB, application/vnd.oasis.opendocument.text)
2018-08-24 18:49 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2018-08-24 18:48:23 UTC
Description:
Scrolling performance in multi page view with large amount of comments slow and comment boxes are flickering (repaints)

Steps to Reproduce:
1. Open the attached file
2. Zoom out (3 pages or more) in one row
3. Scroll down

Actual Results:
Repaints of the comment boxes (over and over)
Slow scrolling

Expected Results:
Snappy scrollling


Reproducible: Always


User Profile Reset: No



Additional Info:
Found in
Version: 6.2.0.0.alpha0+
Build ID: 414ef6cb187dd3bbcc917dbedf3c0c1cc8668f60
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-08-20_22:43:18
Locale: nl-NL (nl_NL); Calc: CL

and in
Versie: 4.4.7.2 
Build ID: f3153a8b245191196a4b6b9abd1d0da16eead600
Locale: nl_NL

also in
Versie: 4.1.0.4 
Build ID: 89ea49ddacd9aa532507cbf852f2bb22b1ace28

and in
LibreOffice 3.5.7.2 
Build ID: 3215f89-f603614-ab984f2-7348103-1225a5b

but not in
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 1 Telesto 2018-08-24 18:49:02 UTC
Created attachment 144417 [details]
Sample file
Comment 2 Buovjaga 2018-09-20 08:49:16 UTC
Looks like it is already in 3.5.0 (Win).

Arch Linux 64-bit
Version: 6.2.0.0.alpha0+
Build ID: 05db125c57ea3c8f04a304561209c32cc5c45a67
CPU threads: 8; OS: Linux 4.18; UI render: default; VCL: gtk3_kde5; 
Locale: fi-FI (fi_FI.UTF-8); Calc: threaded
Built on September 17th 2018
Comment 3 Buovjaga 2019-02-15 11:44:27 UTC

*** This bug has been marked as a duplicate of bug 61558 ***