Download it now!
Bug 119530 - Embedded diagram from .DOC/.DOCX opens read-only from 6.2
Summary: Embedded diagram from .DOC/.DOCX opens read-only from 6.2
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Aron Budea
URL:
Whiteboard: target:6.2.0
Keywords: bibisected, bisected, regression
Depends on:
Blocks: OLE-Objects
  Show dependency treegraph
 
Reported: 2018-08-27 08:12 UTC by Timur
Modified: 2020-01-27 07:23 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Timur 2018-08-27 08:12:19 UTC
Open DOC attachment 52631 [details] from Bug 42112 or .DOCX attachment 144474 [details] from Bug 119529. 
Double click diagram to open embedded document. 
Could be open and edited with 6.1, but opens read-only in 6.2+ so we cannot edit it.

Not sure if regression or on purpose because editing is wrong. 

Note: if one has MSO, depending on settings, double click can open MSO but it should open LO, as can be seen where there's no MSO.
Comment 1 Dieter 2018-08-27 09:07:28 UTC
I confirm it with the doc-File. When I save it as odt and reopen it, I have the same result.
Comment 2 raal 2018-08-27 18:20:30 UTC
This seems to have begun at the below commit.
Adding Cc: to Aron Budea  ; Could you possibly take a look at this one?
Thanks

9879ac3f90c7b96efeb13e0b69f7638d88e69933 is the first bad commit
commit 9879ac3f90c7b96efeb13e0b69f7638d88e69933
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Fri Jul 13 18:52:56 2018 +0200

    source sha:c1817a5b12da642e365a3ef72b556d33c6e29a76

author	Aron Budea <aron.budea@collabora.com>	2017-08-02 03:34:24 +0200
committer	Jan Holesovsky <kendy@collabora.com>	2018-07-13 18:25:27 +0200
commit	c1817a5b12da642e365a3ef72b556d33c6e29a76 (patch)
tree	403e29251b26205f552d28272e7db91a3fbcf70f
parent	1549ff45e14fccec653c2db927393c9710173e6b (diff)
tdf#110987: type detection, binary Office formats > templates
The templates for binary MS Office formats were higher prioritized
than non-templates, this caused files in binary format and lacking
file extension to be identified as templates.
Comment 3 Aron Budea 2018-09-08 18:37:34 UTC
The commit has been reverted (it wasn't that useful), thanks for finding and bibisecting this bug!

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1bb732acc6b4d3de94f343041472ccc096723b30

Revert "tdf#110987: type detection, binary Office formats > templates"
Comment 4 Dieter 2019-09-21 12:43:25 UTC
I tried to verify the bug fix, but I couldn't open embedded document. I always got the error message "Error activating object: General OLE error."
This happened with both files in

Version: 6.4.0.0.alpha0+ (x64)
Build ID: f0c832acb53326ccc9a8c1a47401fbc9e1081feb
CPU threads: 4; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2019-09-11_05:46:53
Locale: de-DE (de_DE); UI-Language: en-US
Calc: threaded

as well as in

Version: 6.3.2.2 (x64)
Build-ID: 98b30e735bda24bc04ab42594c85f7fd8be07b9c
CPU-Threads: 4; BS: Windows 10.0; UI-Render: GL; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: threaded
Comment 5 Timur 2019-10-04 07:28:15 UTC
I tested with 6.4+.
In Linux, embedded documents open as read-only .tmp file, so not fixed.
In Windows, embedded document opens with MSO (if installed) instead with LO.
Comment 6 Aron Budea 2020-01-11 11:46:52 UTC
As you can see the fixing commit is a simple revert of the bibisected commit. Whatever the issue is, either it had been there before, or is caused by an unrelated change. Therefore this bug report can remain closed as FIXED. Please open a separate bug report.
Comment 7 Timur 2020-01-11 12:48:11 UTC
It makes no sense to open a new bug, when this one is clear in description.
Regardless of commits, issue not resolved.
I don't want to spent my time on that, for false stats.
Comment 8 Aron Budea 2020-01-11 13:56:18 UTC
As I mentioned, the commit clearly reverts the identified causing commit, and fixed the regression at the time. If the bug came back, it's a new issue, which should be in a separate bug report.
Comment 9 Aron Budea 2020-01-11 14:04:56 UTC
For the record, this issue re-emerge with the following commit, feel free to reference that in the new bug report:
https://gerrit.libreoffice.org/plugins/gitiles/core/+/65559252f138aada7a55d3c5fe0a932a222d13e0%5E%21
Comment 10 Timur 2020-01-11 15:17:21 UTC
Aron, please do not close my bug report. 
I appreciate your info, but you should appreciate anyone who bothered to write bug report, and you are not entitled to close it.
Comment 11 Aron Budea 2020-01-11 15:49:21 UTC
I am assigned to this, it was fixed after my revert, and what you are seeing now is technically not the same issue that you saw back then, the causing commit is from several months later. Please don't reopen this bug report.
Comment 12 Aron Budea 2020-01-11 16:52:52 UTC
Opened bug 129944 on the current issue.