Download it now!
Bug 119536 - LibreOffice Switches Icon Colour Profile.
Summary: LibreOffice Switches Icon Colour Profile.
Status: RESOLVED DUPLICATE of bug 119020
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.0.6.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: HiDPI
  Show dependency treegraph
 
Reported: 2018-08-27 13:26 UTC by chaphekarvardaan
Modified: 2018-08-28 15:44 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
It shows the issue, screen displays colours accurately and has a 97% srgb (71.62 KB, image/png)
2018-08-28 12:49 UTC, chaphekarvardaan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description chaphekarvardaan 2018-08-27 13:26:12 UTC
Description:
LibreOffice icons have a pink hue, my best guess is at it tries the CMYK colour format rather than RGB and messes horribly with the UI. Also if the resolution of the Icons can be made better, as they are really bad looking in high scaling. 

Steps to Reproduce:
1. Install Libre Office. 
2. Open it
3. Issue prominent

Actual Results:
Even if it shows normal colour scheme during the first time. It changes to a pink-blueish hue midway or during the second open time.

Expected Results:
Worse Colour


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
The software should accurately represent colour schemes.
Comment 1 V Stuart Foote 2018-08-27 22:39:15 UTC
Project does not use CMYK for any of its renderings to GUI.

We'd need screen clips, and as you are running with OpenGL rendering enabled, do things change if you use default rendering?

Tools -> Options -> View: uncheck "Use OpenGL for all rendering"

Also, are there issues with the other icon themes?
Comment 2 chaphekarvardaan 2018-08-28 12:46:19 UTC
(In reply to V Stuart Foote from comment #1)
> Project does not use CMYK for any of its renderings to GUI.
> 
> We'd need screen clips, and as you are running with OpenGL rendering
> enabled, do things change if you use default rendering?
> 
> Tools -> Options -> View: uncheck "Use OpenGL for all rendering"
> 
> Also, are there issues with the other icon themes?

Unchecked Open GL for all rendering but issue still persists.
Update: Issue not present in portable .exe files, only when downloaded through the msi launcher, but there shouldn't be a difference between them.
Comment 3 chaphekarvardaan 2018-08-28 12:49:00 UTC
Created attachment 144512 [details]
It shows the issue, screen displays colours accurately and has a 97% srgb

Issue shown
Comment 4 V Stuart Foote 2018-08-28 14:21:21 UTC
Are you on a HiDPI monitor (i.e. > 168dpi)?

If so this is a duplicate of bug 119020?

What is your monitor size, the resolution, and the Scaling  you have set? 

Check from Windows desktop -> Right mouse Context menu -> Display Settings

GPU & driver details would be helpful as well.  Check from a run of msinfo32.exe -> Components -> Display
Comment 5 chaphekarvardaan 2018-08-28 14:36:48 UTC
(In reply to V Stuart Foote from comment #4)
> Are you on a HiDPI monitor (i.e. > 168dpi)?
> 
> If so this is a duplicate of bug 119020?
> 
> What is your monitor size, the resolution, and the Scaling  you have set? 
> 
> Check from Windows desktop -> Right mouse Context menu -> Display Settings
> 
> GPU & driver details would be helpful as well.  Check from a run of
> msinfo32.exe -> Components -> Display

The monitor is 166ppi 1920*1080p, 13.3 inches. 
Resolution is at 1920*1080 and scaling is 150% as recommended by microsoft. 
Yes it seems to me that it is a duplicate of bug 119020. However the issue is not limited to Colibre but other styles also such as Tango. 
GPU is intel UHD 620 and the Driver version is 23.20.16.5044
Comment 6 V Stuart Foote 2018-08-28 14:48:38 UTC
Curious if reducing scaling to 100% (though making the UI small) renders the icons correctly?

But, closing as duplicate, and OP for another dupe bug 19144#c13 also reported HiDPI scaling issues with Colibre, Elementary, and Tango icon themes.

*** This bug has been marked as a duplicate of bug 119020 ***
Comment 7 chaphekarvardaan 2018-08-28 14:55:10 UTC
(In reply to V Stuart Foote from comment #6)
> Curious if reducing scaling to 100% (though making the UI small) renders the
> icons correctly?
> 
> But, closing as duplicate, and OP for another dupe bug 19144#c13 also
> reported HiDPI scaling issues with Colibre, Elementary, and Tango icon
> themes.
> 
> *** This bug has been marked as a duplicate of bug 119020 ***

Nope scaling isnt affecting the icons, also how do I fix this
Comment 8 V Stuart Foote 2018-08-28 15:15:26 UTC
(In reply to chaphekarvardaan from comment #7)
> (In reply to V Stuart Foote from comment #6)
> > Curious if reducing scaling to 100% (though making the UI small) renders the
> > icons correctly?
> > 
> > But, closing as duplicate, and OP for another dupe bug 19144#c13 also
> > reported HiDPI scaling issues with Colibre, Elementary, and Tango icon
> > themes.
> > 
> > *** This bug has been marked as a duplicate of bug 119020 ***
> 
> Nope scaling isnt affecting the icons, also how do I fix this

Thanks for checking. For now switch from default Tango icon theme (through 6.0.6) to Breeze or Sifr. Likewise from Colibre at 6.1.0 to Breeze, Sifr or Karasa Jaga.

You had marked this bug as 6.0.6.2 but your screen clip comment 3 shows Colibre is the affected icon theme--so are you on 6.0.6.2 or the 6.1.0.3 release? Maybe clip the Help -> About details text.
Comment 9 chaphekarvardaan 2018-08-28 15:34:16 UTC
I thought the issue was in 6.1 onward but when I downloaded the 6.0 version the issue was still there. and it is not limited to just Colibre, every icon style is affected.(In reply to V Stuart Foote from comment #8)
> (In reply to chaphekarvardaan from comment #7)
> > (In reply to V Stuart Foote from comment #6)
> > > Curious if reducing scaling to 100% (though making the UI small) renders the
> > > icons correctly?
> > > 
> > > But, closing as duplicate, and OP for another dupe bug 19144#c13 also
> > > reported HiDPI scaling issues with Colibre, Elementary, and Tango icon
> > > themes.
> > > 
> > > *** This bug has been marked as a duplicate of bug 119020 ***
> > 
> > Nope scaling isnt affecting the icons, also how do I fix this
> 
> Thanks for checking. For now switch from default Tango icon theme (through
> 6.0.6) to Breeze or Sifr. Likewise from Colibre at 6.1.0 to Breeze, Sifr or
> Karasa Jaga.
> 
> You had marked this bug as 6.0.6.2 but your screen clip comment 3 shows
> Colibre is the affected icon theme--so are you on 6.0.6.2 or the 6.1.0.3
> release? Maybe clip the Help -> About details text.

I thought the issue was in 6.1 onward but when I downloaded the 6.0 version the issue was still there. and it is not limited to just Colibre, every icon style is affected.
Comment 10 V Stuart Foote 2018-08-28 15:44:00 UTC
There is bug 114699 for HiDPI related icon theme scaling on Windows DE, but for now we'll close this as a clear dupe of bug 119020

*** This bug has been marked as a duplicate of bug 119020 ***