Bug 119596 - Text DrawText Contextmenu in Writer, Calc, Draw and Impress
Summary: Text DrawText Contextmenu in Writer, Calc, Draw and Impress
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.2.0
Keywords:
Depends on:
Blocks: Context-Menu
  Show dependency treegraph
 
Reported: 2018-08-29 22:50 UTC by andreas_k
Modified: 2018-11-15 22:00 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Contextmenu Text and DrawText in Writer, Calc, Draw and Impress (846.27 KB, image/png)
2018-08-29 22:50 UTC, andreas_k
Details
screenshot (50.19 KB, image/jpeg)
2018-11-13 18:34 UTC, BogdanB
Details

Note You need to log in before you can comment on or make changes to this bug.
Description andreas_k 2018-08-29 22:50:46 UTC
Created attachment 144542 [details]
Contextmenu Text and DrawText in Writer, Calc, Draw and Impress

Same structure than the other context menues

1st group: cut, copy, paste
2nd group: Text formating group
3rd group: dialogues
4rd group: style group
Comment 1 Maxim Monastirsky 2018-09-02 18:31:24 UTC
Some comments:

- Calc also have drawtext popupmenu.
- celledit can also have Paste Special menu.
- Why Special Character is only in celledit?
Comment 2 andreas_k 2018-09-02 18:41:02 UTC
Should special character be in the context menu causes ordinary there are no insert commands in the context menu.
Comment 3 Heiko Tietze 2018-09-05 08:14:04 UTC
(In reply to andreas_k from comment #2)
> Should special character be in the context menu causes ordinary there are no
> insert commands in the context menu.

I don't see a good reason to have access to special characters in the context menu. It would be necessary if you leave the edit mode by clicking the toolbar but this doesn't happen.
Comment 4 Commit Notification 2018-10-22 14:21:06 UTC
andreas kainz committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cae758a8608e584a3c73259797a70d19595c9ea6

tdf#119596 DrawText Contextmenu in Writer, Calc, Draw, Impress

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 BogdanB 2018-11-13 18:34:05 UTC
Created attachment 146602 [details]
screenshot

I don't know if it is solved. It looks different from the image from the description of the bug.

I made a screenshot from Calc.

I am waiting for an answer. I know some context menu change depending of content. Anyway it's too diferent.

Version: 6.2.0.0.alpha1+
Build ID: 7eb71f84db2f2d9a6e79a42d25bb676cf1018a90
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2018-11-12_17:12:50
Locale: ro-RO (ro_RO.UTF-8); UI-Language: en-US
Calc: threaded
Comment 6 Thomas Lendo 2018-11-15 22:00:47 UTC
I don't see many changes you proposed in attachment 144542 [details]. Have I missed something?

Edit style:

In general: I'm not happy with the 'Edit style' items (not only in the drawtext context menus) if this let's edit the 'Default' style of this style type.

This is for example the case for 'Drawing Styles' in Impress. My thoughts are the same as why I'm for the change of 'Default' paragraph style in documents to 'Text body': 'Default' in any style type should not be the standard used style. If it's the standard style, then we've the problem that also here occurs: If the user edits the 'Default' style, this has an effect to all other styles. A default style should be changed wisely and not because it's presented in a prominent area of the UI.

Wrap text:

I would love to see Wrap text commands as far as it's possible. Wrapping is always an important feature as it's mostly hidden in the toolbars or sidebar decks.