Bug 119655 - LibreOffice Calc sluggish/slow on display/render Chinese glyph
Summary: LibreOffice Calc sluggish/slow on display/render Chinese glyph
Status: RESOLVED DUPLICATE of bug 119340
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
6.1.0.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: CommonSalLayout-refactoring-regressions
  Show dependency treegraph
 
Reported: 2018-09-03 04:57 UTC by Jiero
Modified: 2018-09-05 06:28 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
A Calc document with Chinese glyphs as content, basic&unformatted (17.09 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-09-03 12:13 UTC, Jiero
Details
ETW trace (7.43 MB, application/x-zip-compressed)
2018-09-03 17:16 UTC, Buovjaga
Details
VerySleepy profile and callgrind export (11.60 KB, application/x-zip-compressed)
2018-09-03 17:23 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jiero 2018-09-03 04:57:47 UTC
Description:
LibreOffice Calc have performance issue display few Chinese characters, this issue is obvious on 6.10.0 onward; I upgrade from version 6.0.6 and noticed this immediately, I will uninstall the 6.10.

Steps to Reproduce:
1. Use Calc 6.10 onward
2. Filling Chinese characters in cells
3. View the contents


Actual Results:
Sluggish performance made scrolling difficult when displaying glyph

Expected Results:
Anything in view may cause slowness, not this much


Reproducible: Always


User Profile Reset: No


OpenGL enabled: Yes

Additional Info:
Different fonts may cause different level of slowness. 
It work much better on version 6.0.6.

OpenGL enabled or not matter not.
Comment 1 Jiero 2018-09-03 12:13:20 UTC
Created attachment 144626 [details]
A Calc document with Chinese glyphs as content, basic&unformatted
Comment 2 Buovjaga 2018-09-03 13:06:20 UTC
(In reply to Jiero from comment #1)
> Created attachment 144626 [details]
> A Calc document with Chinese glyphs as content, basic&unformatted

Confirmed slowness when zooming in and out.

Bisected with win32-6.2 to https://cgit.freedesktop.org/libreoffice/core/commit/?id=fad862e290d727fc9fefe206f6e4b807482c4175

tdf#118555 fix HFONT fallback handing / lifecycle

Adding Cc: to Jan-Marek Glogowski
Comment 3 Buovjaga 2018-09-03 17:16:04 UTC
Created attachment 144637 [details]
ETW trace

Took an ETW trace with https://github.com/google/UIforETW/releases
Used libo-master~2018-09-03_12.13.14_LibreOfficeDev_6.2.0.0.alpha0_Win_x86.msi
The UIforETW installs the Windows Performance Analyzer.

This is the main info page: https://randomascii.wordpress.com/2015/09/01/xperf-basics-recording-a-trace-the-ultimate-easy-way/

I tested visualising it with this method: https://randomascii.wordpress.com/2016/09/05/etw-flame-graphs-made-easy/
Comment 4 Buovjaga 2018-09-03 17:23:58 UTC
Created attachment 144638 [details]
VerySleepy profile and callgrind export

I used the very latest VerySleepy build https://github.com/VerySleepy/verysleepy from their AppVeyor https://ci.appveyor.com/api/projects/CyberShadow/verysleepy/artifacts/setup.exe?branch=master

VerySleepy allows to export as callgrind, so I did it as well.
Comment 5 Buovjaga 2018-09-05 06:28:58 UTC
This is now fixed!

Version: 6.2.0.0.alpha0+
Build ID: 5e8fd488f17fe0433cc9b31ace6527fb06ea3bb0
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-09-05_02:20:05
Locale: fi-FI (fi_FI); Calc: threaded

*** This bug has been marked as a duplicate of bug 119340 ***