Bug 119679 - Ordinal numbering of chapters
Summary: Ordinal numbering of chapters
Status: RESOLVED DUPLICATE of bug 118261
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Bullet-Number-Outline-Lists
  Show dependency treegraph
 
Reported: 2018-09-04 03:15 UTC by Leandro Martín Drudi
Modified: 2018-09-04 16:55 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
CHapter numberin with text don't work (32.14 KB, image/png)
2018-09-04 03:18 UTC, Leandro Martín Drudi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Leandro Martín Drudi 2018-09-04 03:15:04 UTC
Description:
Chapter numbering with (ordinals) text dont work.

Steps to Reproduce:
1. Tools -> Numbering of chapters
2. Select an ordinal form.
3. (opctional) Write "Chapter" in Before


Actual Results:
Instead of showing "Chapter First" or "Chapter One" shows "Chapter ordinal 1"

Expected Results:
Show "Chapter First" or "Chapter One" (or "First" or "one"


Reproducible: Always


User Profile Reset: No



Additional Info:
I don't know if is in Spanish only or in another languages too. I try in Spanish.
Versión: 6.1.0.3 (x64)
Id. de compilación: efb621ed25068d70781dc026f7e9c5187a4decd1
Subprocs. CPU: 4; SO: Windows 10.0; Repres. IU: predet.; 
Configuración regional: es-AR (es_AR); Calc: CL
Comment 1 Leandro Martín Drudi 2018-09-04 03:18:01 UTC
Created attachment 144651 [details]
CHapter numberin with text don't work
Comment 2 Dieter Praas 2018-09-04 06:11:34 UTC
Same behaviour in English UI

Chapter Ordinal 1
Chapter Ordinal 2
...

when I choose "First, Second, Third"



Version: 6.2.0.0.alpha0+ (x64)
Build ID: 414ef6cb187dd3bbcc917dbedf3c0c1cc8668f60
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-08-21_00:13:04
Locale: en-US (de_DE); Calc: CL


Lázló, I could see from the release notes, that you implemented ordinal indicators to chapter numbering. So I think, you might be interested in this
Comment 3 Regina Henschel 2018-09-04 12:15:48 UTC
I cannot confirm it for Version: 6.2.0.0.alpha0+ (x64)
Build-ID: a201c5c8c3e7ea14001b5634f330dbce2b1f4314
CPU-Threads: 8; BS: Windows 10.0; UI-Render: GL; 
Gebietsschema: de-DE (en_US); Calc: CL

It is correct both in de-DE and in en_US.

But I see "Ordinal 1" in Version: 6.1.0.3 (x64)
Build-ID: efb621ed25068d70781dc026f7e9c5187a4decd1
CPU-Threads: 8; BS: Windows 10.0; UI-Render: Standard; 
Gebietsschema: de-DE (en_US); Calc: CL

and in Version: 6.2.0.0.alpha0+ (x64)
Build ID: 414ef6cb187dd3bbcc917dbedf3c0c1cc8668f60
CPU threads: 8; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-08-21_00:13:04
Locale: de-DE (en_US); Calc: CL

Perhaps it is fixed already on master?
Comment 4 László Németh 2018-09-04 16:55:26 UTC
Unfortunately, packaging had got a problem with the related data files, fixed after the first 6.1 release.

It's possible to fix the problem by creating a LO_installation/share/numbertext folder with these data files: https://github.com/Numbertext/libnumbertext/tree/master/data, or by installing a newer installation set (6.1.1.1)

Thanks for your bug report and checking!

*** This bug has been marked as a duplicate of bug 118261 ***