Bug Hunting Session
Bug 118261 - Doesn't work new feature New “spell out” chapter numbering styles for Russian
Summary: Doesn't work new feature New “spell out” chapter numbering styles for Russian
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.0.0.beta2+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.2.0 target:6.1.1
Keywords:
: 119679 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-06-20 08:10 UTC by Roman Kuznetsov
Modified: 2018-09-14 08:11 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Example with numbering lists (10.22 KB, application/vnd.oasis.opendocument.text)
2018-06-20 08:17 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2018-06-20 08:10:01 UTC
Description:
Doesn't work new feature New “spell out” chapter numbering styles for Russian in LibreOffice Writer 6.1 beta 2

Steps to Reproduce:
0. Make sure, that you use Russian locale in LibreOffice
1. Create a new Writer doc
2. Create a numbering list
3. Set type of Number for list as "First, Second, Third" on tab Customize in dialogue "Bullets and Numbering". Push Ok
4. Numbering of list shows as
    Ordinal 1. Первый
    Ordinal 2. Второй
    Ordinal 3. Третий
instead
    Первый. Первый
    Второй. Второй
    Третий. Третий

Another new variant "1st, 2nd, 3rd" gives
    Ordinal-number 1. Первый
    Ordinal-number 2. Второй
    Ordinal-number 3. Третий
instead
    1-й. Первый
    2-й. Второй
    3-й. Третий

and variant "One, Two, Three" gives
    1. Первый
    2. Второй
    3. Третий
instead
    Один. Первый
    Два. Второй
    Три. Третий

Actual Results:
doesn't work new features for Russian

Expected Results:
new features for Russian works fine


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 2 Roman Kuznetsov 2018-06-20 08:17:30 UTC
Created attachment 142955 [details]
Example with numbering lists
Comment 3 László Németh 2018-06-20 09:17:35 UTC
Unfortunately, this is the fallback of feature, when the C++11 based libnumbertext library is not available.

@Cloph, Could you help us, please? Is it possible, that TDF build is configured with --disable-libnumbertext?
Comment 4 László Németh 2018-06-20 09:26:06 UTC
Note: libnumbertext uses C++11 regex features supported by Windows, libc++ and newer libstdc++ (but not GCC 4.8). If this is a problem for the portability of TDF LibreOffice builds (I don't know) libnumbertext can use boost regex, too, but I couldn't configure it to do that in LibreOffice, yet.
Comment 5 RGB 2018-06-20 11:58:15 UTC
I confirm the problem on Spanish with

6.1.0.0.beta2
Id  0f4d2060bc90b4008fbc8e6d9a49ec7eeea60b78

under Linux (64 bits) with es-ES (es_ES.UTF-8), language settings, Spanish UI on a Spanish document.

For chapter numbering, when using "1º, 2º, 3º..." I obtain instead

   Ordinal-number 1

When using "Uno, Dos, Tres..." I obtain instead

   1

When using "Primero, Segundo, Tercero..." I obtain instead

   Ordinal 1

Changing both, document language and UI language to English do not fix the problem: I get the same results.
Comment 6 Roman Kuznetsov 2018-07-26 17:04:31 UTC
still doesn't work in 6.1.0.2 =(

what is it with library?
Comment 7 Christian Lohmaier 2018-08-01 09:48:11 UTC
while not explicitly disabled, the library is not compatible with the baseline used (or uses bad configure checks).

 configure: WARNING: No system-provided libnumbertext or codecvt/regex c++11 headers (min. libstdc++ 4.9).
       Enable libnumbertext fallback (missing number to number name conversion).

see e.g. https://tinderbox.libreoffice.org/cgi-bin/gunzip.cgi?tree=MASTER&full-log=1533106801.28568#532

Windows doesn't have this issue, so should work there.
Comment 8 Roman Kuznetsov 2018-08-08 20:25:58 UTC
Now we have a new release 6.1 with implemented new good feature, that doesn't work.
Comment 9 László Németh 2018-08-09 07:17:21 UTC
(In reply to Roman Kuznetsov from comment #8)
> Now we have a new release 6.1 with implemented new good feature, that
> doesn't work.

I hope, Linux distributions will solve this problem soon. Suse developer Tomáš Chvátal fixed my boost based regex configuration, so it will be able to compile LibreOffice with libnumbertext support on older Linuxes, too.
Comment 10 Jean-Baptiste Faure 2018-08-11 22:17:14 UTC
Same problem for me in French under Ubuntu 16.04 x86-64.

Best regards. JBF
Comment 11 Mike Kaganski 2018-08-16 12:52:20 UTC
For Windows, the problem is that we don't install share/numbertext directory with data. numbertextlo.dll is installed correctly. Manually copying the directory from dev tree fixes the problem -> installer issue.
Comment 12 László Németh 2018-08-16 13:32:32 UTC
(In reply to Mike Kaganski from comment #11)
> For Windows, the problem is that we don't install share/numbertext directory
> with data. numbertextlo.dll is installed correctly. Manually copying the
> directory from dev tree fixes the problem -> installer issue.

@Mike, Roman, thanks for your investigations. In my patch, I tried to use libtextcat's fingerprint/ installation path as a model for numbertext/, but it seems, I missed something here.
Comment 13 Mike Kaganski 2018-08-16 16:26:30 UTC
From IRC discussion, by cloph:

> ... then the problem is not the wrong variable, but rather a missing gb_Helper_register_packages_for_install in Repository.mk
Comment 14 László Németh 2018-08-17 11:58:29 UTC
(In reply to Mike Kaganski from comment #13)
> From IRC discussion, by cloph:
> 
> > ... then the problem is not the wrong variable, but rather a missing gb_Helper_register_packages_for_install in Repository.mk

@Mike, Cloph: thanks, I've pushed a patch according to your instructions, I hope, it will fix packaging: https://gerrit.libreoffice.org/#/c/59261/
Comment 15 Commit Notification 2018-08-22 06:45:33 UTC
Christian Lohmaier committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=566050c5f3f3e54bfec115f9dba693404ca91770

tdf#118261 package libnumbertext data files into installation sets

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2018-08-24 13:18:05 UTC
Christian Lohmaier committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d6eabbf3e373f3966ab6b0d4e6861dfa6957ccce&h=libreoffice-6-1

tdf#118261 package libnumbertext data files into installation sets

It will be available in 6.1.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 László Németh 2018-08-24 13:21:44 UTC
@Cloph: many thanks for the fix!
Comment 18 Roman Kuznetsov 2018-08-26 10:37:39 UTC
verified in LO 6.1.1.1 on Windows

Thanks Christian and Mike
Comment 19 László Németh 2018-09-04 16:55:26 UTC
*** Bug 119679 has been marked as a duplicate of this bug. ***
Comment 20 RGB 2018-09-14 07:53:03 UTC
This new feature is NOT working in 6.1.1.2 in Linux (64 bits) nor in 6.2.0.0.alpha0+
Build ID: 18c5089df091bddeb8c2dc339776671964389040

Comment 18 indicates that it now works on Windows. Maybe this needs to be reopen as a Linux issue?
Comment 21 Mike Kaganski 2018-09-14 07:54:13 UTC
(In reply to RGB from comment #20)

Please track it separately - file a new report for Linux. This makes issues manageable. Thanks!
Comment 22 RGB 2018-09-14 08:11:30 UTC
(In reply to Mike Kaganski from comment #21)
> (In reply to RGB from comment #20)
> 
> Please track it separately - file a new report for Linux. This makes issues
> manageable. Thanks!

Added Bug 119871