Bug 119702 - Writers jumps view to cursor when saving
Summary: Writers jumps view to cursor when saving
Status: RESOLVED DUPLICATE of bug 116907
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.1.1 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: AutoSave-AutoRecovery-Backup
  Show dependency treegraph
 
Reported: 2018-09-04 19:53 UTC by J22Gim
Modified: 2018-10-25 19:11 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Test File (13.08 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2018-10-08 16:46 UTC, J22Gim
Details

Note You need to log in before you can comment on or make changes to this bug.
Description J22Gim 2018-09-04 19:53:39 UTC
Description:
When I'm reading a Writer document, no matter which part is in the screen at the moment, when I press "save" the screen jumps to wherever the cursor is located at. 

This is not intuitive nor "good UI practice" because a button/instruction is intended to do one thing (ie save the current document) but does an additional action, unintended by the user (ie jump to cursor).

Can this be changed to a more intuitive behavior, eg. when one press "save" Writer just saves? If the user wants to go to cursor, there are more intuitive ways (eg press any letter or arrow so Writer takes you where the cursor is located at).


Steps to Reproduce:
1. Open a Writer file, with more than one page of content
2. Place the cursor at the beginning of the text 
3. Scroll down (using just the mouse or scroll bars) to page 2
4. Press "save" button (or CTRL-S)

Actual Results:
The document is saved and you are taking away from 2nd page and taken to the cursor (ie 1st page).

Expected Results:
The document is saved and you continue with whatever view you currently have, without unintended jumps.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.0.1.1
Build ID: 60bfb1526849283ce2491346ed2aa51c465abfe6
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: kde4; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 1 raal 2018-09-17 19:55:54 UTC
No repro with Version: 6.2.0.0.alpha0+ (x64)
Build ID: 414ef6cb187dd3bbcc917dbedf3c0c1cc8668f60
CPU threads: 1; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-08-21_00:13:04

and Verze: 6.1.1.2 (x64)
ID sestavení: 5d19a1bfa650b796764388cd8b33a5af1f5baa1b
Vlákna CPU: 1; OS: Windows 6.1; Vykreslování UI: výchozí; 

Please retest with newer version.
Comment 2 J22Gim 2018-09-26 01:56:55 UTC
Can't reproduce with Version: 6.0.6.2
Build ID: 1:6.0.6-0ubuntu0.14.04.1
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group

So I guess it can be called fixed.
Comment 3 raal 2018-09-26 07:56:28 UTC
Thank you for testing. Setting correct status.
Comment 4 J22Gim 2018-10-08 16:45:54 UTC
I just found it again:

1) open the testFile.docx
2) place the cursor anywhere in page 1
3) to to page 2 without moving the cursor (ie using the scroll bar)
4) press "Save" (or CTRL+S) and save as DOCX
Result: writers takes me to the current cursor location.

Version: 6.1.2.1
Build ID: 1:6.1.2~rc1-0ubuntu0.14.04.4
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk2; 
Locale: en-US (en_US.UTF-8); Calc: group threaded
Comment 5 J22Gim 2018-10-08 16:46:21 UTC
Created attachment 145482 [details]
Test File
Comment 6 Buovjaga 2018-10-25 19:11:14 UTC

*** This bug has been marked as a duplicate of bug 116907 ***