Download it now!
Bug 116907 - Save/autosave still moves view back to cursor position in case of docx files
Summary: Save/autosave still moves view back to cursor position in case of docx files
Status: RESOLVED DUPLICATE of bug 135244
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.3.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 119702 (view as bug list)
Depends on:
Blocks: Writer-View-Jumps
  Show dependency treegraph
 
Reported: 2018-04-09 18:28 UTC by Péter Trombitás
Modified: 2020-09-29 13:59 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Péter Trombitás 2018-04-09 18:28:33 UTC
Description:
It is the same issue that's been marked as resolved in bug 95797, with the exception that it affects docx documents (odt one are fine, haven't tested other formats).

Steps to Reproduce:
1. Create/open any document with *.docx extension, preferably with more than one page
2. Place the cursor at the first page, then move the view to another page
3. Save the document or wait for autosave to occur.

Actual Results:  
The view jumps back to the page on which the cursor is.

Expected Results:
The view should not change.


Reproducible: Always


User Profile Reset: No



Additional Info:


User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:59.0) Gecko/20100101 Firefox/59.0
Comment 1 Buovjaga 2018-04-15 17:46:13 UTC
Yes, confirmed with a fresh DOCX.

Arch Linux 64-bit
Version: 6.1.0.0.alpha0+
Build ID: c8c74a0b4ca6f3a3619f423b6548c80c52392ae0
CPU threads: 8; OS: Linux 4.15; UI render: default; VCL: kde4; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on April 15th 2018
Comment 2 Buovjaga 2018-10-25 19:11:14 UTC
*** Bug 119702 has been marked as a duplicate of this bug. ***
Comment 3 QA Administrators 2019-10-26 02:10:31 UTC Comment hidden (obsolete)
Comment 4 gokigen 2019-10-28 02:48:34 UTC
Version: 6.3.2.2
Build ID: 98b30e735bda24bc04ab42594c85f7fd8be07b9c
CPU threads: 4; OS: Linux 5.3; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

Version: 6.4.0.0.alpha0+
Build ID: bb11efa477b6700744560d3999190c65d016600b
CPU threads: 4; OS: Linux 5.3; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-09-26_19:53:21
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded

Issue with manual save is reproducible, auto-save issue did not occur.
Comment 5 Telesto 2020-09-26 12:22:50 UTC
This one should be solved. No repro
Version: 7.1.0.0.alpha0+ (x64)
Build ID: 52a49f9e480ca03e231cfda82640a928393131c9
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CLb

See bug 135244
Comment 6 Buovjaga 2020-09-29 13:59:00 UTC

*** This bug has been marked as a duplicate of bug 135244 ***