Download it now!
Bug 119730 - LibreOffice hangs, when add a path in tools > options
Summary: LibreOffice hangs, when add a path in tools > options
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.2.0 target:6.1.5
Keywords: regression
: 121585 (view as bug list)
Depends on:
Blocks: VCL-Scheduler
  Show dependency treegraph
 
Reported: 2018-09-06 14:25 UTC by Regina Henschel
Modified: 2019-01-24 15:07 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot, Windows 10 (82.50 KB, image/png)
2018-09-06 16:07 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2018-09-06 14:25:16 UTC
Start LibreOffice and go to Tools > Options > Paths. Select "AutoText", then click on button "Edit...".
In the dialog "Edit Paths: AutoText" click on button "Add...". You get a dialog "Select Path". You will already notice a delay in this step.
Click on a drive or click on the ">" to open the list of that drive. LibreOffice hangs.

I see the error in Version: 6.2.0.0.alpha0+ (x64)
Build ID: 7f43f0b50135e147fb2bb1f942da3bf60153fd2c
CPU threads: 8; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-09-06_01:41:39
Locale: de-DE (en_US); Calc: CL

It was OK in Version: 6.2.0.0.alpha0+ (x64)
Build ID: 414ef6cb187dd3bbcc917dbedf3c0c1cc8668f60
CPU threads: 8; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-08-21_00:13:04
Locale: de-DE (en_US); Calc: CL
Comment 1 Xisco Faulí 2018-09-06 15:19:27 UTC
When you say it hangs, it means you have to kill LibreOffice afterwards?

Can't reproduce it in

Version: 6.2.0.0.alpha0+
Build ID: a1dd8098e6e2a7d5ba4b9c1a2d094db11d3d6b27
CPU threads: 16; OS: Windows 6.3; UI render: default; 
Locale: en-GB (en_GB); Calc: threaded
Comment 2 Regina Henschel 2018-09-06 16:07:50 UTC
Created attachment 144718 [details]
Screenshot, Windows 10

It shows a spinner and Windows shows "Keine Rückmeldung" in the title bar of the dialog. Sometimes the dialog collapses and restarts immediately. Clicking Cancel in the dialog window and its parent window several times finally allows to go back and close LibreOffice.
Comment 3 Jan-Marek Glogowski 2018-09-06 16:44:39 UTC
It's the same as bug 116615. The patch was never complete, just a band-aid, which seems to be broken now :-(

I can reproduce with:

Version: 6.2.0.0.alpha0+
Build-ID: e69432df6f769eec8463f3a900540d85181f126c
CPU-Threads: 10; BS: Windows 6.1; UI-Render: Standard;
Gebietsschema: de-DE (de_DE); Calc: threaded

which is master + patches for bug 119302.
Comment 4 Commit Notification 2018-09-08 21:07:43 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2129753120d8101f0f484571b6a8cd8eb4d4629c

tdf#119730 WIN switch to IFileDialog FOS_PICKFOLDERS

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Xisco Faulí 2018-10-11 11:59:30 UTC
A polite ping to Jan-Marek Glogowski:
Is this bug fixed? if so, could you please close it as RESOLVED FIXED ?
Otherwise, Could you please explain what's missing?
Thanks
Comment 6 Xisco Faulí 2018-11-21 15:41:30 UTC
*** Bug 121585 has been marked as a duplicate of this bug. ***
Comment 7 Xisco Faulí 2018-11-21 15:43:42 UTC
Cherry-picked to 6-1
https://gerrit.libreoffice.org/#/c/63724/
https://gerrit.libreoffice.org/#/c/63723/
Comment 8 Commit Notification 2019-01-16 14:30:05 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

https://git.libreoffice.org/core/+/960313f0b79fcc4a126b59aafad53efba13dfeb3%5E%21

tdf#119730 WIN switch to IFileDialog FOS_PICKFOLDERS

It will be available in 6.1.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.