Bug 122927 - Writer hangs if I insert a graphic from the gallery as a list bullet
Summary: Writer hangs if I insert a graphic from the gallery as a list bullet
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.3.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.3.0 target:6.2.1 target:6.1.5
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2019-01-24 12:26 UTC by Walter
Modified: 2019-03-14 08:52 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
screencast showing the problem (1.33 MB, video/mp4)
2019-01-24 21:05 UTC, Xisco Faulí
Details
selection of graphical bullet (60.77 KB, image/png)
2019-01-25 09:40 UTC, Walter
Details
Showing squares instead of bullet (6.52 KB, image/png)
2019-01-25 09:40 UTC, Walter
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Walter 2019-01-24 12:26:31 UTC
Description:
If I format paragraphs as a list and go to Format - Bullets and Numbering - Options and change the Numbering type to a graphical bullet from the Gallery (the huge submenu) the following behavior occurs:
6.1.5, 6.2.0.2: crash (no response)
6.1.3, 6.1.4: a white square appears instead of the graphical bullet

Steps to Reproduce:
1. Mark several paragraphs
2. Format - Bullets and Numbering 
3. Options
4. Kind of Numbering: Graphics
5. Gallery
6. Choose a graphical bullet
7. OK
(Sorry, I only have the german version, names could be different)

Actual Results:
6.1.5, 6.2.0.2: crash (no response)
6.1.3, 6.1.4: a white square appears instead of the graphical bullet

Expected Results:
Showing a list with graphical bullets


Reproducible: Always


User Profile Reset: No



Additional Info:
I.e. tested with 
Version: 6.1.5.1 (x64)
Build-ID: f18954c1ba9116b85c32b6bdbc0188d3e0fd24c7
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; 
Gebietsschema: de-AT (de_AT); Calc: group threaded
Comment 1 Xisco Faulí 2019-01-24 13:54:16 UTC
Reproduced in

Version: 6.3.0.0.alpha0+
Build ID: a71a33e2f03fd2a56894dc8bce0250623c7a05b4
CPU threads: 16; OS: Windows 6.3; UI render: default; VCL: win; 
Locale: en-GB (en_GB); UI-Language: en-US
Calc: threaded
Comment 2 Xisco Faulí 2019-01-24 15:07:50 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=2129753120d8101f0f484571b6a8cd8eb4d4629c

author	Jan-Marek Glogowski <glogow@fbihome.de>	2018-09-07 13:00:38 +0200
committer	Jan-Marek Glogowski <glogow@fbihome.de>	2018-09-08 23:07:06 +0200
commit	2129753120d8101f0f484571b6a8cd8eb4d4629c (patch)
tree	e06a410cf94d9815f6bf0710172bab7b6a235331
parent	025abb05385a1dc6219d48390cd4b783988cb409 (diff)
tdf#119730 WIN switch to IFileDialog FOS_PICKFOLDERS

Bisected with: bibisect-win32-6.2

Adding Cc: to Jan-Marek Glogowski
Comment 3 Jan-Marek Glogowski 2019-01-24 17:18:18 UTC
@Xisco: at which point is a filepicker involved in the process?
The commit just changes the native Windows file picker.

I couldn't reproduce with my older Windows master.
Comment 4 Xisco Faulí 2019-01-24 21:01:13 UTC
(In reply to Jan-Marek Glogowski from comment #3)
> @Xisco: at which point is a filepicker involved in the process?
> The commit just changes the native Windows file picker.
> 
> I couldn't reproduce with my older Windows master.

So, I have an old build from 6 month ago on windows and I can't reproduce the hang. I've cherry-picked the commit from gerrit and I can reproduce it
Comment 5 Xisco Faulí 2019-01-24 21:05:00 UTC
Created attachment 148611 [details]
screencast showing the problem

Does the gallery in this case behave like a filepicker ?
Comment 6 Walter 2019-01-25 09:39:45 UTC
Added two pictures showing the selection of the bullet (no filepicker) and the result in Version: 6.1.2.1 (x64) showing squares instead of the graphical bullets 
I had the same behavior with 6.1.3 and 6.1.4. 
Version 6.1.5 and 6.2.0.2 crash like shown in the screencast.
Comment 7 Walter 2019-01-25 09:40:28 UTC
Created attachment 148618 [details]
selection of graphical bullet
Comment 8 Walter 2019-01-25 09:40:58 UTC
Created attachment 148619 [details]
Showing squares instead of bullet
Comment 9 Xisco Faulí 2019-01-25 10:21:54 UTC
> 6.1.5, 6.2.0.2: crash (no response)

Jan-marek is already working on a solution for that...

> 6.1.3, 6.1.4: a white square appears instead of the graphical bullet

that's reported in bug 122951
Comment 10 Commit Notification 2019-01-25 15:04:58 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/5b2f1243bd44b450da26c8344b3ee459f8e88f6c%5E%21

tdf#122927 prevent SolarMutex deadlock on join()

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Xisco Faulí 2019-01-28 12:09:49 UTC
Verified in

Version: 6.3.0.0.alpha0+
Build ID: fcc5fc76c33de566cb2d02be541dcbde29d1eb8a
CPU threads: 16; OS: Windows 6.3; UI render: default; VCL: win; 
Locale: en-GB (en_GB); UI-Language: en-US
Calc: threaded

@Jan-marek, Thanks for the quick fix!!
Comment 12 Commit Notification 2019-01-28 12:12:45 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "libreoffice-6-2":

https://git.libreoffice.org/core/+/1ed8416703d1f1a33690cc47fd6cb6b2b3520cf1%5E%21

tdf#122927 prevent SolarMutex deadlock on join()

It will be available in 6.2.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2019-01-29 10:03:29 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

https://git.libreoffice.org/core/+/5070fa647ed09c16d49b3a1a1a7d1cdc8035af2e%5E%21

tdf#122927 prevent SolarMutex deadlock on join()

It will be available in 6.1.6.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2019-01-29 12:53:10 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "libreoffice-6-1-5":

https://git.libreoffice.org/core/+/3640f39432d0dae45321699703b75c38df4f0c28%5E%21

tdf#122927 prevent SolarMutex deadlock on join()

It will be available in 6.1.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.