Bug 119733 - Chart axis labels trimmed when chart wall size is changed
Summary: Chart axis labels trimmed when chart wall size is changed
Status: RESOLVED DUPLICATE of bug 117088
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
6.0.4.1 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Chart-Labels
  Show dependency treegraph
 
Reported: 2018-09-06 16:53 UTC by 56SEhpYHEpVvddiH
Modified: 2018-10-02 07:59 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file as requested (18.03 KB, application/vnd.oasis.opendocument.spreadsheet)
2018-10-01 18:00 UTC, 56SEhpYHEpVvddiH
Details

Note You need to log in before you can comment on or make changes to this bug.
Description 56SEhpYHEpVvddiH 2018-09-06 16:53:28 UTC
Description:
After upgrading to version 6, my heavy chart presented only 1-6 characters on horizontal axis. Lower margin is the trigger for the bug.
Scale of trimming depends mostly on font size and content, so "VII 18" (bold size 8) was reduced to "VII" one size higher, with plenty of space around (50-80% free), no change when trying to ease the problem using two rows etc.
Sometimes down to single character.

Up until noticing this bug I remember being convinced of a big improvement in axis labeling introduced with version 6.

Steps to Reproduce:
1. Column 1 to 10, column -1 to 8.
2. Select and create XY chart.
3. Horizontal axis step: 1.
4. Number format: abcabc (because data is simplified).
5. Stretch lower end of chart's grid couple pixels downward.

Actual Results:
Captions trimmed to "a".

Expected Results:
Negligibly tighter diagonal spacing.


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Buovjaga 2018-10-01 17:16:56 UTC
(In reply to badomen@o2.pl from comment #0)
> Steps to Reproduce:
> 1. Column 1 to 10, column -1 to 8.
> 2. Select and create XY chart.
> 3. Horizontal axis step: 1.
> 4. Number format: abcabc (because data is simplified).

Can you attach an example file at this step? I tried creating one myself, but apparently I am not familiar enough with charting.

Please attach an example document.
Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the document.
Comment 2 56SEhpYHEpVvddiH 2018-10-01 18:00:53 UTC
Created attachment 145304 [details]
Example file as requested
Comment 3 Buovjaga 2018-10-01 18:31:00 UTC
Thanks a lot.

Bibisected on Win with 6.0 repo to https://cgit.freedesktop.org/libreoffice/core/commit/?id=87d8df83efd210a322b42f590aaff3d2e8efe2bc

tdf#116163: Limit label height in chart if needed

Adding Cc: to Szymon Kłos

I tested by always grabbing the right edge of the chart wall and moving to the left. The labels changed to "ab" and horizontal orientation.
Comment 4 56SEhpYHEpVvddiH 2018-10-01 19:15:10 UTC
It breaks decreasing, expanding or moving grid closer to object edges.

It seems that chart always counts space available for labels like if h-axis is at the bottom. So if axis is at a different height, space requirement downwards is not reduced.

If axis is at the top, labels can go out of chart (no trimming). This may be a closely related bug of no space-check upwards or just due to this bug of not taking axis position into account at all.
Comment 5 Szymon Kłos 2018-10-02 07:59:49 UTC
I know the issue, I was working on it. I will finish when I will found some time. PoC https://gerrit.libreoffice.org/#/c/59464/

I think this is duplicate of tdf#117088

*** This bug has been marked as a duplicate of bug 117088 ***