Bug 119789 - a11y: printer status details should be exposed through an expandable
Summary: a11y: printer status details should be exposed through an expandable
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: accessibility
Depends on:
Blocks: a11y-Linux
  Show dependency treegraph
 
Reported: 2018-09-10 15:32 UTC by Samuel Thibault
Modified: 2021-10-13 08:37 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Samuel Thibault 2018-09-10 15:32:05 UTC
Description:
The printer status details should be exposed through an expandable widget and "details" relation, for the screen reader to automatically read the content when expanding the "details" widget.

Steps to Reproduce:
1. Open Print dialog
2. Open the "Details" subpanel


Actual Results:
The "details" widget has role "checkbox" in accerciser.

Details for the printer status are added as static widget children, without direct relation to the "details" widget.

Expected Results:
- The "details" widget should have role "toggle_button"
- state "expandable" should be set in that widget
- state "expanded" should be set in that widget when it is expanded
- state-change:expanded event should be emitted when that widget gets expanded
- the details for the printer status should be either direct children of the "details" widget (probably not feasible), or pointed to by the toggle button using the atk "details" relation.


Reproducible: Always


User Profile Reset: No



Additional Info:
The screen reader bits to make this work on the screen reader side have been discussed and implemented in

https://gitlab.gnome.org/GNOME/orca/issues/13
Comment 1 Buovjaga 2018-10-03 15:47:59 UTC
-> NEW
Comment 2 QA Administrators 2019-10-04 03:05:23 UTC Comment hidden (obsolete)
Comment 3 Samuel Thibault 2019-10-13 16:07:56 UTC
I seems that in libreoffice 6.3.2.2 the "details" widget has disappeared, so this bug report is now moot.
Comment 4 QA Administrators 2021-10-13 03:40:24 UTC
Dear Samuel Thibault,

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from https://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug