Bug 119802 - LibreOffice crashes when I save multiple times in a row (gtk/gtk3)
Summary: LibreOffice crashes when I save multiple times in a row (gtk/gtk3)
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.0.0.alpha0+
Hardware: All Linux (All)
: highest critical
Assignee: Not Assigned
URL:
Whiteboard: target:6.2.0 target:6.1.2
Keywords: bibisected, bisected, regression
: 119869 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-09-11 10:28 UTC by Vignesh Kumar
Modified: 2018-09-14 08:52 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
GDB backtrace (4.64 KB, text/plain)
2018-09-12 11:31 UTC, Michael Weghorn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vignesh Kumar 2018-09-11 10:28:03 UTC
Description:
Libeoffice Writer crashes when I try to save multiple times in a row. I am able to recover the file again but this is just unstable behavior

Steps to Reproduce:
1.Open any document in LibreOffice Writer
2. Press Ctrl+S multiple times in a row without pause (just spam it).

Actual Results:
Libreoffice Writer crashes and restarts with "recover your file" dialog.

Expected Results:
Should not have crashed.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
I have only checked this behavior in Writer, might be happening in other apps too.

Version: 6.1.0.3
Build ID: 6.1.0-2
CPU threads: 8; OS: Linux 4.18; UI render: default; VCL: gtk3_kde5; 
Locale: en-US (en_US.utf-8); Calc: group threaded
Comment 1 Dieter Praas 2018-09-11 10:49:13 UTC
Not reproducible for me in

Version: 6.2.0.0.alpha0+ (x64)
Build ID: 414ef6cb187dd3bbcc917dbedf3c0c1cc8668f60
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-08-21_00:13:04
Locale: en-US (de_DE); Calc: CL
Comment 2 Xisco Faulí 2018-09-11 14:05:02 UTC
I see you're using 'gtk3_kde5'...
Do you reproduce it if you launch LibreOffice like SAL_USE_VCLPLUGIN=gen soffice?

Setting to NEEDINFO
Comment 3 Vignesh Kumar 2018-09-11 14:10:53 UTC
(In reply to Xisco Faulí from comment #2)
> I see you're using 'gtk3_kde5'...
> Do you reproduce it if you launch LibreOffice like SAL_USE_VCLPLUGIN=gen
> soffice?
> 
> Setting to NEEDINFO

I think you're on to something here. When I run 
```
SAL_USE_VCLPLUGIN=gen libreoffice --writer
```
,I no longer get the crash.
Comment 4 Vignesh Kumar 2018-09-11 14:16:09 UTC
Is there any workaround to this issue?
Comment 5 Michael Weghorn 2018-09-12 11:30:39 UTC
I can reproduce with a current master build and it happens for me with "plain" gtk3 as well, so it's unrelated to the gtk3_kde5 vclplugin.

Version: 6.2.0.0.alpha0+
Build ID: 40069adbc225a6dd5d3431a7cd9f17986f6385de
CPU threads: 4; OS: Linux 4.18; UI render: default; VCL: gtk3; 
Locale: en-GB (en_GB.UTF-8); Calc: threaded

Backtrace attached.
Comment 6 Michael Weghorn 2018-09-12 11:31:13 UTC
Created attachment 144814 [details]
GDB backtrace
Comment 7 Katarina Behrens (CIB) 2018-09-12 11:51:50 UTC

*** This bug has been marked as a duplicate of bug 119814 ***
Comment 8 Michael Weghorn 2018-09-12 12:38:01 UTC
> *** This bug has been marked as a duplicate of bug 119814 ***

Given that bug 119814 is specific for the gtk3_kde5 vclplugin while this one here is not (s. comment 5), the two seem to be unrelated, so I'm reopening this one.
Comment 9 Xisco Faulí 2018-09-12 12:39:44 UTC
Adding Caolán to the loop...
Comment 10 Xisco Faulí 2018-09-12 12:40:53 UTC
The backtrace seems the same as in bug http://crashreport.libreoffice.org/stats/signature/SfxRequest::IsCancelled()
Comment 11 Xisco Faulí 2018-09-12 12:50:51 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=c2452e52f644649723df10e3cd6bbd48d6bafb49

author	Noel Grandin <noel.grandin@collabora.co.uk>	2018-02-28 14:38:40 +0200
committer	Noel Grandin <noel.grandin@collabora.co.uk>	2018-03-05 07:27:45 +0100
commit	c2452e52f644649723df10e3cd6bbd48d6bafb49 (patch)
tree	5bb1993b265e7a93114c779ac7779ccb33ee9e51
parent	c9f01cc7855a20b1e0bff662cfbb75fe3665cd8a (diff)
loplugin:useuniqueptr in SfxDispatcher_Impl

Bisected with: bibisect-linux64-6.1

Adding Cc: to Noel Grandin
Comment 12 Xisco Faulí 2018-09-12 12:52:00 UTC
Also reproduced with gtk
Comment 13 Xisco Faulí 2018-09-12 15:50:45 UTC
Patch in gerrit: https://gerrit.libreoffice.org/#/c/60395/
Comment 14 Commit Notification 2018-09-12 18:34:41 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3778399872ad592b4416e54a154e8bcc02d73a2e

tdf#119802 LibreOffice crashes when I save multiple times in a row

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2018-09-13 06:33:01 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7ba9e99b08b01b4fb869e3153a50f6b53dcca25f&h=libreoffice-6-1

tdf#119802 LibreOffice crashes when I save multiple times in a row

It will be available in 6.1.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Xisco Faulí 2018-09-13 14:36:40 UTC
Verified in

Version: 6.2.0.0.alpha0+
Build ID: b74db4138342f646fda061eac5d6759ecf2c366f
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: threaded

@Noel Grandin, Thanks for fixing this!!
Comment 17 Xisco Faulí 2018-09-14 08:52:24 UTC
*** Bug 119869 has been marked as a duplicate of this bug. ***