Bug 119826 - Feature request: Highlight double space characters
Summary: Feature request: Highlight double space characters
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Spell-Checking Character
  Show dependency treegraph
 
Reported: 2018-09-12 16:25 UTC by NikoKrause
Modified: 2018-09-13 07:04 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description NikoKrause 2018-09-12 16:25:08 UTC
Description:
It would be nice, if LibreOffice Writer would highlight double (and more) whitespaces (in blue) as it highlights wrong written words in red.

Steps to Reproduce:
Write a text and add two  whitespaces.

Actual Results:
No highlighted whitespaces.

Expected Results:
Highlighted double whitespaces


Reproducible: Always


User Profile Reset: No



Additional Info:
Comment 1 Dieter Praas 2018-09-12 19:48:37 UTC
I assume, your proposal is about space characters (so I changed the bug summary). I think your proposal is useful and could also be a kind of workaround for bug 119363. Let's ask design team.
Comment 2 NikoKrause 2018-09-12 20:09:06 UTC
Yes, I mean space characters resp. blanks. Sorry for the looseness.

I've seen this feature recently in one of the newer Word versions and found it to be very useful, especially because I do proofread a lot of stuff and have observed, that most people do ignore double space characters. Highlighting them makes people aware of this issue.

Usually I remove double space characters with SEARCH for two space characters and REPLACE with one space character. But that's not very intuitive (nor ideal, if there are triple, etc space characters, you have to do this a few times). Having a tool/button to remove two and more space characters would be nice.

But highlighting them is something, that in my opinion would be great to make people aware of this issue in the first place.

Thanks for taking my suggestion into consideration.
Comment 3 Heiko Tietze 2018-09-13 07:04:22 UTC
This would be a very special (and MSO-like) solution for the use case to deal with multiple spaces. Besides find and replace another could be the auto correction and ideally we have grammar checking for not only English.

So ideally this is realized per extension and in fact the Language Tool [1] may provide this feature (bug 101687 talks about a minor issue). 

[1] https://extensions.libreoffice.org/extensions/languagetool