Download it now!
Bug 119829 - Malformed Writer ruler with some specific content on the clipboard
Summary: Malformed Writer ruler with some specific content on the clipboard
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.2.0
Keywords: bibisected, bisected, regression
: 120258 120263 (view as bug list)
Depends on:
Blocks: Rulers
  Show dependency treegraph
 
Reported: 2018-09-12 19:03 UTC by Telesto
Modified: 2018-11-09 06:26 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot (28.90 KB, image/png)
2018-09-12 19:03 UTC, Telesto
Details
A random PDF (458.52 KB, application/pdf)
2018-09-12 19:04 UTC, Telesto
Details
Screenshot of the problem (139.12 KB, image/png)
2018-09-19 08:51 UTC, Gabor Kelemen
Details
Example document with default chart (13.10 KB, application/vnd.oasis.opendocument.text)
2018-09-19 08:51 UTC, Gabor Kelemen
Details
Minimized doc from tdf#120258 bug (16.89 KB, application/vnd.oasis.opendocument.text)
2018-10-02 21:16 UTC, Jan-Marek Glogowski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2018-09-12 19:03:11 UTC
Description:
Malformed Writer ruler with some specific content on the clipboard

Steps to Reproduce:
1. Open Writer
2. Insert a PDF image (I attached one, doesn't matter)
3. Cut it
4. Close Writer (Start Center). Don't save
5. Open Calc
6. Paste -> Empty Frame
7. Cut the empty frame
8. Open a new Writer document -> File NEW - Writer Document


Actual Results:
Malformed ruler

Expected Results:
Shouldn't happen


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 6.2.0.0.alpha0+
Build ID: d5a2202f955657e427670a87c2d4e5638884517b
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-09-12_02:38:23
Locale: nl-NL (nl_NL); Calc: CL
Comment 1 Telesto 2018-09-12 19:03:45 UTC
Created attachment 144823 [details]
Screenshot
Comment 2 Telesto 2018-09-12 19:04:09 UTC
Created attachment 144824 [details]
A random PDF
Comment 3 Gabor Kelemen 2018-09-19 08:51:12 UTC
Created attachment 145009 [details]
Screenshot of the problem

We see this too when opening a simple odt document containing any chart.

Not present in bibisect-win32-6.2:

Version: 6.2.0.0.alpha0+
Build ID: a27ae800fed5a974c9b255f7ce2b38ec2dbaa426
CPU threads: 4; OS: Windows 6.3; UI render: default; 
Locale: hu-HU (hu_HU); Calc: CL

But this is 8 days old.
Happens with daily master from yesterday: 

Version: 6.2.0.0.alpha0+
Build ID: e2a525b00c9ea15408fb64dcb6749405739f58ab
CPU threads: 4; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-09-18_03:37:59
Locale: hu-HU (hu_HU); Calc: threaded
Comment 4 Gabor Kelemen 2018-09-19 08:51:48 UTC
Created attachment 145010 [details]
Example document with default chart
Comment 5 Telesto 2018-10-02 09:17:11 UTC
(In reply to Gabor Kelemen from comment #4)
> Created attachment 145010 [details]
> Example document with default chart

STR
1. Open the file
2. Select the chart.
2. CTRL+N
Comment 6 Timur 2018-10-02 16:03:48 UTC
*** Bug 120258 has been marked as a duplicate of this bug. ***
Comment 7 Xisco Faulí 2018-10-02 16:08:35 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=2ee177e58a57420eaa18b9d39ade4c28907bc0c8

author	Jan-Marek Glogowski <glogow@fbihome.de>	2018-09-10 13:15:36 +0200
committer	Jan-Marek Glogowski <glogow@fbihome.de>	2018-09-11 16:10:08 +0200
commit	2ee177e58a57420eaa18b9d39ade4c28907bc0c8 (patch)
tree	b9496c96d361219e759ca6b7f3353ed5d652d26f
parent	bb209f2f53edc1b0d268d561e0c12bf93e83fb41 (diff)
tdf#119756 assume the HFONT is always valid

Bisected with: bibisect-win32-6.2

Adding Cc: to Jan-Marek Glogowski
Comment 8 Xisco Faulí 2018-10-02 16:21:42 UTC
Just for the record, I bisected the issue using https://bugs.documentfoundation.org/attachment.cgi?id=120313
Comment 9 Xisco Faulí 2018-10-02 16:25:50 UTC
*** Bug 120263 has been marked as a duplicate of this bug. ***
Comment 10 Jan-Marek Glogowski 2018-10-02 21:16:45 UTC
Created attachment 145337 [details]
Minimized doc from tdf#120258 bug
Comment 11 Commit Notification 2018-10-06 13:20:57 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=01a782d2ceb741d20721b44d26d862d80b47d226

tdf#119829 use font cache based glyph rect cache

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Xisco Faulí 2018-10-10 09:03:05 UTC
Verified in

Version: 6.2.0.0.alpha0+
Build ID: 425af6845ebe066c950b0b63f50563e067485f3e
CPU threads: 16; OS: Windows 6.3; UI render: default; VCL: win; 
Locale: en-GB (en_GB); Calc: threaded