Bug Hunting Session
Bug 121269 - Writer's horizontal ruler is 142 px tall for a document
Summary: Writer's horizontal ruler is 142 px tall for a document
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.1.3.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.1.4
Keywords:
: 121308 121310 121397 121660 121776 121817 121994 122019 122028 122051 122061 122135 122147 122518 122948 122961 123201 123431 (view as bug list)
Depends on:
Blocks: Rulers
  Show dependency treegraph
 
Reported: 2018-11-08 11:39 UTC by Mihaly Korodi
Modified: 2019-10-31 07:33 UTC (History)
25 users (show)

See Also:
Crash report or crash signature:


Attachments
Picture about the ruler bug (27.50 KB, image/png)
2018-11-08 12:56 UTC, Mihaly Korodi
Details
Document with ruler bug (93.36 KB, application/vnd.oasis.opendocument.text)
2018-11-08 13:19 UTC, Mihaly Korodi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mihaly Korodi 2018-11-08 11:39:25 UTC
Description:
Horizontal ruler is 142 px tall when opening one particular document while it is OK with others. It is ugly and switching the ruler off and on does not help. 

Steps to Reproduce:
A. Double clicking on the document which is opened automatically by LibreOffice
or
B. Open the same file in LibreOffice's main navigator screen

Actual Results:
142 px tall, annoying ruler. 

Expected Results:
Expected to see 16 px tall ruler only. 


Reproducible: Always


User Profile Reset: No



Additional Info:
The ruler is appearing wrongly also when opening the document in safe mode.
Comment 1 Xisco Faulí 2018-11-08 11:53:37 UTC
Thank you for reporting the bug. Please attach a sample document, as this makes it easier for us to verify the bug. 
(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)

I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
Comment 2 Mihaly Korodi 2018-11-08 12:56:33 UTC
Created attachment 146437 [details]
Picture about the ruler bug
Comment 3 Mihaly Korodi 2018-11-08 13:01:04 UTC
Update!

When I changed the Default Style's font from Calibri to Liberation Serif on the copy of the problematic document, then saved and reopened it, the issue disappeared. Even the original document opens properly where the Default Style's font is still Calibri. 

It still can be considered as a bug though but at least the above solved it.
Comment 4 Mihaly Korodi 2018-11-08 13:07:00 UTC
Nope, it is still the same, but once it opened properly. 

I'm working on creating a document copy that doesn't contain any valuable content but represents the bug. Once it is done, I will upload it.
Comment 5 Mihaly Korodi 2018-11-08 13:17:38 UTC
OK, it should be related to inserted text boxes around the first picture (?). Once I remove them, save as and reopen the document, the ruler is fine. 

Uploading the document that opens with wrong ruler for sure.
Comment 6 Mihaly Korodi 2018-11-08 13:19:01 UTC
Created attachment 146438 [details]
Document with ruler bug
Comment 7 BogdanB 2018-11-09 06:12:13 UTC
I remember this was a known bug some weeks ago and it was solved, but I don't find the exact bug.
Comment 9 Mike Kaganski 2018-11-09 06:42:36 UTC
Reproducible with attachment 146438 [details] and Version: 6.1.3.2 (x64)
Build ID: 86daf60bf00efa86ad547e59e09d6bb77c699acb
CPU threads: 12; OS: Windows 10.0; UI render: default; 
Locale: ru-RU (ru_RU); Calc: group threaded
Comment 10 Oliver 2018-11-09 08:12:29 UTC
Reproducible with attachment 146438 [details] on Version: 6.1.3.2 (x64)
Build-ID: 86daf60bf00efa86ad547e59e09d6bb77c699acb
CPU-Threads: 8; BS: Windows 10.0; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: CL

We also have many Documents in the old doc format with the ruler problem.
Comment 11 Mihaly Korodi 2018-11-09 11:07:51 UTC
Yes, same as seen in in thread: https://ask.libreoffice.org/en/question/171726/huge-ruler-in-one-single-existing-document-after-update/

Switching OpenGL (as suggested in a comment there) off and on does not help. The "Use OpenGL for all rendering" is turned on by default, the "Ignore OpenGL blacklist" is not, but none of the combinations helps, the ruler remains huge.
Comment 12 BogdanB 2018-11-09 11:30:16 UTC
I can reproduce in
Version: 6.1.3.2 (x64)
Build ID: 86daf60bf00efa86ad547e59e09d6bb77c699acb
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: ro-RO (ro_RO); Calc: group threaded
Comment 13 Mike Kaganski 2018-11-09 11:45:38 UTC
(In reply to Mihaly Korodi from comment #11)
> Yes, same as seen in in thread:
> https://ask.libreoffice.org/en/question/171726/huge-ruler-in-one-single-
> existing-document-after-update/
> 
> Switching OpenGL (as suggested ...

Sorry for not being clear. The link above was intended as just an independent confirmation of this on 6.1.3.2, not a workaround information.

What is much more interesting, is that bug 119829 (which I added to See Also) is fixed for 6.2; and its cause is attributed to a commit which has never made it to 6.1 branch. Still, the two bugs look identical.
Comment 14 Mike Kaganski 2018-11-09 12:05:17 UTC
<jmux> mikekaganski: should be fixed with ac39aba9b2d08b061b0eef651f5ebc7a84391171, but that'll just be in 6.1.4

https://git.libreoffice.org/core/+/ac39aba9b2d08b061b0eef651f5ebc7a84391171 was pushed in bug 120204.
Comment 15 Dieter Praas 2018-11-09 12:26:18 UTC
*** Bug 121308 has been marked as a duplicate of this bug. ***
Comment 16 Dieter Praas 2018-11-09 13:29:56 UTC
*** Bug 121310 has been marked as a duplicate of this bug. ***
Comment 17 Xisco Faulí 2018-11-09 15:19:45 UTC
(In reply to Mike Kaganski from comment #14)
> <jmux> mikekaganski: should be fixed with
> ac39aba9b2d08b061b0eef651f5ebc7a84391171, but that'll just be in 6.1.4
> 
> https://git.libreoffice.org/core/+/ac39aba9b2d08b061b0eef651f5ebc7a84391171
> was pushed in bug 120204.

Using bibisect-win32-6.1 I do confirm it's fixed by that commit
Closing as VERIFIED FIXED
Comment 18 Xisco Faulí 2018-11-13 17:02:01 UTC
*** Bug 121397 has been marked as a duplicate of this bug. ***
Comment 19 tommy27 2018-11-18 13:15:37 UTC
just bumped into this bug after upgrading to 6.1.3
glad to know a fix will be provided in  6.1.4
Comment 20 Dieter Praas 2018-11-23 09:59:48 UTC
*** Bug 121660 has been marked as a duplicate of this bug. ***
Comment 21 V Stuart Foote 2018-11-29 00:20:25 UTC
*** Bug 121776 has been marked as a duplicate of this bug. ***
Comment 22 Dieter Praas 2018-11-30 11:59:10 UTC
*** Bug 121817 has been marked as a duplicate of this bug. ***
Comment 23 V Stuart Foote 2018-12-09 16:10:42 UTC
*** Bug 121994 has been marked as a duplicate of this bug. ***
Comment 24 Xisco Faulí 2018-12-11 11:01:47 UTC
*** Bug 122019 has been marked as a duplicate of this bug. ***
Comment 25 Wim Heyvaert 2018-12-11 15:27:17 UTC
If you reload the document (menu File > Reload) then the ruler has his normal format.
Comment 26 Xisco Faulí 2018-12-11 18:25:18 UTC
*** Bug 122028 has been marked as a duplicate of this bug. ***
Comment 27 Patrik Eschle 2018-12-12 14:17:10 UTC
(In reply to Wim Heyvaert from comment #25)
> If you reload the document (menu File > Reload) then the ruler has his
> normal format.

Not confirmed. I have a writer document where File -> Reload does not restore the correct size of the ruler (Windows 10, LO Version: 6.1.3.2 (x64))
Comment 28 Xisco Faulí 2018-12-12 14:19:26 UTC
(In reply to Patrik Eschle from comment #27)
> (In reply to Wim Heyvaert from comment #25)
> > If you reload the document (menu File > Reload) then the ruler has his
> > normal format.
> 
> Not confirmed. I have a writer document where File -> Reload does not
> restore the correct size of the ruler (Windows 10, LO Version: 6.1.3.2 (x64))

This issue is fixed in LibreOffice 6.1.4 not in LibreOffice 6.1.3. Please update it next week when it's publicly announced
Comment 29 Jan-Marek Glogowski 2018-12-12 17:32:59 UTC
*** Bug 122051 has been marked as a duplicate of this bug. ***
Comment 30 Xisco Faulí 2018-12-12 22:24:36 UTC
*** Bug 122061 has been marked as a duplicate of this bug. ***
Comment 31 raal 2018-12-16 08:16:36 UTC
*** Bug 122135 has been marked as a duplicate of this bug. ***
Comment 32 V Stuart Foote 2018-12-17 02:13:48 UTC
*** Bug 122147 has been marked as a duplicate of this bug. ***
Comment 33 Mike Kaganski 2019-01-06 21:02:49 UTC
*** Bug 122518 has been marked as a duplicate of this bug. ***
Comment 34 Xisco Faulí 2019-01-25 10:08:58 UTC
*** Bug 122948 has been marked as a duplicate of this bug. ***
Comment 35 Oliver Brinzing 2019-01-25 11:59:02 UTC
*** Bug 122961 has been marked as a duplicate of this bug. ***
Comment 36 V Stuart Foote 2019-02-06 07:19:58 UTC
*** Bug 123201 has been marked as a duplicate of this bug. ***
Comment 37 Dieter Praas 2019-02-13 10:30:17 UTC
*** Bug 123431 has been marked as a duplicate of this bug. ***
Comment 38 Jacques 2019-10-31 07:24:56 UTC
In October 2019 this still happens on 6.1.3.2 (X64) for Win; not on my Ubuntu boxes - which are 6.0.7.3 (but which has several other problems).

The status of Bug 121269 says it is fixed; well, it is not.
Comment 39 Aron Budea 2019-10-31 07:33:12 UTC
(In reply to Jacques from comment #38)
> In October 2019 this still happens on 6.1.3.2 (X64) for Win; not on my
> Ubuntu boxes - which are 6.0.7.3 (but which has several other problems).
> 
> The status of Bug 121269 says it is fixed; well, it is not.
Please note the following Whiteboard field: 'target:6.1.4'. The bug is fixed in versions 6.1.4 and up.