Bug 119830 - Saving and inserted JPG image to any format (bmp/png/pdf) will only add a corresponding extension without real conversion
Summary: Saving and inserted JPG image to any format (bmp/png/pdf) will only add a cor...
Status: RESOLVED DUPLICATE of bug 60684
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0 all versions
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, regression
Depends on:
Blocks: Graphics-Export
  Show dependency treegraph
 
Reported: 2018-09-12 19:43 UTC by Telesto
Modified: 2020-05-24 10:24 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (80.23 KB, application/vnd.oasis.opendocument.text)
2018-09-12 19:43 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2018-09-12 19:43:25 UTC
Description:
Saving and inserted JPG image to any format (bmp/png/pdf) will only add a corresponding extension without real conversion

Steps to Reproduce:
1. Open the attached file
2. Right click -> Save -> Choose any file format (except JPG)

Actual Results:
Only an extension change; no conversion

Expected Results:
A proper conversion; or 
no conversion option


Reproducible: Always


User Profile Reset: No



Additional Info:
Found in
Version: 6.2.0.0.alpha0+
Build ID: d5a2202f955657e427670a87c2d4e5638884517b
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-09-12_02:38:23
Locale: nl-NL (nl_NL); Calc: CL

and in 
Versie: 4.4.7.2 
Build ID: f3153a8b245191196a4b6b9abd1d0da16eead600
Locale: nl_NL
Comment 1 Telesto 2018-09-12 19:43:46 UTC
Created attachment 144825 [details]
Example file
Comment 2 MM 2018-09-12 21:24:35 UTC
Confirmed on windows 7 x64 with Version: 6.0.6.2 (x64)
Build ID: 0c292870b25a325b5ed35f6b45599d2ea4458e77
CPU threads: 3; OS: Windows 6.1; UI render: default

Unconfirmed with LibreOffice 3.3.4 
OOO330m19 (Build:401)
Comment 3 Xisco Faulí 2018-09-13 11:49:14 UTC
Same behaviour in

Version: 6.2.0.0.alpha0+
Build ID: 2da435922f9c1fcf52eb0c1eb3d6f73581e9f793
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: threaded

file test.bmp 
test.bmp: JPEG image data, JFIF standard 1.01, resolution (DPI), density 72x72, segment length 16, Exif Standard: [TIFF image data, little-endian, direntries=13, description=                               , manufacturer=Canon, model=Canon PowerShot SX50 HS, orientation=upper-left, xresolution=232, yresolution=240, resolutionunit=2, datetime=2018:07:14 09:07:24], baseline, precision 8, 640x426, frames 3
Comment 4 Xisco Faulí 2018-09-13 11:51:06 UTC
Regression introduced in range https://cgit.freedesktop.org/libreoffice/core/log/?qt=range&q=786f730ea2608abaafdc656e2181d11e076b6648..b7822657fa67e7265d07f5852057e975e9efae0d

before it,

file /home/xisco/Baixades/test.bmp
/home/xisco/Baixades/test.bmp:
PC bitmap, Windows 3.x format, 640 x 426 x 24
Comment 5 Xisco Faulí 2018-09-13 11:52:53 UTC
Not reproduced in OpenOffice 4.1.3. so the problem wasn't cherrypicked from OOo code
Comment 6 QA Administrators 2019-09-14 02:48:03 UTC Comment hidden (obsolete)
Comment 7 Telesto 2020-05-24 10:24:02 UTC

*** This bug has been marked as a duplicate of bug 60684 ***